Upstream information

CVE-2021-41773 at MITRE

Description

A flaw was found in a change made to path normalization in Apache HTTP Server 2.4.49. An attacker could use a path traversal attack to map URLs to files outside the directories configured by Alias-like directives. If files outside of these directories are not protected by the usual default configuration "require all denied", these requests can succeed. If CGI scripts are also enabled for these aliased pathes, this could allow for remote code execution. This issue is known to be exploited in the wild. This issue only affects Apache 2.4.49 and not earlier versions. The fix in Apache HTTP Server 2.4.50 was found to be incomplete, see CVE-2021-42013.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entries: 1191325 [RESOLVED / FIXED], 1191476 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • apache2 >= 2.4.51-1.1
Patchnames:
openSUSE Tumbleweed GA apache2-2.4.51-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 apache2 Not affected
SUSE CaaS Platform 4.0 apache2 Not affected
SUSE Enterprise Storage 6 apache2 Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 apache2 Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS apache2 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS apache2 Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 apache2 Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 apache2 Not affected
SUSE Linux Enterprise Point of Service 11 SP3 apache2 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS apache2 Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS apache2 Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS apache2 Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS apache2 Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS apache2 Not affected
SUSE Linux Enterprise Server 12 SP5 apache2 Not affected
SUSE Linux Enterprise Server 15 ESPOS apache2 Not affected
SUSE Linux Enterprise Server 15 LTSS apache2 Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS apache2 Not affected
SUSE Linux Enterprise Server BCL 12 SP2 apache2 Not affected
SUSE Linux Enterprise Server BCL 12 SP3 apache2 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 apache2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 apache2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 apache2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 apache2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 apache2 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 apache2 Not affected
SUSE OpenStack Cloud 8 apache2 Not affected
SUSE OpenStack Cloud 9 apache2 Not affected
SUSE OpenStack Cloud Crowbar 8 apache2 Not affected
SUSE OpenStack Cloud Crowbar 9 apache2 Not affected