Upstream information

CVE-2021-41134 at MITRE

Description

nbdime provides tools for diffing and merging of Jupyter Notebooks. In affected versions a stored cross-site scripting (XSS) issue exists within the Jupyter-owned nbdime project. It appears that when reading the file name and path from disk, the extension does not sanitize the string it constructs before returning it to be displayed. The diffNotebookCheckpoint function within nbdime causes this issue. When attempting to display the name of the local notebook (diffNotebookCheckpoint), nbdime appears to simply append .ipynb to the name of the input file. The NbdimeWidget is then created, and the base string is passed through to the request API function. From there, the frontend simply renders the HTML tag and anything along with it. Users are advised to patch to the most recent version of the affected product.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 8.7
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction Required
Scope Changed
Confidentiality Impact High
Integrity Impact High
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1192355 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • jupyter-nbdime >= 6.1.2-8.1
  • jupyter-nbdime-git >= 6.1.2-8.1
  • jupyter-nbdime-hg >= 6.1.2-8.1
  • jupyter-nbdime-jupyterlab >= 2.1.1-8.1
  • python36-nbdime >= 3.1.1-8.1
  • python38-nbdime >= 3.1.1-8.1
  • python39-nbdime >= 3.1.1-8.1
Patchnames:
openSUSE Tumbleweed GA jupyter-nbdime-6.1.2-8.1