Upstream information

CVE-2021-41133 at MITRE

Description

Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. In versions prior to 1.10.4 and 1.12.0, Flatpak apps with direct access to AF_UNIX sockets such as those used by Wayland, Pipewire or pipewire-pulse can trick portals and other host-OS services into treating the Flatpak app as though it was an ordinary, non-sandboxed host-OS process. They can do this by manipulating the VFS using recent mount-related syscalls that are not blocked by Flatpak's denylist seccomp filter, in order to substitute a crafted `/.flatpak-info` or make that file disappear entirely. Flatpak apps that act as clients for AF_UNIX sockets such as those used by Wayland, Pipewire or pipewire-pulse can escalate the privileges that the corresponding services will believe the Flatpak app has. Note that protocols that operate entirely over the D-Bus session bus (user bus), system bus or accessibility bus are not affected by this. This is due to the use of a proxy process `xdg-dbus-proxy`, whose VFS cannot be manipulated by the Flatpak app, when interacting with these buses. Patches exist for versions 1.10.4 and 1.12.0, and as of time of publication, a patch for version 1.8.2 is being planned. There are no workarounds aside from upgrading to a patched version.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 8.8
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entries: 1191507 [NEW], 1191937 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • flatpak >= 1.10.5-4.9.1
  • flatpak-devel >= 1.10.5-4.9.1
  • flatpak-zsh-completion >= 1.10.5-4.9.1
  • libflatpak0 >= 1.10.5-4.9.1
  • system-user-flatpak >= 1.10.5-4.9.1
  • typelib-1_0-Flatpak-1_0 >= 1.10.5-4.9.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-3472
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • flatpak >= 1.10.5-4.9.1
  • flatpak-devel >= 1.10.5-4.9.1
  • flatpak-zsh-completion >= 1.10.5-4.9.1
  • libflatpak0 >= 1.10.5-4.9.1
  • system-user-flatpak >= 1.10.5-4.9.1
  • typelib-1_0-Flatpak-1_0 >= 1.10.5-4.9.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2021-3472
openSUSE Leap 15.2
  • flatpak >= 1.10.5-lp152.3.9.1
  • flatpak-devel >= 1.10.5-lp152.3.9.1
  • flatpak-zsh-completion >= 1.10.5-lp152.3.9.1
  • libflatpak0 >= 1.10.5-lp152.3.9.1
  • system-user-flatpak >= 1.10.5-lp152.3.9.1
  • typelib-1_0-Flatpak-1_0 >= 1.10.5-lp152.3.9.1
Patchnames:
openSUSE-2021-1400
openSUSE Leap 15.3
  • flatpak >= 1.10.5-4.9.1
  • flatpak-devel >= 1.10.5-4.9.1
  • flatpak-zsh-completion >= 1.10.5-4.9.1
  • libflatpak0 >= 1.10.5-4.9.1
  • system-user-flatpak >= 1.10.5-4.9.1
  • typelib-1_0-Flatpak-1_0 >= 1.10.5-4.9.1
Patchnames:
openSUSE-SLE-15.3-2021-3472
openSUSE Tumbleweed
  • flatpak >= 1.12.1-1.1
  • flatpak-devel >= 1.12.1-1.1
  • flatpak-zsh-completion >= 1.12.1-1.1
  • libflatpak0 >= 1.12.1-1.1
  • system-user-flatpak >= 1.12.1-1.1
  • typelib-1_0-Flatpak-1_0 >= 1.12.1-1.1
Patchnames:
openSUSE Tumbleweed GA flatpak-1.12.1-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 flatpak Affected
SUSE CaaS Platform 4.5 flatpak Released
SUSE Enterprise Storage 6 flatpak Affected
SUSE Enterprise Storage 7 flatpak Released
SUSE Linux Enterprise High Performance Computing 15 LTSS flatpak Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS flatpak Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS flatpak Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS flatpak Released
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS flatpak Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 flatpak Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 flatpak Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 flatpak Already fixed
SUSE Linux Enterprise Real Time 15 SP2 flatpak Released
SUSE Linux Enterprise Server 15 ESPOS flatpak Affected
SUSE Linux Enterprise Server 15 LTSS flatpak Affected
SUSE Linux Enterprise Server 15 SP1 LTSS flatpak Affected
SUSE Linux Enterprise Server 15 SP2 LTSS flatpak Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 flatpak Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 flatpak Released
SUSE Linux Enterprise Server for SAP Applications 15 flatpak Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 flatpak Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 flatpak Released
SUSE Manager Proxy 4.1 flatpak Released
SUSE Manager Retail Branch Server 4.1 flatpak Released
SUSE Manager Server 4.1 flatpak Released