Upstream information

CVE-2021-3778 at MITRE

Description

vim is vulnerable to Heap-based Buffer Overflow

SUSE information

Overall state of this security issue: Revisit

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.3
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Local Local
Access Complexity Low Low
Privileges Required None Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1190533 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 vim Affected
SUSE CaaS Platform 4.0 vim Affected
SUSE Enterprise Storage 6 vim Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 vim Affected
SUSE Linux Enterprise High Performance Computing 15 LTSS vim Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS vim Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS vim Affected
SUSE Linux Enterprise Micro 5.0 vim Affected
SUSE Linux Enterprise Micro 5.1 vim Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 vim Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 vim Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 vim Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 vim Affected
SUSE Linux Enterprise Point of Service 11 SP3 vim Not affected
SUSE Linux Enterprise Server 11 SP1 vim Analysis
SUSE Linux Enterprise Server 11 SP3 vim Analysis
SUSE Linux Enterprise Server 11 SP4 vim Analysis
SUSE Linux Enterprise Server 11 SP4 LTSS vim Not affected
SUSE Linux Enterprise Server 12 SP3 ESPOS vim Affected
SUSE Linux Enterprise Server 12 SP3 LTSS vim Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS vim Affected
SUSE Linux Enterprise Server 12 SP4 LTSS vim Affected
SUSE Linux Enterprise Server 12 SP5 vim Affected
SUSE Linux Enterprise Server 15 ESPOS vim Affected
SUSE Linux Enterprise Server 15 LTSS vim Affected
SUSE Linux Enterprise Server 15 SP1 LTSS vim Affected
SUSE Linux Enterprise Server BCL 12 SP2 vim Affected
SUSE Linux Enterprise Server BCL 12 SP3 vim Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 vim Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 vim Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 vim Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 vim Affected
SUSE Linux Enterprise Server for SAP Applications 15 vim Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 vim Affected
SUSE OpenStack Cloud 8 vim Affected
SUSE OpenStack Cloud 9 vim Affected
SUSE OpenStack Cloud Crowbar 8 vim Affected
SUSE OpenStack Cloud Crowbar 9 vim Affected