Upstream information

CVE-2021-23437 at MITRE

Description

The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1190229 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • python-Pillow >= 4.2.1-3.20.2
Patchnames:
HPE-Helion-OpenStack-8-2021-3234
SUSE OpenStack Cloud 8
  • python-Pillow >= 4.2.1-3.20.2
Patchnames:
SUSE-OpenStack-Cloud-8-2021-3234
SUSE OpenStack Cloud 9
  • python-Pillow >= 5.2.0-3.14.1
Patchnames:
SUSE-OpenStack-Cloud-9-2021-3235
SUSE OpenStack Cloud Crowbar 8
  • python-Pillow >= 4.2.1-3.20.2
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-3234
SUSE OpenStack Cloud Crowbar 9
  • python-Pillow >= 5.2.0-3.14.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-3235
openSUSE Tumbleweed
  • python36-Pillow >= 8.3.2-1.2
  • python36-Pillow-tk >= 8.3.2-1.2
  • python38-Pillow >= 8.3.2-1.2
  • python38-Pillow-tk >= 8.3.2-1.2
  • python39-Pillow >= 8.3.2-1.2
  • python39-Pillow-tk >= 8.3.2-1.2
Patchnames:
openSUSE Tumbleweed GA python36-Pillow-8.3.2-1.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 python-Pillow Released
SUSE OpenStack Cloud 8 python-Pillow Released
SUSE OpenStack Cloud 9 python-Pillow Released
SUSE OpenStack Cloud Crowbar 8 python-Pillow Released
SUSE OpenStack Cloud Crowbar 9 python-Pillow Released