Upstream information

CVE-2021-23556 at MITRE


The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6
Vector AV:N/AC:M/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8 6.4
Attack Vector Network Network
Attack Complexity Low High
Privileges Required Low Low
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1197256 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP4
  • guake >= 3.8.1-bp154.2.3.1
  • guake-lang >= 3.8.1-bp154.2.3.1
openSUSE Leap 15.4
  • guake >= 3.8.1-bp154.2.3.1
  • guake-lang >= 3.8.1-bp154.2.3.1

SUSE Timeline for this CVE

CVE page created: Thu Mar 17 17:21:04 2022
CVE page last modified: Tue Apr 11 17:52:50 2023