Upstream information

CVE-2021-21148 at MITRE

Description

Heap buffer overflow in V8 in Google Chrome prior to 88.0.4324.150 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1181827 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Web Scripting 15 SP3
  • nodejs14 >= 14.16.0-5.9.1
  • nodejs14-devel >= 14.16.0-5.9.1
  • nodejs14-docs >= 14.16.0-5.9.1
  • npm14 >= 14.16.0-5.9.1
SUSE Package Hub for SUSE Linux Enterprise 15 SP2
  • chromedriver >= 88.0.4324.150-bp152.2.59.1
  • chromium >= 88.0.4324.150-bp152.2.59.1
  • libQt5Pdf5 >= 5.15.3-bp152.3.3.1
  • libQt5PdfWidgets5 >= 5.15.3-bp152.3.3.1
  • libqt5-qtpdf-devel >= 5.15.3-bp152.3.3.1
  • libqt5-qtpdf-examples >= 5.15.3-bp152.3.3.1
  • libqt5-qtpdf-imports >= 5.15.3-bp152.3.3.1
  • libqt5-qtpdf-private-headers-devel >= 5.15.3-bp152.3.3.1
  • libqt5-qtwebengine >= 5.15.3-bp152.3.3.1
  • libqt5-qtwebengine-devel >= 5.15.3-bp152.3.3.1
  • libqt5-qtwebengine-examples >= 5.15.3-bp152.3.3.1
  • libqt5-qtwebengine-private-headers-devel >= 5.15.3-bp152.3.3.1
Patchnames:
openSUSE-2021-1016
openSUSE-2021-276
openSUSE Leap 15.2
  • chromedriver >= 88.0.4324.150-lp152.2.72.1
  • chromium >= 88.0.4324.150-lp152.2.72.1
  • libQt5Pdf5 >= 5.15.3-lp152.3.3.4
  • libQt5PdfWidgets5 >= 5.15.3-lp152.3.3.4
  • libqt5-qtpdf-devel >= 5.15.3-lp152.3.3.4
  • libqt5-qtpdf-examples >= 5.15.3-lp152.3.3.4
  • libqt5-qtpdf-imports >= 5.15.3-lp152.3.3.4
  • libqt5-qtpdf-private-headers-devel >= 5.15.3-lp152.3.3.4
  • libqt5-qtwebengine >= 5.15.3-lp152.3.3.4
  • libqt5-qtwebengine-devel >= 5.15.3-lp152.3.3.4
  • libqt5-qtwebengine-examples >= 5.15.3-lp152.3.3.4
  • libqt5-qtwebengine-private-headers-devel >= 5.15.3-lp152.3.3.4
Patchnames:
openSUSE-2021-267
openSUSE-2021-973
openSUSE Leap 15.2 NonFree
  • opera >= 74.0.3911.203-lp152.2.37.1
Patchnames:
openSUSE-2021-296
openSUSE-2021-413
openSUSE Tumbleweed
  • chromedriver >= 93.0.4577.82-1.1
  • chromium >= 93.0.4577.82-1.1
  • libQt5Pdf5 >= 5.15.6-2.1
  • libQt5PdfWidgets5 >= 5.15.6-2.1
  • libqt5-qtpdf-devel >= 5.15.6-2.1
  • libqt5-qtpdf-examples >= 5.15.6-2.1
  • libqt5-qtpdf-imports >= 5.15.6-2.1
  • libqt5-qtpdf-private-headers-devel >= 5.15.6-2.1
  • libqt5-qtwebengine >= 5.15.6-2.1
  • libqt5-qtwebengine-devel >= 5.15.6-2.1
  • libqt5-qtwebengine-examples >= 5.15.6-2.1
  • libqt5-qtwebengine-private-headers-devel >= 5.15.6-2.1
  • nodejs14 >= 14.17.5-1.2
  • nodejs14-devel >= 14.17.5-1.2
  • nodejs14-docs >= 14.17.5-1.2
  • npm14 >= 14.17.5-1.2
Patchnames:
openSUSE Tumbleweed GA chromedriver-93.0.4577.82-1.1
openSUSE Tumbleweed GA libQt5Pdf5-5.15.6-2.1
openSUSE Tumbleweed GA nodejs14-14.17.5-1.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs14 In progress
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 nodejs12 In progress
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 nodejs14 In progress
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 nodejs8 In progress