Upstream information

CVE-2020-8552 at MITRE

Description

The Kubernetes API server component in versions prior to 1.15.9, 1.16.0-1.16.6, and 1.17.0-1.17.2 has been found to be vulnerable to a denial of service attack via successful API requests.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 4.3
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1167508 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration kubernetes Unsupported
SUSE CaaS Platform 3.0 kubernetes Unsupported
SUSE CaaS Platform 4.0 kubernetes Already fixed
SUSE Container as a Service Platform 1.0 kubernetes Affected
SUSE Container as a Service Platform 2.0 kubernetes Unsupported
SUSE Linux Enterprise High Performance Computing 12 kubernetes Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 kubernetes Already fixed
SUSE Linux Enterprise Module for Containers 15 SP1 kubernetes Already fixed
SUSE Linux Enterprise Module for Public Cloud 12 kubernetes Not affected
SUSE Linux Enterprise Server 12 kubernetes Not affected
SUSE Linux Enterprise Server 12 SP3 kubernetes Not affected
SUSE Linux Enterprise Server 12 SP4 kubernetes Not affected
SUSE Linux Enterprise Server 12 SP5 kubernetes Not affected
SUSE Linux Enterprise Server 15 SP1 kubernetes Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 kubernetes Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 kubernetes Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 kubernetes Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 kubernetes Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 kubernetes Already fixed
SUSE Linux Enterprise Storage 6 kubernetes Already fixed
SUSE Manager Proxy 4.0 kubernetes Already fixed
SUSE Manager Retail Branch Server 4.0 kubernetes Already fixed
SUSE Manager Server 4.0 kubernetes Already fixed