Upstream information

CVE-2020-17525 at MITRE

Description

Subversion's mod_authz_svn module will crash if the server is using in-repository authz rules with the AuthzSVNReposRelativeAccessFile option and a client sends a request for a non-existing repository URL. This can lead to disruption for users of the service. This issue was fixed in mod_dav_svn+mod_authz_svn servers 1.14.1 and mod_dav_svn+mod_authz_svn servers 1.10.7

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1181687 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 4.0
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-425
SUSE Enterprise Storage 6
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-Storage-6-2021-425
SUSE Linux Enterprise Desktop 15 SP2
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-425
SUSE-SLE-Module-Development-Tools-15-SP2-2021-425
SUSE Linux Enterprise Desktop 15 SP3
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA subversion-1.10.6-3.15.1
SUSE Linux Enterprise Module for Development Tools 15 SP3 GA subversion-bash-completion-1.10.6-3.15.1
SUSE Linux Enterprise Desktop 15 SP4
  • subversion >= 1.14.1-150400.3.8
  • subversion-bash-completion >= 1.14.1-150400.3.8
  • subversion-devel >= 1.14.1-150400.3.8
  • subversion-perl >= 1.14.1-150400.3.8
  • subversion-python >= 1.14.1-150400.3.8
  • subversion-tools >= 1.14.1-150400.3.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA subversion-1.14.1-150400.3.8
SUSE Linux Enterprise Module for Development Tools 15 SP4 GA subversion-bash-completion-1.14.1-150400.3.8
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-425
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-425
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Linux Enterprise Storage 7
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-425
SUSE-SLE-Module-Development-Tools-15-SP2-2021-425
SUSE-SLE-Module-Server-Applications-15-SP2-2021-425
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Linux Enterprise Storage 7.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA subversion-1.10.6-3.15.1
SUSE Linux Enterprise Module for Development Tools 15 SP3 GA subversion-bash-completion-1.10.6-3.15.1
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA subversion-server-1.10.6-3.15.1
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • subversion >= 1.14.1-150400.3.8
  • subversion-bash-completion >= 1.14.1-150400.3.8
  • subversion-devel >= 1.14.1-150400.3.8
  • subversion-perl >= 1.14.1-150400.3.8
  • subversion-python >= 1.14.1-150400.3.8
  • subversion-server >= 1.14.1-150400.3.8
  • subversion-tools >= 1.14.1-150400.3.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA subversion-1.14.1-150400.3.8
SUSE Linux Enterprise Module for Development Tools 15 SP4 GA subversion-bash-completion-1.14.1-150400.3.8
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA subversion-server-1.14.1-150400.3.8
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-425
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • subversion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-425
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • subversion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA subversion-1.10.6-3.15.1
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • subversion >= 1.14.1-150400.3.8
  • subversion-devel >= 1.14.1-150400.3.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA subversion-1.14.1-150400.3.8
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2021-425
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP3 GA subversion-bash-completion-1.10.6-3.15.1
SUSE Linux Enterprise Module for Development Tools 15 SP4
  • subversion-bash-completion >= 1.14.1-150400.3.8
  • subversion-perl >= 1.14.1-150400.3.8
  • subversion-python >= 1.14.1-150400.3.8
  • subversion-tools >= 1.14.1-150400.3.8
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP4 GA subversion-bash-completion-1.14.1-150400.3.8
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • subversion-server >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2021-425
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • subversion-server >= 1.10.6-3.15.1
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA subversion-server-1.10.6-3.15.1
SUSE Linux Enterprise Module for Server Applications 15 SP4
  • subversion-server >= 1.14.1-150400.3.8
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA subversion-server-1.14.1-150400.3.8
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libsvn_auth_gnome_keyring-1-0 >= 1.10.6-3.3.1
  • subversion >= 1.10.6-3.3.1
  • subversion-bash-completion >= 1.10.6-3.3.1
  • subversion-devel >= 1.10.6-3.3.1
  • subversion-perl >= 1.10.6-3.3.1
  • subversion-python >= 1.10.6-3.3.1
  • subversion-server >= 1.10.6-3.3.1
  • subversion-tools >= 1.10.6-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2021-424
SUSE Linux Enterprise Server 15 SP1-BCL
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-425
SUSE Linux Enterprise Server 15 SP1-LTSS
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-425
SUSE Linux Enterprise Server 15-LTSS
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-425
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-425
SUSE Linux Enterprise Server for SAP Applications 15
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-425
SUSE Manager Proxy 4.0
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-425
SUSE Manager Retail Branch Server 4.0
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-425
SUSE Manager Server 4.0
  • subversion >= 1.10.6-3.15.1
  • subversion-bash-completion >= 1.10.6-3.15.1
  • subversion-devel >= 1.10.6-3.15.1
  • subversion-perl >= 1.10.6-3.15.1
  • subversion-python >= 1.10.6-3.15.1
  • subversion-server >= 1.10.6-3.15.1
  • subversion-tools >= 1.10.6-3.15.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-425
openSUSE Leap 15.2
  • libsvn_auth_gnome_keyring-1-0 >= 1.10.6-lp152.2.9.1
  • libsvn_auth_kwallet-1-0 >= 1.10.6-lp152.2.9.1
  • subversion >= 1.10.6-lp152.2.9.1
  • subversion-bash-completion >= 1.10.6-lp152.2.9.1
  • subversion-devel >= 1.10.6-lp152.2.9.1
  • subversion-perl >= 1.10.6-lp152.2.9.1
  • subversion-python >= 1.10.6-lp152.2.9.1
  • subversion-python-ctypes >= 1.10.6-lp152.2.9.1
  • subversion-ruby >= 1.10.6-lp152.2.9.1
  • subversion-server >= 1.10.6-lp152.2.9.1
  • subversion-tools >= 1.10.6-lp152.2.9.1
Patchnames:
openSUSE-2021-280
openSUSE Tumbleweed
  • libsvn_auth_gnome_keyring-1-0 >= 1.14.1-1.11
  • libsvn_auth_kwallet-1-0 >= 1.14.1-1.11
  • subversion >= 1.14.1-1.11
  • subversion-bash-completion >= 1.14.1-1.11
  • subversion-devel >= 1.14.1-1.11
  • subversion-perl >= 1.14.1-1.11
  • subversion-python >= 1.14.1-1.11
  • subversion-ruby >= 1.14.1-1.11
  • subversion-server >= 1.14.1-1.11
  • subversion-tools >= 1.14.1-1.11
Patchnames:
openSUSE Tumbleweed GA libsvn_auth_gnome_keyring-1-0-1.14.1-1.11


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 subversion Released
SUSE Enterprise Storage 6 subversion Released
SUSE Linux Enterprise Desktop 15 SP1 subversion Released
SUSE Linux Enterprise Desktop 15 SP2 subversion Released
SUSE Linux Enterprise High Performance Computing 15 LTSS subversion Released
SUSE Linux Enterprise High Performance Computing 15 SP1 subversion Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS subversion Released
SUSE Linux Enterprise High Performance Computing 15 SP2 subversion Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 subversion Released
SUSE Linux Enterprise Module for Basesystem 15 SP2 subversion Released
SUSE Linux Enterprise Module for Development Tools 15 SP1 subversion Released
SUSE Linux Enterprise Module for Development Tools 15 SP2 subversion Released
SUSE Linux Enterprise Module for Server Applications 15 SP1 subversion Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 subversion Released
SUSE Linux Enterprise Server 15 ESPOS subversion Released
SUSE Linux Enterprise Server 15 LTSS subversion Released
SUSE Linux Enterprise Server 15 SP1 subversion Released
SUSE Linux Enterprise Server 15 SP1 LTSS subversion Released
SUSE Linux Enterprise Server 15 SP2 subversion Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 subversion Released
SUSE Linux Enterprise Server for SAP Applications 15 subversion Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 subversion Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 subversion Released
SUSE Linux Enterprise Storage 6 subversion Released
SUSE Linux Enterprise Storage 7 subversion Released
SUSE Manager Proxy 4.0 subversion Released
SUSE Manager Proxy 4.1 subversion Released
SUSE Manager Retail Branch Server 4.0 subversion Released
SUSE Manager Retail Branch Server 4.1 subversion Released
SUSE Manager Server 4.0 subversion Released
SUSE Manager Server 4.1 subversion Released