Upstream information

CVE-2020-17521 at MITRE

Description

Apache Groovy provides extension methods to aid with creating temporary directories. Prior to this fix, Groovy's implementation of those extension methods was using a now superseded Java JDK method call that is potentially not secure on some operating systems in some contexts. Users not using the extension methods mentioned in the advisory are not affected, but may wish to read the advisory for further details. Versions Affected: 2.0 to 2.4.20, 2.5.0 to 2.5.13, 3.0.0 to 3.0.6, and 4.0.0-alpha-1. Fixed in versions 2.4.21, 2.5.14, 3.0.7, 4.0.0-alpha-2.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.5 5.5
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Access Vector Local Local
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1179729 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • groovy-lib >= 2.4.21-3.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2020-3917
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • groovy >= 2.4.21-3.3.2
  • groovy-ant >= 2.4.21-3.3.2
  • groovy-bsf >= 2.4.21-3.3.2
  • groovy-console >= 2.4.21-3.3.2
  • groovy-docgenerator >= 2.4.21-3.3.2
  • groovy-groovydoc >= 2.4.21-3.3.2
  • groovy-groovysh >= 2.4.21-3.3.2
  • groovy-jmx >= 2.4.21-3.3.2
  • groovy-json >= 2.4.21-3.3.2
  • groovy-jsr223 >= 2.4.21-3.3.2
  • groovy-nio >= 2.4.21-3.3.2
  • groovy-servlet >= 2.4.21-3.3.2
  • groovy-sql >= 2.4.21-3.3.2
  • groovy-swing >= 2.4.21-3.3.2
  • groovy-templates >= 2.4.21-3.3.2
  • groovy-test >= 2.4.21-3.3.2
  • groovy-testng >= 2.4.21-3.3.2
  • groovy-xml >= 2.4.21-3.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-3917
openSUSE Leap 15.2
  • groovy >= 2.4.21-lp152.2.3.2
  • groovy-ant >= 2.4.21-lp152.2.3.2
  • groovy-bsf >= 2.4.21-lp152.2.3.2
  • groovy-console >= 2.4.21-lp152.2.3.2
  • groovy-docgenerator >= 2.4.21-lp152.2.3.2
  • groovy-groovydoc >= 2.4.21-lp152.2.3.2
  • groovy-groovysh >= 2.4.21-lp152.2.3.2
  • groovy-jmx >= 2.4.21-lp152.2.3.2
  • groovy-json >= 2.4.21-lp152.2.3.2
  • groovy-jsr223 >= 2.4.21-lp152.2.3.2
  • groovy-lib >= 2.4.21-lp152.2.3.2
  • groovy-nio >= 2.4.21-lp152.2.3.2
  • groovy-servlet >= 2.4.21-lp152.2.3.2
  • groovy-sql >= 2.4.21-lp152.2.3.2
  • groovy-swing >= 2.4.21-lp152.2.3.2
  • groovy-templates >= 2.4.21-lp152.2.3.2
  • groovy-test >= 2.4.21-lp152.2.3.2
  • groovy-testng >= 2.4.21-lp152.2.3.2
  • groovy-xml >= 2.4.21-lp152.2.3.2
Patchnames:
openSUSE-2020-2367


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Development Tools 15 SP2 groovy Released