Upstream information

CVE-2019-3885 at MITRE

Description

A use-after-free flaw was found in pacemaker up to and including version 2.0.1 which could result in certain sensitive information to be leaked via the system logs.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1131357 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 12 SP4
  • libpacemaker3 >= 1.1.19+20181105.ccd6b5b10-3.10.1
  • pacemaker >= 1.1.19+20181105.ccd6b5b10-3.10.1
  • pacemaker-cli >= 1.1.19+20181105.ccd6b5b10-3.10.1
  • pacemaker-cts >= 1.1.19+20181105.ccd6b5b10-3.10.1
  • pacemaker-remote >= 1.1.19+20181105.ccd6b5b10-3.10.1
Patchnames:
SUSE-SLE-HA-12-SP4-2019-1047
SUSE Linux Enterprise High Availability 12 SP5
  • libpacemaker3 >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-cli >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-cts >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-remote >= 1.1.21+20190809.bf34b44fa-1.17
SUSE Linux Enterprise High Availability 15 SP1
  • libpacemaker-devel >= 2.0.1+20190417.13d370ca9-1.2
  • libpacemaker3 >= 2.0.1+20190417.13d370ca9-1.2
  • pacemaker >= 2.0.1+20190417.13d370ca9-1.2
  • pacemaker-cli >= 2.0.1+20190417.13d370ca9-1.2
  • pacemaker-cts >= 2.0.1+20190417.13d370ca9-1.2
  • pacemaker-remote >= 2.0.1+20190417.13d370ca9-1.2
SUSE Linux Enterprise High Availability 15
  • libpacemaker-devel >= 1.1.18+20180430.b12c320f5-3.9.4
  • libpacemaker3 >= 1.1.18+20180430.b12c320f5-3.9.4
  • pacemaker >= 1.1.18+20180430.b12c320f5-3.9.4
  • pacemaker-cli >= 1.1.18+20180430.b12c320f5-3.9.4
  • pacemaker-cts >= 1.1.18+20180430.b12c320f5-3.9.4
  • pacemaker-remote >= 1.1.18+20180430.b12c320f5-3.9.4
Patchnames:
SUSE-SLE-Product-HA-15-2019-1209
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libpacemaker-devel >= 1.1.19+20181105.ccd6b5b10-3.10.1
  • pacemaker-cts >= 1.1.19+20181105.ccd6b5b10-3.10.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1047
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libpacemaker-devel >= 1.1.21+20190809.bf34b44fa-1.17
  • pacemaker-cts >= 1.1.21+20190809.bf34b44fa-1.17
openSUSE Leap 15.0
  • libpacemaker-devel >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • libpacemaker3 >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • libpacemaker3-debuginfo >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker-cli >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker-cli-debuginfo >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker-cts >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker-debuginfo >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker-debugsource >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker-remote >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
  • pacemaker-remote-debuginfo >= 1.1.18+20180430.b12c320f5-lp150.2.9.1
Patchnames:
openSUSE-2019-1400


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications pacemaker Unsupported
SUSE Linux Enterprise High Availability Extension 11 SP4 pacemaker Affected
SUSE Linux Enterprise High Availability Extension 12 pacemaker Unsupported
SUSE Linux Enterprise High Availability Extension 12 SP2 pacemaker Unsupported
SUSE Linux Enterprise High Availability Extension 12 SP3 pacemaker Not affected
SUSE Linux Enterprise High Availability Extension 12 SP4 pacemaker Released
SUSE Linux Enterprise High Availability Extension 12 SP5 pacemaker Already fixed
SUSE Linux Enterprise High Availability Extension 15 pacemaker Released
SUSE Linux Enterprise High Availability Extension 15 SP1 pacemaker Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 pacemaker Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP1 pacemaker Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 pacemaker Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 pacemaker Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 pacemaker Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP3 pacemaker Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP4 pacemaker Released