Upstream information

CVE-2019-13115 at MITRE

Description

In libssh2 before 1.9.0, kex_method_diffie_hellman_group_exchange_sha256_key_exchange in kex.c has an integer overflow that could lead to an out-of-bounds read in the way packets are read from the server. A remote attacker who compromises a SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server. This is related to an _libssh2_check_length mistake, and is different from the various issues fixed in 1.8.1, such as CVE-2019-3855.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 6.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None High
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact None High
Availability Impact High None
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1141850 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
Magnum Orchestration libssh2_org Not affected
SLES for SAP Applications libssh2_org Not affected
SUSE CaaS Platform 3.0 libssh2_org Not affected
SUSE CaaS Platform 4.5 libssh2_org Not affected
SUSE Container as a Service Platform 1.0 libssh2_org Affected
SUSE Container as a Service Platform 2.0 libssh2_org Not affected
SUSE Enterprise Storage 7 libssh2_org Not affected
SUSE Linux Enterprise Desktop 12 SP3 libssh2_org Not affected
SUSE Linux Enterprise Desktop 12 SP4 libssh2_org Not affected
SUSE Linux Enterprise Desktop 15 libssh2_org Not affected
SUSE Linux Enterprise Desktop 15 SP1 libssh2_org Not affected
SUSE Linux Enterprise Desktop 15 SP3 libssh2_org Not affected
SUSE Linux Enterprise Desktop 15 SP4 libssh2_org Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 libssh2_org Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libssh2_org Not affected
SUSE Linux Enterprise High Performance Computing 15 libssh2_org Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 libssh2_org Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 ESPOS libssh2_org Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ESPOS libssh2_org Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS libssh2_org Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 libssh2_org Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 libssh2_org Not affected
SUSE Linux Enterprise Micro 5.0 libssh2_org Not affected
SUSE Linux Enterprise Micro 5.1 libssh2_org Not affected
SUSE Linux Enterprise Micro 5.2 libssh2_org Not affected
SUSE Linux Enterprise Module for Basesystem 15 libssh2_org Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 libssh2_org Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 libssh2_org Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 libssh2_org Not affected
SUSE Linux Enterprise Real Time 15 SP2 libssh2_org Not affected
SUSE Linux Enterprise Server 11 SP1 libssh2_org Unsupported
SUSE Linux Enterprise Server 11 SP3 libssh2_org Unsupported
SUSE Linux Enterprise Server 11 SP3 LTSS libssh2_org Not affected
SUSE Linux Enterprise Server 12 LTSS libssh2_org Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS libssh2_org Not affected
SUSE Linux Enterprise Server 12 SP2 BCL libssh2_org Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS libssh2_org Not affected
SUSE Linux Enterprise Server 12 SP3 libssh2_org Not affected
SUSE Linux Enterprise Server 12 SP3 BCL libssh2_org Not affected
SUSE Linux Enterprise Server 12 SP4 libssh2_org Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS libssh2_org Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS libssh2_org Not affected
SUSE Linux Enterprise Server 12 SP5 libssh2_org Not affected
SUSE Linux Enterprise Server 15 libssh2_org Not affected
SUSE Linux Enterprise Server 15 SP1 libssh2_org Not affected
SUSE Linux Enterprise Server 15 SP2 LTSS libssh2_org Not affected
SUSE Linux Enterprise Server 15 SP3 libssh2_org Not affected
SUSE Linux Enterprise Server 15 SP4 libssh2_org Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libssh2_org Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libssh2_org Not affected
SUSE Linux Enterprise Server for SAP Applications 12 libssh2_org Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libssh2_org Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libssh2_org Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libssh2_org Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libssh2_org Not affected
SUSE Linux Enterprise Server for SAP Applications 15 libssh2_org Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libssh2_org Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libssh2_org Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libssh2_org Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libssh2_org Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libssh2_org Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libssh2_org Not affected
SUSE Linux Enterprise Storage 6 libssh2_org Not affected
SUSE Linux Enterprise Storage 7.1 libssh2_org Not affected
SUSE Manager Proxy 4.0 libssh2_org Not affected
SUSE Manager Proxy 4.1 libssh2_org Not affected
SUSE Manager Proxy 4.2 libssh2_org Not affected
SUSE Manager Proxy 4.3 libssh2_org Not affected
SUSE Manager Retail Branch Server 4.0 libssh2_org Not affected
SUSE Manager Retail Branch Server 4.1 libssh2_org Not affected
SUSE Manager Retail Branch Server 4.2 libssh2_org Not affected
SUSE Manager Retail Branch Server 4.3 libssh2_org Not affected
SUSE Manager Server 4.0 libssh2_org Not affected
SUSE Manager Server 4.1 libssh2_org Not affected
SUSE Manager Server 4.2 libssh2_org Not affected
SUSE Manager Server 4.3 libssh2_org Not affected
SUSE OpenStack Cloud 9 libssh2_org Not affected
SUSE OpenStack Cloud Crowbar 9 libssh2_org Not affected