Upstream information

CVE-2019-12779 at MITRE

Description

libqb before 1.0.5 allows local users to overwrite arbitrary files via a symlink attack, because it uses predictable filenames (under /dev/shm and /tmp) without O_EXCL.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.6
Vector AV:L/AC:L/Au:N/C:N/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.1 6.5
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Changed
Confidentiality Impact None None
Integrity Impact High High
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1137835 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Image SLES12-SP4-SAP-Azure
Image SLES12-SP4-SAP-Azure-BYOS
Image SLES12-SP4-SAP-Azure-LI-BYOS-Production
Image SLES12-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES12-SP4-SAP-EC2-HVM
Image SLES12-SP4-SAP-EC2-HVM-BYOS
Image SLES12-SP4-SAP-GCE
Image SLES12-SP4-SAP-GCE-BYOS
Image SLES12-SP4-SAP-OCI-BYOS
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-Azure-SAP-On-Demand
Image SLES12-SP5-EC2-SAP-BYOS
Image SLES12-SP5-EC2-SAP-On-Demand
Image SLES12-SP5-GCE-SAP-BYOS
Image SLES12-SP5-GCE-SAP-On-Demand
Image SLES12-SP5-OCI-BYOS-SAP-BYOS
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • libdlm >= 4.0.7-3.3.2
  • libdlm3 >= 4.0.7-3.3.2
  • libqb0 >= 1.0.3+20171226.6d62b64-4.3.1
Image SLES15-SAP-Azure
Image SLES15-SAP-Azure-BYOS
Image SLES15-SAP-Azure-LI-BYOS-Production
Image SLES15-SAP-Azure-VLI-BYOS-Production
Image SLES15-SAP-EC2-HVM
Image SLES15-SAP-EC2-HVM-BYOS
Image SLES15-SAP-GCE
Image SLES15-SAP-GCE-BYOS
Image SLES15-SAP-OCI-BYOS
  • libqb0 >= 1.0.3+20171226.6d62b64-3.3.1
Image SLES15-SP1-SAP-Azure
Image SLES15-SP1-SAP-Azure-BYOS
Image SLES15-SP1-SAP-Azure-LI-BYOS-Production
Image SLES15-SP1-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP1-SAP-EC2-HVM
Image SLES15-SP1-SAP-EC2-HVM-BYOS
Image SLES15-SP1-SAP-GCE
Image SLES15-SP1-SAP-GCE-BYOS
Image SLES15-SP1-SAP-OCI-BYOS
Image SLES15-SP2-SAP-Azure
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP2-SAP-BYOS-Azure
Image SLES15-SP2-SAP-BYOS-EC2-HVM
Image SLES15-SP2-SAP-BYOS-GCE
Image SLES15-SP2-SAP-EC2-HVM
Image SLES15-SP2-SAP-GCE
  • libqb20 >= 1.0.3+20190326.a521604-3.3.1
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libdlm-devel >= 4.0.7-3.3.2
  • libqb-devel >= 1.0.3+20171226.6d62b64-4.3.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1806
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libqb-devel >= 2.0.4+20211112.a2691b9-150400.2.4
  • libqb100 >= 2.0.4+20211112.a2691b9-150400.2.4
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA libqb-devel-2.0.4+20211112.a2691b9-150400.2.4
SUSE Linux Enterprise High Availability 12 SP3
SUSE Linux Enterprise High Performance Computing 12 SP3
SUSE Linux Enterprise Server 12 SP3
  • libdlm >= 4.0.7-3.3.2
  • libdlm3 >= 4.0.7-3.3.2
  • libqb0 >= 1.0.3+20171226.6d62b64-4.3.1
Patchnames:
SUSE-SLE-HA-12-SP3-2019-1806
SUSE Linux Enterprise High Availability 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP4
  • libdlm >= 4.0.7-3.3.2
  • libdlm3 >= 4.0.7-3.3.2
  • libqb0 >= 1.0.3+20171226.6d62b64-4.3.1
Patchnames:
SUSE-SLE-HA-12-SP4-2019-1806
SUSE Linux Enterprise High Availability 12 SP5
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libqb0 >= 1.0.3+20171226.6d62b64-4.3.1
Patchnames:
SUSE Linux Enterprise High Availability 12 SP5 GA libqb0-1.0.3+20171226.6d62b64-4.3.1
SUSE Linux Enterprise High Availability 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libqb-devel >= 1.0.3+20190326.a521604-3.3.1
  • libqb-tests >= 1.0.3+20190326.a521604-3.3.1
  • libqb-tools >= 1.0.3+20190326.a521604-3.3.1
  • libqb20 >= 1.0.3+20190326.a521604-3.3.1
Patchnames:
SUSE-SLE-Product-HA-15-SP1-2019-1791
SUSE Linux Enterprise High Availability 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libqb-devel >= 1.0.3+20171226.6d62b64-3.3.1
  • libqb0 >= 1.0.3+20171226.6d62b64-3.3.1
Patchnames:
SUSE-SLE-Product-HA-15-2019-1812
SUSE Linux Enterprise Server 12 SP4
  • libdlm >= 4.0.7-3.3.2
  • libdlm-devel >= 4.0.7-3.3.2
  • libdlm3 >= 4.0.7-3.3.2
  • libqb-devel >= 1.0.3+20171226.6d62b64-4.3.1
  • libqb0 >= 1.0.3+20171226.6d62b64-4.3.1
Patchnames:
SUSE-SLE-HA-12-SP4-2019-1806
SUSE-SLE-SDK-12-SP4-2019-1806
SUSE Linux Enterprise Server 12 SP5
  • libqb-devel >= 1.0.3+20171226.6d62b64-4.3.1
  • libqb0 >= 1.0.3+20171226.6d62b64-4.3.1
Patchnames:
SUSE Linux Enterprise High Availability 12 SP5 GA libqb0-1.0.3+20171226.6d62b64-4.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libqb-devel-1.0.3+20171226.6d62b64-4.3.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libqb-devel >= 1.0.3+20171226.6d62b64-4.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libqb-devel-1.0.3+20171226.6d62b64-4.3.1
SUSE Package Hub 15 SP1
  • libqb-devel >= 1.0.3+20190326.a521604-bp151.2.3.1
  • libqb-devel-64bit >= 1.0.3+20190326.a521604-bp151.2.3.1
  • libqb-tests >= 1.0.3+20190326.a521604-bp151.2.3.1
  • libqb-tools >= 1.0.3+20190326.a521604-bp151.2.3.1
  • libqb20 >= 1.0.3+20190326.a521604-bp151.2.3.1
  • libqb20-64bit >= 1.0.3+20190326.a521604-bp151.2.3.1
Patchnames:
openSUSE-2019-1891
openSUSE Leap 15.0
  • libqb-devel >= 1.0.3+20171226.6d62b64-lp150.2.3.1
  • libqb-devel-32bit >= 1.0.3+20171226.6d62b64-lp150.2.3.1
  • libqb0 >= 1.0.3+20171226.6d62b64-lp150.2.3.1
  • libqb0-32bit >= 1.0.3+20171226.6d62b64-lp150.2.3.1
Patchnames:
openSUSE-2019-1718
openSUSE Leap 15.1
  • libqb-devel >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb-devel-32bit >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb-tests >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb-tools >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb20 >= 1.0.3+20190326.a521604-lp151.2.3.1
  • libqb20-32bit >= 1.0.3+20190326.a521604-lp151.2.3.1
Patchnames:
openSUSE-2019-1752
openSUSE Tumbleweed
  • doxygen2man >= 2.0.2+20201203.def947e-1.6
  • libqb-devel >= 2.0.2+20201203.def947e-1.6
  • libqb-devel-32bit >= 2.0.2+20201203.def947e-1.6
  • libqb-tests >= 2.0.2+20201203.def947e-1.6
  • libqb-tools >= 2.0.2+20201203.def947e-1.6
  • libqb100 >= 2.0.2+20201203.def947e-1.6
  • libqb100-32bit >= 2.0.2+20201203.def947e-1.6
Patchnames:
openSUSE Tumbleweed GA doxygen2man-2.0.2+20201203.def947e-1.6


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications libqb Unsupported
SUSE Linux Enterprise Desktop 12 libqb Unsupported
SUSE Linux Enterprise Desktop 12 SP1 libqb Unsupported
SUSE Linux Enterprise Desktop 12 SP2 libqb Affected
SUSE Linux Enterprise Desktop 12 SP3 libqb Affected
SUSE Linux Enterprise Desktop 12 SP4 libdlm Released
SUSE Linux Enterprise Desktop 12 SP4 libqb Released
SUSE Linux Enterprise Desktop 15 SP4 libqb Already fixed
SUSE Linux Enterprise High Availability 12 libqb Unsupported
SUSE Linux Enterprise High Availability 12 SP1 libqb Unsupported
SUSE Linux Enterprise High Availability 12 SP2 libqb Affected
SUSE Linux Enterprise High Availability 12 SP3 libdlm Released
SUSE Linux Enterprise High Availability 12 SP3 libqb Released
SUSE Linux Enterprise High Availability 12 SP4 libdlm Released
SUSE Linux Enterprise High Availability 12 SP4 libqb Released
SUSE Linux Enterprise High Availability 12 SP5 libqb Affected
SUSE Linux Enterprise High Availability 15 libqb Released
SUSE Linux Enterprise High Availability 15 SP1 libqb Released
SUSE Linux Enterprise High Availability 15 SP2 libqb Affected
SUSE Linux Enterprise High Availability 15 SP3 libqb Already fixed
SUSE Linux Enterprise High Availability 15 SP4 libqb Already fixed
SUSE Linux Enterprise High Availability Extension 12 libqb Affected
SUSE Linux Enterprise High Availability Extension 12 SP2 libqb Unsupported
SUSE Linux Enterprise High Availability Extension 12 SP3 libqb Released
SUSE Linux Enterprise High Availability Extension 12 SP4 libqb Released
SUSE Linux Enterprise High Availability Extension 12 SP5 libqb Released
SUSE Linux Enterprise High Availability Extension 15 libqb Released
SUSE Linux Enterprise High Availability Extension 15 SP1 libqb Released
SUSE Linux Enterprise High Availability Extension 15 SP2 libqb Affected
SUSE Linux Enterprise High Availability Extension 15 SP3 libqb Already fixed
SUSE Linux Enterprise High Availability Extension 15 SP4 libqb Already fixed
SUSE Linux Enterprise High Performance Computing 12 libqb Affected
SUSE Linux Enterprise High Performance Computing 12 SP1 libqb Unsupported
SUSE Linux Enterprise High Performance Computing 12 SP2 libqb Unsupported
SUSE Linux Enterprise High Performance Computing 12 SP3 libdlm Released
SUSE Linux Enterprise High Performance Computing 12 SP3 libqb Released
SUSE Linux Enterprise High Performance Computing 12 SP4 libdlm Released
SUSE Linux Enterprise High Performance Computing 12 SP4 libqb Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libqb Released
SUSE Linux Enterprise High Performance Computing 15 libqb Released
SUSE Linux Enterprise High Performance Computing 15 SP1 libqb Released
SUSE Linux Enterprise High Performance Computing 15 SP2 libqb Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 libqb Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 libqb Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 libqb Already fixed
SUSE Linux Enterprise Server 12 libqb Affected
SUSE Linux Enterprise Server 12 SP1 libqb Unsupported
SUSE Linux Enterprise Server 12 SP2 libqb Unsupported
SUSE Linux Enterprise Server 12 SP3 libdlm Released
SUSE Linux Enterprise Server 12 SP3 libqb Released
SUSE Linux Enterprise Server 12 SP4 libdlm Released
SUSE Linux Enterprise Server 12 SP4 libqb Released
SUSE Linux Enterprise Server 12 SP5 libqb Released
SUSE Linux Enterprise Server 15 libqb Released
SUSE Linux Enterprise Server 15 SP1 libqb Released
SUSE Linux Enterprise Server 15 SP2 libqb Affected
SUSE Linux Enterprise Server 15 SP3 libqb Already fixed
SUSE Linux Enterprise Server 15 SP4 libqb Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 libqb Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libqb Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libqb Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libqb Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libdlm Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libqb Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libqb Released
SUSE Linux Enterprise Server for SAP Applications 15 libqb Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libqb Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libqb Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libqb Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libqb Already fixed
SUSE Linux Enterprise Software Development Kit 12 libqb Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP1 libqb Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 libqb Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libqb Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libdlm Released
SUSE Linux Enterprise Software Development Kit 12 SP4 libqb Released
SUSE Linux Enterprise Software Development Kit 12 SP5 libqb Released
SUSE Manager Proxy 4.0 libqb Released
SUSE Manager Proxy 4.1 libqb Affected
SUSE Manager Proxy 4.2 libqb Already fixed
SUSE Manager Proxy 4.3 libqb Already fixed
SUSE Manager Retail Branch Server 4.0 libqb Released
SUSE Manager Retail Branch Server 4.1 libqb Affected
SUSE Manager Retail Branch Server 4.2 libqb Already fixed
SUSE Manager Retail Branch Server 4.3 libqb Already fixed
SUSE Manager Server 4.0 libqb Released
SUSE Manager Server 4.1 libqb Affected
SUSE Manager Server 4.2 libqb Already fixed
SUSE Manager Server 4.3 libqb Already fixed
SUSE Package Hub 15 SP1 libqb Released


SUSE Timeline for this CVE

CVE page created: Sat Jun 8 02:12:58 2019
CVE page last modified: Wed Nov 30 13:33:21 2022