Upstream information

CVE-2019-12761 at MITRE

Description

A code injection issue was discovered in PyXDG before 0.26 via crafted Python code in a Category element of a Menu XML document in a .menu file. XDG_CONFIG_DIRS must be set up to trigger xdg.Menu.parse parsing within the directory containing this file. This is due to a lack of sanitization in xdg/Menu.py before an eval call.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.3
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Attack Vector Network Network
Attack Complexity High Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1137627 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 4.0
  • python2-pyxdg >= 0.25-150000.3.3.1
  • python3-pyxdg >= 0.25-150000.3.3.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2022-2997
SUSE Enterprise Storage 6
  • python2-pyxdg >= 0.25-150000.3.3.1
  • python3-pyxdg >= 0.25-150000.3.3.1
Patchnames:
SUSE-Storage-6-2022-2997
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • python2-pyxdg >= 0.25-150000.3.3.1
  • python3-pyxdg >= 0.25-150000.3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2022-2997
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • python2-pyxdg >= 0.25-150000.3.3.1
  • python3-pyxdg >= 0.25-150000.3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2022-2997
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • python2-pyxdg >= 0.25-150000.3.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-2022-2997
SUSE Linux Enterprise Server 15 SP1-BCL
  • python2-pyxdg >= 0.25-150000.3.3.1
  • python3-pyxdg >= 0.25-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2022-2997
SUSE Linux Enterprise Server 15 SP1-LTSS
  • python2-pyxdg >= 0.25-150000.3.3.1
  • python3-pyxdg >= 0.25-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-2997
SUSE Linux Enterprise Server 15-LTSS
  • python2-pyxdg >= 0.25-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-2022-2997
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • python2-pyxdg >= 0.25-150000.3.3.1
  • python3-pyxdg >= 0.25-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2022-2997
SUSE Linux Enterprise Server for SAP Applications 15
  • python2-pyxdg >= 0.25-150000.3.3.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2022-2997


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 python-pyxdg Already fixed
SUSE Enterprise Storage 7.1 python-pyxdg Already fixed
SUSE Linux Enterprise Desktop 15 SP4 python-pyxdg Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 python-pyxdg Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 python-pyxdg Already fixed
SUSE Linux Enterprise Real Time 15 SP3 python-pyxdg Already fixed
SUSE Linux Enterprise Server 15 SP4 python-pyxdg Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 python-pyxdg Already fixed
SUSE Manager Proxy 4.2 python-pyxdg Already fixed
SUSE Manager Proxy 4.3 python-pyxdg Already fixed
SUSE Manager Retail Branch Server 4.2 python-pyxdg Already fixed
SUSE Manager Retail Branch Server 4.3 python-pyxdg Already fixed
SUSE Manager Server 4.2 python-pyxdg Already fixed
SUSE Manager Server 4.3 python-pyxdg Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 python-pyxdg Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 python-pyxdg Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS python-pyxdg Released
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS python-pyxdg Released
SUSE Linux Enterprise High Performance Computing 15 SP2 python-pyxdg Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS python-pyxdg Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS python-pyxdg Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 python-pyxdg Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS python-pyxdg Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS python-pyxdg Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS python-pyxdg Released
SUSE Linux Enterprise High Performance Computing 15-LTSS python-pyxdg Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 python-pyxdg Unsupported
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 python-pyxdg Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 python-pyxdg Already fixed
SUSE Linux Enterprise Module for Python 2 15 SP1 python-pyxdg Unsupported
SUSE Linux Enterprise Module for Python 2 15 SP2 python-pyxdg Already fixed
SUSE Linux Enterprise Module for Python 2 15 SP3 python-pyxdg Already fixed
SUSE Linux Enterprise Server 15 SP1 python-pyxdg Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS python-pyxdg Released
SUSE Linux Enterprise Server 15 SP2 python-pyxdg Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS python-pyxdg Already fixed
SUSE Linux Enterprise Server 15 SP3 python-pyxdg Already fixed
SUSE Linux Enterprise Server 15 SP3-LTSS python-pyxdg Already fixed
SUSE Linux Enterprise Server 15-ESPOS python-pyxdg Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 python-pyxdg Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 python-pyxdg Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 python-pyxdg Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 python-pyxdg Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 python-pyxdg Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 python-pyxdg Already fixed
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 python-pyxdg Released
SUSE CaaS Platform 4.5 python-pyxdg Already fixed
SUSE Enterprise Storage 6 python-pyxdg Released
SUSE Linux Enterprise Desktop 15 python-pyxdg Affected
SUSE Linux Enterprise Desktop 15 SP1 python-pyxdg Unsupported
SUSE Linux Enterprise Desktop 15 SP2 python-pyxdg Already fixed
SUSE Linux Enterprise Desktop 15 SP3 python-pyxdg Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 python-pyxdg Affected
SUSE Linux Enterprise Module for Package Hub 15 python-pyxdg Affected
SUSE Linux Enterprise Real Time 15 SP2 python-pyxdg Already fixed
SUSE Linux Enterprise Server 15 python-pyxdg Affected
SUSE Linux Enterprise Server 15 SP1-BCL python-pyxdg Released
SUSE Linux Enterprise Server 15 SP2-BCL python-pyxdg Already fixed
SUSE Linux Enterprise Server 15 SP3-BCL python-pyxdg Already fixed
SUSE Linux Enterprise Server 15-LTSS python-pyxdg Released
SUSE Manager Proxy 4.0 python-pyxdg Unsupported
SUSE Manager Proxy 4.1 python-pyxdg Already fixed
SUSE Manager Retail Branch Server 4.0 python-pyxdg Unsupported
SUSE Manager Retail Branch Server 4.1 python-pyxdg Already fixed
SUSE Manager Server 4.0 python-pyxdg Unsupported
SUSE Manager Server 4.1 python-pyxdg Already fixed
SUSE Package Hub 15 python-pyxdg Unsupported


SUSE Timeline for this CVE

CVE page created: Fri Jun 7 02:01:47 2019
CVE page last modified: Fri Jan 20 14:55:44 2023