Upstream information

CVE-2018-20106 at MITRE

Description

In yast2-printer up to and including version 4.0.2 the SMB printer settings don't escape characters in passwords properly. If a password with backticks or simliar characters is supplied this allows for executing code as root. This requires tricking root to enter such a password in yast.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.1 6.3
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Local
Access Complexity High High
Privileges Required None High
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1114853 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications yast2-printer Unsupported
SUSE Linux Enterprise Desktop 12 SP3 yast2-printer Affected
SUSE Linux Enterprise Desktop 12 SP4 yast2-printer Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 yast2-printer Affected
SUSE Linux Enterprise Module for Basesystem 15 yast2-printer Affected
SUSE Linux Enterprise Server 11 SP3 LTSS yast2-printer Affected
SUSE Linux Enterprise Server 11 SP4 yast2-printer Affected
SUSE Linux Enterprise Server 12 LTSS yast2-printer Affected
SUSE Linux Enterprise Server 12 SP2 LTSS yast2-printer Affected
SUSE Linux Enterprise Server 12 SP3 yast2-printer Affected
SUSE Linux Enterprise Server 12 SP4 yast2-printer Affected
SUSE Linux Enterprise Server for SAP Applications 12 yast2-printer Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 yast2-printer Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 yast2-printer Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 yast2-printer Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 yast2-printer Affected