Upstream information

CVE-2018-1000140 at MITRE

Description

rsyslog librelp version 1.2.14 and earlier contains a Buffer Overflow vulnerability in the checking of x509 certificates from a peer that can result in Remote code execution. This attack appear to be exploitable a remote attacker that can connect to rsyslog and trigger a stack buffer overflow by sending a specially crafted x509 certificate.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1086730 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • librelp0 >= 1.2.12-3.3.1
SUSE Linux Enterprise Module for Server Applications 15
SUSE Linux Enterprise Module for Server Applications 15 SP1
SUSE Linux Enterprise Module for Server Applications 15 SP2
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • librelp-devel >= 1.2.15-1.15
  • librelp0 >= 1.2.15-1.15
SUSE Linux Enterprise Server 12 SP1-LTSS
  • librelp0 >= 1.2.7-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-553
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • librelp0 >= 1.2.7-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-553
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • librelp0 >= 1.2.12-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-552
SUSE Linux Enterprise Server 12-LTSS
  • librelp0 >= 1.2.7-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-2018-553
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • librelp0 >= 1.2.7-3.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-553
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • librelp0 >= 1.2.7-3.3.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-553
SUSE Linux Enterprise Software Development Kit 12 SP2
  • librelp-devel >= 1.2.7-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-553
SUSE Linux Enterprise Software Development Kit 12 SP3
  • librelp-devel >= 1.2.12-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-552
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • librelp-devel >= 1.2.12-3.3.1
SUSE OpenStack Cloud 6
  • librelp0 >= 1.2.7-3.3.1
Patchnames:
SUSE-OpenStack-Cloud-6-2018-553
openSUSE Tumbleweed
  • librelp-devel >= 1.10.0-1.5
  • librelp0 >= 1.10.0-1.5
Patchnames:
openSUSE Tumbleweed GA librelp-devel-1.10.0-1.5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 librelp In progress
SUSE CaaS Platform 4.0 librelp Already fixed
SUSE Enterprise Storage 6 librelp Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 librelp In progress
SUSE Linux Enterprise High Performance Computing 15 LTSS librelp Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS librelp Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP2 librelp Already fixed
SUSE Linux Enterprise Point of Service Image Server 12 librelp Released
SUSE Linux Enterprise Server 11 SP3 LTSS librelp Not affected
SUSE Linux Enterprise Server 11 SP4 librelp Not affected
SUSE Linux Enterprise Server 12 LTSS librelp Released
SUSE Linux Enterprise Server 12 SP1 LTSS librelp Released
SUSE Linux Enterprise Server 12 SP2 librelp Released
SUSE Linux Enterprise Server 12 SP2 BCL librelp Released
SUSE Linux Enterprise Server 12 SP2 ESPOS librelp Released
SUSE Linux Enterprise Server 12 SP2 LTSS librelp Released
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON librelp Released
SUSE Linux Enterprise Server 12 SP2 LTSS SAP librelp Released
SUSE Linux Enterprise Server 12 SP3 librelp Released
SUSE Linux Enterprise Server 12 SP3 BCL librelp In progress
SUSE Linux Enterprise Server 12 SP3 ESPOS librelp In progress
SUSE Linux Enterprise Server 12 SP3 LTSS librelp In progress
SUSE Linux Enterprise Server 12 SP4 ESPOS librelp In progress
SUSE Linux Enterprise Server 12 SP4 LTSS librelp In progress
SUSE Linux Enterprise Server 12 SP5 librelp In progress
SUSE Linux Enterprise Server 15 LTSS librelp Already fixed
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux librelp Already fixed
SUSE Linux Enterprise Server 15 SP1 LTSS librelp Already fixed
SUSE Linux Enterprise Server ESPOS 15 librelp Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 librelp Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 librelp In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 librelp In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP5 librelp In progress
SUSE Linux Enterprise Server for SAP Applications 15 librelp Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 librelp Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP4 librelp Not affected
SUSE Linux Enterprise Software Development Kit 12 librelp Released
SUSE Linux Enterprise Software Development Kit 12 SP3 librelp Released
SUSE Manager Proxy 4.0 librelp Already fixed
SUSE Manager Retail Branch Server 4.0 librelp Already fixed
SUSE Manager Server 4.0 librelp Already fixed
SUSE OpenStack Cloud 7 librelp Released
SUSE OpenStack Cloud 8 librelp In progress
SUSE OpenStack Cloud 9 librelp In progress
SUSE OpenStack Cloud Crowbar 8 librelp In progress
SUSE OpenStack Cloud Crowbar 9 librelp In progress