Upstream information

CVE-2016-7035 at MITRE

Description

An authorization flaw was found in Pacemaker before 1.1.16, where it did not properly guard its IPC interface. An attacker with an unprivileged account on a Pacemaker node could use this flaw to, for example, force the Local Resource Manager daemon to execute a script as root and thereby gain root access on the machine.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  SUSE
Base Score 6.8
Vector AV:L/AC:L/Au:S/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication Single
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 1007433 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Availability 12 SP1
  • libpacemaker3 >= 1.1.13-20.1
  • pacemaker >= 1.1.13-20.1
  • pacemaker-cli >= 1.1.13-20.1
  • pacemaker-cts >= 1.1.13-20.1
  • pacemaker-remote >= 1.1.13-20.1
Patchnames:
SUSE-SLE-HA-12-SP1-2016-1742
SUSE Linux Enterprise High Availability 12 SP2
  • libpacemaker3 >= 1.1.15-21.1
  • pacemaker >= 1.1.15-21.1
  • pacemaker-cli >= 1.1.15-21.1
  • pacemaker-cts >= 1.1.15-21.1
  • pacemaker-remote >= 1.1.15-21.1
Patchnames:
SUSE-SLE-HA-12-SP2-2016-1679
SUSE Linux Enterprise High Availability 12 SP3
  • libpacemaker3 >= 1.1.16-4.8
  • pacemaker >= 1.1.16-4.8
  • pacemaker-cli >= 1.1.16-4.8
  • pacemaker-cts >= 1.1.16-4.8
  • pacemaker-remote >= 1.1.16-4.8
Patchnames:
SUSE Linux Enterprise High Availability 12 SP3 GA libpacemaker3
SUSE Linux Enterprise High Availability 15
  • libpacemaker-devel >= 1.1.18+20180430.b12c320f5-1.14
  • libpacemaker3 >= 1.1.18+20180430.b12c320f5-1.14
  • pacemaker >= 1.1.18+20180430.b12c320f5-1.14
  • pacemaker-cli >= 1.1.18+20180430.b12c320f5-1.14
  • pacemaker-cts >= 1.1.18+20180430.b12c320f5-1.14
  • pacemaker-remote >= 1.1.18+20180430.b12c320f5-1.14
Patchnames:
SUSE Linux Enterprise High Availability 15 GA libpacemaker-devel
SUSE Linux Enterprise High Availability Extension 11 SP4
  • libpacemaker-devel >= 1.1.12-18.1
  • libpacemaker3 >= 1.1.12-18.1
  • pacemaker >= 1.1.12-18.1
  • pacemaker-cli >= 1.1.12-18.1
  • pacemaker-remote >= 1.1.12-18.1
Patchnames:
slehasp4-pacemaker-12889
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libpacemaker-devel >= 1.1.13-20.1
  • pacemaker >= 1.1.13-20.1
  • pacemaker-cts >= 1.1.13-20.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1742
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpacemaker-devel >= 1.1.15-21.1
  • pacemaker >= 1.1.15-21.1
  • pacemaker-cts >= 1.1.15-21.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2016-1679
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libpacemaker-devel >= 1.1.16-4.8
  • pacemaker-cts >= 1.1.16-4.8
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libpacemaker-devel
openSUSE Leap 42.1
  • libpacemaker-devel >= 1.1.13-23.2
  • libpacemaker3 >= 1.1.13-23.2
  • libpacemaker3-debuginfo >= 1.1.13-23.2
  • pacemaker >= 1.1.13-23.2
  • pacemaker-cli >= 1.1.13-23.2
  • pacemaker-cli-debuginfo >= 1.1.13-23.2
  • pacemaker-cts >= 1.1.13-23.2
  • pacemaker-cts-debuginfo >= 1.1.13-23.2
  • pacemaker-debuginfo >= 1.1.13-23.2
  • pacemaker-debugsource >= 1.1.13-23.2
  • pacemaker-remote >= 1.1.13-23.2
  • pacemaker-remote-debuginfo >= 1.1.13-23.2
Patchnames:
openSUSE-2016-1447
openSUSE Leap 42.2
  • libpacemaker-devel >= 1.1.15-5.1
  • libpacemaker3 >= 1.1.15-5.1
  • libpacemaker3-debuginfo >= 1.1.15-5.1
  • pacemaker >= 1.1.15-5.1
  • pacemaker-cli >= 1.1.15-5.1
  • pacemaker-cli-debuginfo >= 1.1.15-5.1
  • pacemaker-cts >= 1.1.15-5.1
  • pacemaker-cts-debuginfo >= 1.1.15-5.1
  • pacemaker-debuginfo >= 1.1.15-5.1
  • pacemaker-debugsource >= 1.1.15-5.1
  • pacemaker-remote >= 1.1.15-5.1
  • pacemaker-remote-debuginfo >= 1.1.15-5.1
Patchnames:
openSUSE-2016-1376
openSUSE Tumbleweed
  • libpacemaker-devel >= 1.1.15+git20161104.b6f251a-1.1
  • libpacemaker3 >= 1.1.15+git20161104.b6f251a-1.1
  • pacemaker >= 1.1.15+git20161104.b6f251a-1.1
  • pacemaker-cli >= 1.1.15+git20161104.b6f251a-1.1
  • pacemaker-cts >= 1.1.15+git20161104.b6f251a-1.1
  • pacemaker-remote >= 1.1.15+git20161104.b6f251a-1.1
Patchnames:
openSUSE Tumbleweed GA libpacemaker-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability 12 GA pacemaker Unsupported
SUSE Linux Enterprise High Availability 12 SP1 pacemaker Released
SUSE Linux Enterprise High Availability 12 SP2 pacemaker Released
SUSE Linux Enterprise High Availability Extension 11 SP4 pacemaker Affected
SUSE Linux Enterprise SDK 12 SP1 pacemaker Released
SUSE Linux Enterprise SDK 12 SP2 pacemaker Released