Upstream information

CVE-2015-8915 at MITRE

Description

bsdcpio in libarchive before 3.2.0 allows remote attackers to cause a denial of service (invalid read and crash) via crafted cpio file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
SUSE Bugzilla entry: 985601 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libarchive-devel >= 3.1.2-25.1
  • libarchive13 >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libarchive13-3.1.2-25.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise Desktop 12 SP4
  • libarchive-devel >= 3.1.2-25.1
  • libarchive13 >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libarchive13-3.1.2-25.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libarchive13 >= 3.1.2-26.3.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libarchive13-3.1.2-26.3.1
SUSE Linux Enterprise Server 12 SP3
  • libarchive-devel >= 3.1.2-25.1
  • libarchive13 >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libarchive13-3.1.2-25.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise Server 12 SP4
  • libarchive-devel >= 3.1.2-25.1
  • libarchive13 >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libarchive13-3.1.2-25.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise Server 12 SP5
  • libarchive-devel >= 3.1.2-26.3.1
  • libarchive13 >= 3.1.2-26.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libarchive13-3.1.2-26.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libarchive-devel-3.1.2-26.3.1
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libarchive-devel >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libarchive-devel >= 3.1.2-25.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libarchive-devel-3.1.2-25.1
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libarchive-devel >= 3.1.2-26.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libarchive-devel-3.1.2-26.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 libarchive Already fixed
SUSE Linux Enterprise Desktop 15 SP5 libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP5 libarchive Already fixed
SUSE Linux Enterprise Micro 5.3 libarchive Already fixed
SUSE Linux Enterprise Micro 5.4 libarchive Already fixed
SUSE Linux Enterprise Micro 5.5 libarchive Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP5 libarchive Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP5 libarchive Already fixed
SUSE Linux Enterprise Server 12 SP5 libarchive Already fixed
SUSE Linux Enterprise Server 15 SP5 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 libarchive Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 libarchive Already fixed
SUSE Manager Proxy 4.3 libarchive Already fixed
SUSE Manager Retail Branch Server 4.3 libarchive Already fixed
SUSE Manager Server 4.3 libarchive Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS libarchive Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 libarchive Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP3 libarchive Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 libarchive Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP2 libarchive Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP3 libarchive Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP4 libarchive Already fixed
SUSE Linux Enterprise Server 15 SP2 libarchive Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS libarchive Already fixed
SUSE Linux Enterprise Server 15 SP3 libarchive Already fixed
SUSE Linux Enterprise Server 15 SP3-LTSS libarchive Already fixed
SUSE Linux Enterprise Server 15 SP4 libarchive Already fixed
SUSE Linux Enterprise Server 15 SP4-LTSS libarchive Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libarchive Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libarchive Already fixed
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 libarchive Affected
SUSE CaaS Platform 4.0 libarchive Already fixed
SUSE CaaS Platform 4.5 libarchive Unsupported
SUSE Enterprise Storage 6 libarchive Already fixed
SUSE Enterprise Storage 7 libarchive Already fixed
SUSE Linux Enterprise Desktop 11 SP4 bsdtar Unsupported
SUSE Linux Enterprise Desktop 12 libarchive Unsupported
SUSE Linux Enterprise Desktop 12 SP1 libarchive Unsupported
SUSE Linux Enterprise Desktop 12 SP2 libarchive Unsupported
SUSE Linux Enterprise Desktop 12 SP3 libarchive Affected
SUSE Linux Enterprise Desktop 12 SP4 libarchive Affected
SUSE Linux Enterprise Desktop 15 libarchive Already fixed
SUSE Linux Enterprise Desktop 15 SP1 libarchive Already fixed
SUSE Linux Enterprise Desktop 15 SP2 libarchive Already fixed
SUSE Linux Enterprise Desktop 15 SP3 libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS libarchive Already fixed
SUSE Linux Enterprise High Performance Computing 15-LTSS libarchive Already fixed
SUSE Linux Enterprise Module for Basesystem 15 libarchive Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP1 libarchive Already fixed
SUSE Linux Enterprise Module for Development Tools 15 libarchive Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP1 libarchive Already fixed
SUSE Linux Enterprise Point of Service 11 SP3 bsdtar Released
SUSE Linux Enterprise Real Time 15 SP2 libarchive Unsupported
SUSE Linux Enterprise Real Time 15 SP3 libarchive Already fixed
SUSE Linux Enterprise Real Time 15 SP4 libarchive Already fixed
SUSE Linux Enterprise Server 11 SP1 bsdtar Unsupported
SUSE Linux Enterprise Server 11 SP2 LTSS bsdtar Unsupported
SUSE Linux Enterprise Server 11 SP3 bsdtar Unsupported
SUSE Linux Enterprise Server 11 SP3 LTSS bsdtar Unsupported
SUSE Linux Enterprise Server 11 SP3-LTSS bsdtar Affected
SUSE Linux Enterprise Server 11 SP4 bsdtar Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS bsdtar Released
SUSE Linux Enterprise Server 11 SP4-LTSS bsdtar Unsupported
SUSE Linux Enterprise Server 12 libarchive Unsupported
SUSE Linux Enterprise Server 12 SP1 libarchive Unsupported
SUSE Linux Enterprise Server 12 SP1-LTSS libarchive Affected
SUSE Linux Enterprise Server 12 SP2 libarchive Affected
SUSE Linux Enterprise Server 12 SP2-BCL libarchive Released
SUSE Linux Enterprise Server 12 SP2-ESPOS libarchive Affected
SUSE Linux Enterprise Server 12 SP2-LTSS libarchive Affected
SUSE Linux Enterprise Server 12 SP3 libarchive Affected
SUSE Linux Enterprise Server 12 SP3-BCL libarchive Released
SUSE Linux Enterprise Server 12 SP3-ESPOS libarchive Unsupported
SUSE Linux Enterprise Server 12 SP3-LTSS libarchive Unsupported
SUSE Linux Enterprise Server 12 SP4 libarchive Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS libarchive Already fixed
SUSE Linux Enterprise Server 12 SP4-LTSS libarchive Already fixed
SUSE Linux Enterprise Server 12-LTSS libarchive Affected
SUSE Linux Enterprise Server 15 libarchive Already fixed
SUSE Linux Enterprise Server 15 SP1 libarchive Already fixed
SUSE Linux Enterprise Server 15 SP1-BCL libarchive Already fixed
SUSE Linux Enterprise Server 15 SP1-LTSS libarchive Already fixed
SUSE Linux Enterprise Server 15 SP2-BCL libarchive Already fixed
SUSE Linux Enterprise Server 15 SP3-BCL libarchive Already fixed
SUSE Linux Enterprise Server 15-LTSS libarchive Already fixed
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 libarchive Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 bsdtar Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 libarchive Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libarchive Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libarchive Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libarchive Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 libarchive Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libarchive Already fixed
SUSE Linux Enterprise Server for the Raspberry Pi 12 SP2 libarchive Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP4 bsdtar Unsupported
SUSE Linux Enterprise Software Development Kit 12 libarchive Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP1 libarchive Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 libarchive Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 libarchive Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libarchive Affected
SUSE Manager Proxy 4.0 libarchive Already fixed
SUSE Manager Proxy 4.1 libarchive Already fixed
SUSE Manager Proxy 4.2 libarchive Already fixed
SUSE Manager Retail Branch Server 4.0 libarchive Already fixed
SUSE Manager Retail Branch Server 4.1 libarchive Already fixed
SUSE Manager Retail Branch Server 4.2 libarchive Already fixed
SUSE Manager Server 4.0 libarchive Already fixed
SUSE Manager Server 4.1 libarchive Already fixed
SUSE Manager Server 4.2 libarchive Already fixed
SUSE OpenStack Cloud 7 libarchive Affected
SUSE OpenStack Cloud 8 libarchive Affected
SUSE OpenStack Cloud 9 libarchive Already fixed
SUSE OpenStack Cloud Crowbar 8 libarchive Affected
SUSE OpenStack Cloud Crowbar 9 libarchive Already fixed
SUSE Studio Onsite 1.3 bsdtar Unsupported


SUSE Timeline for this CVE

CVE page created: Fri Jun 17 22:19:19 2016
CVE page last modified: Sat Jun 15 22:49:18 2024