Upstream information

CVE-2015-2152 at MITRE

Description

Xen 4.5.x and earlier enables certain default backends when emulating a VGA device for an x86 HVM guest qemu even when the configuration disables them, which allows local guest users to obtain access to the VGA console by (1) setting the DISPLAY environment variable, when compiled with SDL support, or connecting to the VNC server on (2) ::1 or (3) 127.0.0.1, when not compiled with SDL support.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 1.9
Vector AV:L/AC:M/Au:N/C:N/I:P/A:N
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 918998 [RESOLVED / FIXED], 919663 [RESOLVED / FIXED], 950367 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • xen >= 4.5.1_12-2.3
  • xen-devel >= 4.5.1_12-2.3
  • xen-kmp-default >= 4.5.1_12_k3.12.49_11-2.3
  • xen-libs >= 4.5.1_12-2.3
  • xen-libs-32bit >= 4.5.1_12-2.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA xen-4.5.1_12-2.3
SUSE Linux Enterprise Software Development Kit 12 SP1 GA xen-devel-4.5.1_12-2.3
SUSE Linux Enterprise Desktop 12
  • xen >= 4.4.1_10-9.1
  • xen-devel >= 4.4.1_10-9.1
  • xen-kmp-default >= 4.4.1_10_k3.12.36_38-9.1
  • xen-libs >= 4.4.1_10-9.1
  • xen-libs-32bit >= 4.4.1_10-9.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-147
SUSE-SLE-SDK-12-2015-147
SUSE Linux Enterprise Server 12 SP1
  • xen >= 4.5.1_12-2.3
  • xen-devel >= 4.5.1_12-2.3
  • xen-doc-html >= 4.5.1_12-2.3
  • xen-kmp-default >= 4.5.1_12_k3.12.49_11-2.3
  • xen-libs >= 4.5.1_12-2.3
  • xen-libs-32bit >= 4.5.1_12-2.3
  • xen-tools >= 4.5.1_12-2.3
  • xen-tools-domU >= 4.5.1_12-2.3
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA xen-4.5.1_12-2.3
SUSE Linux Enterprise Software Development Kit 12 SP1 GA xen-devel-4.5.1_12-2.3
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • xen >= 4.4.1_10-9.1
  • xen-devel >= 4.4.1_10-9.1
  • xen-doc-html >= 4.4.1_10-9.1
  • xen-kmp-default >= 4.4.1_10_k3.12.36_38-9.1
  • xen-libs >= 4.4.1_10-9.1
  • xen-libs-32bit >= 4.4.1_10-9.1
  • xen-tools >= 4.4.1_10-9.1
  • xen-tools-domU >= 4.4.1_10-9.1
Patchnames:
SUSE-SLE-SDK-12-2015-147
SUSE-SLE-SERVER-12-2015-147
SUSE Linux Enterprise Server for SAP Applications 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • xen-devel >= 4.5.1_12-2.3
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA xen-devel-4.5.1_12-2.3
SUSE Linux Enterprise Software Development Kit 12
  • xen-devel >= 4.4.1_10-9.1
Patchnames:
SUSE-SLE-SDK-12-2015-147


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 11 SP1 xen Released
SUSE Linux Enterprise Desktop 11 SP2 xen Released
SUSE Linux Enterprise Desktop 11 SP3 xen Released
SUSE Linux Enterprise Desktop 11 SP4 xen Already fixed
SUSE Linux Enterprise Desktop 12 xen Released
SUSE Linux Enterprise Server 11 SP1 xen Released
SUSE Linux Enterprise Server 11 SP1 LTSS xen Released
SUSE Linux Enterprise Server 11 SP2 xen Released
SUSE Linux Enterprise Server 11 SP2 LTSS xen Released
SUSE Linux Enterprise Server 11 SP3 xen Released
SUSE Linux Enterprise Server 11 SP3-LTSS xen Affected
SUSE Linux Enterprise Server 11 SP4 xen Already fixed
SUSE Linux Enterprise Server 11 SP4 LTSS xen Already fixed
SUSE Linux Enterprise Server 11 SP4-LTSS xen Already fixed
SUSE Linux Enterprise Server 12 xen Released
SUSE Linux Enterprise Server 12-LTSS xen Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP1 xen Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 xen Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 xen Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 xen Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 xen Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 xen Released
SUSE Linux Enterprise Software Development Kit 11 SP1 xen Released
SUSE Linux Enterprise Software Development Kit 11 SP2 xen Released
SUSE Linux Enterprise Software Development Kit 11 SP3 xen Released
SUSE Linux Enterprise Software Development Kit 11 SP4 xen Already fixed
SUSE Linux Enterprise Software Development Kit 12 xen Released


SUSE Timeline for this CVE

CVE page created: Thu Feb 26 10:25:05 2015
CVE page last modified: Sat Jun 15 22:31:52 2024