Upstream information

CVE-2014-9447 at MITRE

Description

Directory traversal vulnerability in the read_long_names function in libelf/elf_begin.c in elfutils 0.152 and 0.161 allows remote attackers to write to arbitrary files to the root directory via a / (slash) in a crafted archive, as demonstrated using the ar program.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:N/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 911662 [RESOLVED / FIXED], 912408 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/default-http-backend:beta1
Container caasp/v4/dnsmasq-nanny:2.78
Container caasp/v4/flannel:0.9.1
Container caasp/v4/haproxy:beta1
Container caasp/v4/kubedns:beta1
Container caasp/v4/openldap:beta1
Container caasp/v4/pause:1.0.0
Container caasp/v4/pv-recycler-node:8.25
Container caasp/v4/salt-api:beta1
Container caasp/v4/salt-master:beta1
Container caasp/v4/salt-minion:beta1
Container caasp/v4/sidecar:beta1
Container caasp/v4/velum:4.0.0
  • elfutils >= 0.158-6.1
  • libasm1 >= 0.158-6.1
  • libdw1 >= 0.158-6.1
  • libelf1 >= 0.158-6.1
Container caasp/v4/nginx-ingress-controller:beta1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • elfutils >= 0.158-6.1
  • libasm1 >= 0.158-6.1
  • libdw1 >= 0.158-6.1
  • libebl1 >= 0.158-6.1
  • libelf1 >= 0.158-6.1
Container suse/sles12sp4:latest
Container suse/sles12sp5:latest
  • libdw1 >= 0.158-6.1
  • libebl1 >= 0.158-6.1
  • libelf1 >= 0.158-6.1
SUSE Linux Enterprise Desktop 11 SP3
  • elfutils >= 0.152-4.9.17
  • libasm1 >= 0.152-4.9.17
  • libdw1 >= 0.152-4.9.17
  • libdw1-32bit >= 0.152-4.9.17
  • libebl1 >= 0.152-4.9.17
  • libebl1-32bit >= 0.152-4.9.17
  • libelf1 >= 0.152-4.9.17
  • libelf1-32bit >= 0.152-4.9.17
Patchnames:
sledsp3-elfutils
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
  • elfutils >= 0.158-6.1
  • libasm1 >= 0.158-6.1
  • libdw1 >= 0.158-6.1
  • libdw1-32bit >= 0.158-6.1
  • libebl1 >= 0.158-6.1
  • libebl1-32bit >= 0.158-6.1
  • libelf1 >= 0.158-6.1
  • libelf1-32bit >= 0.158-6.1
SUSE Linux Enterprise Desktop 12 SP4
  • elfutils >= 0.158-6.1
  • libasm1 >= 0.158-6.1
  • libdw1 >= 0.158-6.1
  • libdw1-32bit >= 0.158-6.1
  • libebl1 >= 0.158-6.1
  • libebl1-32bit >= 0.158-6.1
  • libelf-devel >= 0.158-6.1
  • libelf1 >= 0.158-6.1
  • libelf1-32bit >= 0.158-6.1
SUSE Linux Enterprise Desktop 12
  • elfutils >= 0.158-6.1
  • libasm1 >= 0.158-6.1
  • libdw1 >= 0.158-6.1
  • libdw1-32bit >= 0.158-6.1
  • libebl1 >= 0.158-6.1
  • libebl1-32bit >= 0.158-6.1
  • libelf1 >= 0.158-6.1
  • libelf1-32bit >= 0.158-6.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-76
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • elfutils >= 0.158-7.7.2
  • libasm1 >= 0.158-7.7.2
  • libasm1-32bit >= 0.158-7.7.2
  • libdw1 >= 0.158-7.7.2
  • libdw1-32bit >= 0.158-7.7.2
  • libebl1 >= 0.158-7.7.2
  • libebl1-32bit >= 0.158-7.7.2
  • libelf-devel >= 0.158-7.7.2
  • libelf1 >= 0.158-7.7.2
  • libelf1-32bit >= 0.158-7.7.2
SUSE Linux Enterprise Module for Basesystem 15 SP2
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • elfutils >= 0.168-4.5.3
  • elfutils-lang >= 0.168-4.5.3
  • libasm-devel >= 0.168-4.5.3
  • libasm1 >= 0.168-4.5.3
  • libdw-devel >= 0.168-4.5.3
  • libdw1 >= 0.168-4.5.3
  • libdw1-32bit >= 0.168-4.5.3
  • libebl-devel >= 0.168-4.5.3
  • libebl-plugins >= 0.168-4.5.3
  • libebl-plugins-32bit >= 0.168-4.5.3
  • libelf-devel >= 0.168-4.5.3
  • libelf1 >= 0.168-4.5.3
  • libelf1-32bit >= 0.168-4.5.3
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • elfutils >= 0.168-2.164
  • elfutils-lang >= 0.168-2.164
  • libasm-devel >= 0.168-2.164
  • libasm1 >= 0.168-2.164
  • libdw-devel >= 0.168-2.164
  • libdw1 >= 0.168-2.164
  • libdw1-32bit >= 0.168-2.164
  • libebl-devel >= 0.168-2.164
  • libebl-plugins >= 0.168-2.164
  • libebl-plugins-32bit >= 0.168-2.164
  • libelf-devel >= 0.168-2.164
  • libelf1 >= 0.168-2.164
  • libelf1-32bit >= 0.168-2.164
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • elfutils >= 0.152-4.9.17
  • libasm1 >= 0.152-4.9.17
  • libasm1-32bit >= 0.152-4.9.17
  • libdw1 >= 0.152-4.9.17
  • libdw1-32bit >= 0.152-4.9.17
  • libdw1-x86 >= 0.152-4.9.17
  • libebl1 >= 0.152-4.9.17
  • libebl1-32bit >= 0.152-4.9.17
  • libebl1-x86 >= 0.152-4.9.17
  • libelf1 >= 0.152-4.9.17
  • libelf1-32bit >= 0.152-4.9.17
  • libelf1-x86 >= 0.152-4.9.17
Patchnames:
slessp3-elfutils
SUSE Linux Enterprise Server 11 SP4
  • elfutils >= 0.152-4.9.17
  • libasm1 >= 0.152-4.9.17
  • libasm1-32bit >= 0.152-4.9.17
  • libdw1 >= 0.152-4.9.17
  • libdw1-32bit >= 0.152-4.9.17
  • libdw1-x86 >= 0.152-4.9.17
  • libebl1 >= 0.152-4.9.17
  • libebl1-32bit >= 0.152-4.9.17
  • libebl1-x86 >= 0.152-4.9.17
  • libelf1 >= 0.152-4.9.17
  • libelf1-32bit >= 0.152-4.9.17
  • libelf1-x86 >= 0.152-4.9.17
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
  • elfutils >= 0.158-6.1
  • libasm1 >= 0.158-6.1
  • libasm1-32bit >= 0.158-6.1
  • libdw1 >= 0.158-6.1
  • libdw1-32bit >= 0.158-6.1
  • libebl1 >= 0.158-6.1
  • libebl1-32bit >= 0.158-6.1
  • libelf1 >= 0.158-6.1
  • libelf1-32bit >= 0.158-6.1
SUSE Linux Enterprise Server 12 SP4
  • elfutils >= 0.158-6.1
  • libasm1 >= 0.158-6.1
  • libasm1-32bit >= 0.158-6.1
  • libdw1 >= 0.158-6.1
  • libdw1-32bit >= 0.158-6.1
  • libebl1 >= 0.158-6.1
  • libebl1-32bit >= 0.158-6.1
  • libelf-devel >= 0.158-6.1
  • libelf1 >= 0.158-6.1
  • libelf1-32bit >= 0.158-6.1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • elfutils >= 0.158-6.1
  • libasm1 >= 0.158-6.1
  • libasm1-32bit >= 0.158-6.1
  • libdw1 >= 0.158-6.1
  • libdw1-32bit >= 0.158-6.1
  • libebl1 >= 0.158-6.1
  • libebl1-32bit >= 0.158-6.1
  • libelf1 >= 0.158-6.1
  • libelf1-32bit >= 0.158-6.1
Patchnames:
SUSE-SLE-SERVER-12-2015-76
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libasm-devel >= 0.152-4.9.17
  • libdw-devel >= 0.152-4.9.17
  • libebl-devel >= 0.152-4.9.17
  • libelf-devel >= 0.152-4.9.17
  • libelf1-32bit >= 0.152-4.9.17
Patchnames:
sdksp3-elfutils
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libasm-devel >= 0.152-4.9.17
  • libdw-devel >= 0.152-4.9.17
  • libebl-devel >= 0.152-4.9.17
  • libelf-devel >= 0.152-4.9.17
  • libelf1-32bit >= 0.152-4.9.17
SUSE Linux Enterprise Software Development Kit 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libasm-devel >= 0.158-6.1
  • libdw-devel >= 0.158-6.1
  • libebl-devel >= 0.158-6.1
  • libelf-devel >= 0.158-6.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libasm-devel >= 0.158-6.1
  • libdw-devel >= 0.158-6.1
  • libebl-devel >= 0.158-6.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libasm-devel >= 0.158-7.7.2
  • libdw-devel >= 0.158-7.7.2
  • libebl-devel >= 0.158-7.7.2
SUSE Linux Enterprise Software Development Kit 12
  • libasm-devel >= 0.158-6.1
  • libdw-devel >= 0.158-6.1
  • libebl-devel >= 0.158-6.1
  • libelf-devel >= 0.158-6.1
Patchnames:
SUSE-SLE-SDK-12-2015-76
openSUSE Leap 15.0
  • elfutils >= 0.168-lp150.2.48
  • elfutils-lang >= 0.168-lp150.2.48
  • libasm1 >= 0.168-lp150.2.48
  • libdw1 >= 0.168-lp150.2.48
  • libdw1-32bit >= 0.168-lp150.2.48
  • libebl-plugins >= 0.168-lp150.2.48
  • libebl-plugins-32bit >= 0.168-lp150.2.48
  • libelf1 >= 0.168-lp150.2.48
  • libelf1-32bit >= 0.168-lp150.2.48
Patchnames:
openSUSE Leap 15.0 GA elfutils-0.168-lp150.2.48
openSUSE Tumbleweed
  • elfutils >= 0.167-1.5
  • elfutils-lang >= 0.167-1.5
  • libasm-devel >= 0.167-1.5
  • libasm1 >= 0.167-1.5
  • libasm1-32bit >= 0.167-1.5
  • libdw-devel >= 0.167-1.5
  • libdw1 >= 0.167-1.5
  • libdw1-32bit >= 0.167-1.5
  • libebl-devel >= 0.167-1.5
  • libebl1 >= 0.167-1.5
  • libebl1-32bit >= 0.167-1.5
  • libelf-devel >= 0.167-1.5
  • libelf-devel-32bit >= 0.167-1.5
  • libelf1 >= 0.167-1.5
  • libelf1-32bit >= 0.167-1.5
Patchnames:
openSUSE Tumbleweed GA elfutils-0.167-1.5


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 elfutils Released
SUSE Enterprise Storage 5 elfutils Released
SUSE Linux Enterprise Desktop 11 SP1 elfutils Released
SUSE Linux Enterprise Desktop 11 SP3 elfutils Released
SUSE Linux Enterprise Desktop 12 elfutils Released
SUSE Linux Enterprise Desktop 12 SP1 elfutils Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search elfutils Released
SUSE Linux Enterprise High Performance Computing 12 SP5 elfutils Released
SUSE Linux Enterprise Point of Service Image Server 12 SP2 elfutils Released
SUSE Linux Enterprise Server 11 SP1 elfutils Released
SUSE Linux Enterprise Server 11 SP1 LTSS elfutils Released
SUSE Linux Enterprise Server 11 SP3 elfutils Released
SUSE Linux Enterprise Server 11 SP3 for VMware elfutils Released
SUSE Linux Enterprise Server 12 elfutils Released
SUSE Linux Enterprise Server 12 SP2 ESPOS elfutils Released
SUSE Linux Enterprise Server 12 SP2 LTSS elfutils Released
SUSE Linux Enterprise Server 12 SP3 ESPOS elfutils Released
SUSE Linux Enterprise Server 12 SP3 LTSS elfutils Released
SUSE Linux Enterprise Server 12 SP4 ESPOS elfutils Released
SUSE Linux Enterprise Server 12 SP4 LTSS elfutils Released
SUSE Linux Enterprise Server 12 SP5 elfutils Released
SUSE Linux Enterprise Server BCL 12 SP2 elfutils Released
SUSE Linux Enterprise Server BCL 12 SP3 elfutils Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 elfutils Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 elfutils Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 elfutils Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 elfutils Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 elfutils Released
SUSE Linux Enterprise Software Development Kit 11 SP1 elfutils Released
SUSE Linux Enterprise Software Development Kit 11 SP3 elfutils Released
SUSE Linux Enterprise Software Development Kit 12 elfutils Released
SUSE Linux Enterprise Software Development Kit 12 SP5 elfutils Released
SUSE OpenStack Cloud 7 elfutils Released
SUSE OpenStack Cloud 8 elfutils Released
SUSE OpenStack Cloud 9 elfutils Released
SUSE OpenStack Cloud Crowbar 8 elfutils Released
SUSE OpenStack Cloud Crowbar 9 elfutils Released