Upstream information

CVE-2014-3775 at MITRE

Description

libgadu before 1.11.4 and 1.12.0 before 1.12.0-rc3, as used in Pidgin and other products, allows remote Gadu-Gadu file relay servers to cause a denial of service (memory overwrite) or possibly execute arbitrary code via a crafted message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 878540 [VERIFIED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Workstation Extension 12
SUSE Linux Enterprise Workstation Extension 12 SP1
SUSE Linux Enterprise Workstation Extension 12 SP2
SUSE Linux Enterprise Workstation Extension 12 SP3
SUSE Linux Enterprise Workstation Extension 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libgadu3 >= 1.11.4-1.12
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libgadu-devel >= 1.11.4-1.7
  • libgadu3 >= 1.11.4-1.7
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libgadu-devel >= 1.11.4-1.12
  • libgadu3 >= 1.11.4-1.12
SUSE Linux Enterprise Workstation Extension 15
SUSE Linux Enterprise Workstation Extension 15 SP1
SUSE Linux Enterprise Workstation Extension 15 SP2
  • libgadu-devel >= 1.12.2-1.44
  • libgadu3 >= 1.12.2-1.44
openSUSE Leap 15.0
  • libgadu3 >= 1.12.2-lp150.1.9
Patchnames:
openSUSE Leap 15.0 GA libgadu3-1.12.2-lp150.1.9
openSUSE Tumbleweed
  • libgadu-devel >= 1.12.1-1.10
  • libgadu3 >= 1.12.1-1.10
Patchnames:
openSUSE Tumbleweed GA libgadu-devel-1.12.1-1.10


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP3 libgadu Released
SUSE Linux Enterprise Software Development Kit 11 SP3 libgadu Released
SUSE Linux Enterprise Workstation Extension 12 SP5 libgadu Already fixed