Upstream information

CVE-2014-0250 at MITRE

Description

Multiple integer overflows in client/X11/xf_graphics.c in FreeRDP allow remote attackers to have an unspecified impact via the width and height to the (1) xf_Pointer_New or (2) xf_Bitmap_Decompress function, which causes an incorrect amount of memory to be allocated.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.8
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
SUSE Bugzilla entries: 880317 [CLOSED / FIXED], 975218 [RESOLVED / UPSTREAM]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • freerdp >= 1.0.2-9.1
  • libfreerdp-1_0 >= 1.0.2-9.1
  • libfreerdp-1_0-plugins >= 1.0.2-9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1462
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Workstation Extension 12 SP2
SUSE Linux Enterprise Workstation Extension 12 SP3
  • freerdp >= 2.0.0~git.1463131968.4e66df7-11.69
  • libfreerdp2 >= 2.0.0~git.1463131968.4e66df7-11.69
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Workstation Extension 12 SP4
  • freerdp >= 2.0.0~git.1463131968.4e66df7-12.3.2
  • libfreerdp2 >= 2.0.0~git.1463131968.4e66df7-12.3.2
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Workstation Extension 12
  • freerdp >= 1.0.2-7.9
  • libfreerdp-1_0 >= 1.0.2-7.9
  • libfreerdp-1_0-plugins >= 1.0.2-7.9
SUSE Linux Enterprise Software Development Kit 12 SP1
  • freerdp-devel >= 1.0.2-9.1
  • libfreerdp-1_0 >= 1.0.2-9.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1462
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • freerdp-devel >= 2.0.0~git.1463131968.4e66df7-11.69
  • libfreerdp2 >= 2.0.0~git.1463131968.4e66df7-11.69
SUSE Linux Enterprise Software Development Kit 12 SP4
  • freerdp-devel >= 2.0.0~git.1463131968.4e66df7-12.3.2
  • libfreerdp2 >= 2.0.0~git.1463131968.4e66df7-12.3.2
SUSE Linux Enterprise Software Development Kit 12 SP5
  • freerdp-devel >= 2.0.0~git.1463131968.4e66df7-12.8.1
  • libfreerdp2 >= 2.0.0~git.1463131968.4e66df7-12.8.1
SUSE Linux Enterprise Software Development Kit 12
  • freerdp-devel >= 1.0.2-7.9
  • libfreerdp-1_0 >= 1.0.2-7.9
SUSE Linux Enterprise Workstation Extension 12 SP1
  • freerdp >= 1.0.2-9.1
  • libfreerdp-1_0 >= 1.0.2-9.1
  • libfreerdp-1_0-plugins >= 1.0.2-9.1
Patchnames:
SUSE-SLE-WE-12-SP1-2016-1462
SUSE Linux Enterprise Workstation Extension 12 SP5
  • freerdp >= 2.0.0~git.1463131968.4e66df7-12.8.1
  • libfreerdp2 >= 2.0.0~git.1463131968.4e66df7-12.8.1
SUSE Linux Enterprise Workstation Extension 15 SP1
  • freerdp >= 2.0.0~rc4-8.4
  • freerdp-devel >= 2.0.0~rc4-8.4
  • libfreerdp2 >= 2.0.0~rc4-8.4
  • libwinpr2 >= 2.0.0~rc4-8.4
  • winpr2-devel >= 2.0.0~rc4-8.4
SUSE Linux Enterprise Workstation Extension 15 SP2
  • freerdp >= 2.0.0~rc4-13.2
  • freerdp-devel >= 2.0.0~rc4-13.2
  • libfreerdp2 >= 2.0.0~rc4-13.2
  • libwinpr2 >= 2.0.0~rc4-13.2
  • winpr2-devel >= 2.0.0~rc4-13.2
SUSE Linux Enterprise Workstation Extension 15
  • freerdp >= 2.0.0~rc2-1.8
  • freerdp-devel >= 2.0.0~rc2-1.8
  • libfreerdp2 >= 2.0.0~rc2-1.8
  • libwinpr2 >= 2.0.0~rc2-1.8
  • winpr2-devel >= 2.0.0~rc2-1.8
openSUSE Leap 15.0
  • freerdp >= 2.0.0~rc2-lp150.1.1
  • libfreerdp2 >= 2.0.0~rc2-lp150.1.1
  • libwinpr2 >= 2.0.0~rc2-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA freerdp
openSUSE Tumbleweed
  • freerdp >= 2.0.0~git.1463131968.4e66df7-2.5
  • freerdp-devel >= 2.0.0~git.1463131968.4e66df7-2.5
  • libfreerdp2 >= 2.0.0~git.1463131968.4e66df7-2.5
Patchnames:
openSUSE Tumbleweed GA freerdp


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 freerdp Released
SUSE Linux Enterprise Desktop 12 SP1 freerdp Released
SUSE Linux Enterprise Software Development Kit 12 freerdp Released
SUSE Linux Enterprise Software Development Kit 12 SP1 freerdp Released
SUSE Linux Enterprise Workstation Extension 12 freerdp Released
SUSE Linux Enterprise Workstation Extension 12 SP1 freerdp Released