Upstream information

CVE-2014-0249 at MITRE

Description

The System Security Services Daemon (SSSD) 1.11.6 does not properly identify group membership when a non-POSIX group is in a group membership chain, which allows local users to bypass access restrictions via unspecified vectors.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 3.3 2.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:N AV:L/AC:H/Au:S/C:P/I:P/A:N
Access Vector Local Local
Access Complexity Medium High
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact None None
SUSE Bugzilla entry: 880245 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Basesystem 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libipa_hbac-devel >= 1.16.1-3.18.1
  • libipa_hbac0 >= 1.16.1-3.18.1
  • libsss_certmap-devel >= 1.16.1-3.18.1
  • libsss_certmap0 >= 1.16.1-3.18.1
  • libsss_idmap-devel >= 1.16.1-3.18.1
  • libsss_idmap0 >= 1.16.1-3.18.1
  • libsss_nss_idmap-devel >= 1.16.1-3.18.1
  • libsss_nss_idmap0 >= 1.16.1-3.18.1
  • libsss_simpleifp-devel >= 1.16.1-3.18.1
  • libsss_simpleifp0 >= 1.16.1-3.18.1
  • python3-sssd-config >= 1.16.1-3.18.1
  • sssd >= 1.16.1-3.18.1
  • sssd-32bit >= 1.16.1-3.18.1
  • sssd-ad >= 1.16.1-3.18.1
  • sssd-dbus >= 1.16.1-3.18.1
  • sssd-ipa >= 1.16.1-3.18.1
  • sssd-krb5 >= 1.16.1-3.18.1
  • sssd-krb5-common >= 1.16.1-3.18.1
  • sssd-ldap >= 1.16.1-3.18.1
  • sssd-proxy >= 1.16.1-3.18.1
  • sssd-tools >= 1.16.1-3.18.1
  • sssd-wbclient >= 1.16.1-3.18.1
  • sssd-wbclient-devel >= 1.16.1-3.18.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libipa_hbac-devel-1.16.1-3.18.1
SUSE Linux Enterprise Desktop 12 SP1
  • libipa_hbac-devel >= 1.11.5.1-28.1
  • libipa_hbac0 >= 1.11.5.1-28.1
  • libsss_idmap-devel >= 1.11.5.1-28.1
  • libsss_idmap0 >= 1.11.5.1-28.1
  • libsss_nss_idmap-devel >= 1.11.5.1-28.1
  • libsss_nss_idmap0 >= 1.11.5.1-28.1
  • libsss_sudo >= 1.11.5.1-28.1
  • python-sssd-config >= 1.11.5.1-28.1
  • sssd >= 1.11.5.1-28.1
  • sssd-32bit >= 1.11.5.1-28.1
  • sssd-ad >= 1.11.5.1-28.1
  • sssd-ipa >= 1.11.5.1-28.1
  • sssd-krb5 >= 1.11.5.1-28.1
  • sssd-krb5-common >= 1.11.5.1-28.1
  • sssd-ldap >= 1.11.5.1-28.1
  • sssd-proxy >= 1.11.5.1-28.1
  • sssd-tools >= 1.11.5.1-28.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1513
SUSE-SLE-SDK-12-SP1-2016-1513
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libipa_hbac-devel >= 1.16.1-1.22
  • libipa_hbac0 >= 1.16.1-1.22
  • libsss_certmap-devel >= 1.16.1-1.22
  • libsss_certmap0 >= 1.16.1-1.22
  • libsss_idmap-devel >= 1.16.1-1.22
  • libsss_idmap0 >= 1.16.1-1.22
  • libsss_nss_idmap-devel >= 1.16.1-1.22
  • libsss_nss_idmap0 >= 1.16.1-1.22
  • libsss_simpleifp-devel >= 1.16.1-1.22
  • libsss_simpleifp0 >= 1.16.1-1.22
  • python3-sssd-config >= 1.16.1-1.22
  • sssd >= 1.16.1-1.22
  • sssd-32bit >= 1.16.1-1.22
  • sssd-ad >= 1.16.1-1.22
  • sssd-ipa >= 1.16.1-1.22
  • sssd-krb5 >= 1.16.1-1.22
  • sssd-krb5-common >= 1.16.1-1.22
  • sssd-ldap >= 1.16.1-1.22
  • sssd-proxy >= 1.16.1-1.22
  • sssd-tools >= 1.16.1-1.22
  • sssd-wbclient >= 1.16.1-1.22
  • sssd-wbclient-devel >= 1.16.1-1.22
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libipa_hbac-devel-1.16.1-1.22
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libipa_hbac-devel >= 1.11.5.1-28.1
  • libipa_hbac0 >= 1.11.5.1-28.1
  • libsss_idmap-devel >= 1.11.5.1-28.1
  • libsss_idmap0 >= 1.11.5.1-28.1
  • libsss_nss_idmap-devel >= 1.11.5.1-28.1
  • libsss_nss_idmap0 >= 1.11.5.1-28.1
  • libsss_sudo >= 1.11.5.1-28.1
  • python-sssd-config >= 1.11.5.1-28.1
  • sssd >= 1.11.5.1-28.1
  • sssd-32bit >= 1.11.5.1-28.1
  • sssd-ad >= 1.11.5.1-28.1
  • sssd-ipa >= 1.11.5.1-28.1
  • sssd-krb5 >= 1.11.5.1-28.1
  • sssd-krb5-common >= 1.11.5.1-28.1
  • sssd-ldap >= 1.11.5.1-28.1
  • sssd-proxy >= 1.11.5.1-28.1
  • sssd-tools >= 1.11.5.1-28.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1513
SUSE-SLE-SERVER-12-SP1-2016-1513
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libipa_hbac-devel >= 1.11.5.1-28.1
  • libsss_idmap-devel >= 1.11.5.1-28.1
  • libsss_nss_idmap-devel >= 1.11.5.1-28.1
  • libsss_nss_idmap0 >= 1.11.5.1-28.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1513
openSUSE Tumbleweed
  • libipa_hbac-devel >= 1.14.2-3.1
  • libipa_hbac0 >= 1.14.2-3.1
  • libnfsidmap-sss >= 1.14.2-3.1
  • libsss_idmap-devel >= 1.14.2-3.1
  • libsss_idmap0 >= 1.14.2-3.1
  • libsss_nss_idmap-devel >= 1.14.2-3.1
  • libsss_nss_idmap0 >= 1.14.2-3.1
  • libsss_simpleifp-devel >= 1.14.2-3.1
  • libsss_simpleifp0 >= 1.14.2-3.1
  • python-ipa_hbac >= 1.14.2-3.1
  • python-sss-murmur >= 1.14.2-3.1
  • python-sss_nss_idmap >= 1.14.2-3.1
  • python-sssd-config >= 1.14.2-3.1
  • python3-ipa_hbac >= 1.14.2-3.1
  • python3-sss-murmur >= 1.14.2-3.1
  • python3-sss_nss_idmap >= 1.14.2-3.1
  • python3-sssd-config >= 1.14.2-3.1
  • sssd >= 1.14.2-3.1
  • sssd-32bit >= 1.14.2-3.1
  • sssd-ad >= 1.14.2-3.1
  • sssd-dbus >= 1.14.2-3.1
  • sssd-ipa >= 1.14.2-3.1
  • sssd-krb5 >= 1.14.2-3.1
  • sssd-krb5-common >= 1.14.2-3.1
  • sssd-ldap >= 1.14.2-3.1
  • sssd-proxy >= 1.14.2-3.1
  • sssd-tools >= 1.14.2-3.1
  • sssd-wbclient >= 1.14.2-3.1
  • sssd-wbclient-devel >= 1.14.2-3.1
  • sssd-winbind-idmap >= 1.14.2-3.1
Patchnames:
openSUSE Tumbleweed GA libipa_hbac-devel-1.14.2-3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Server 12-LTSS sssd Ignore
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Server 12 SP2-BCL sssd Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 sssd Not affected
SUSE Linux Enterprise Desktop 11 SP3 sssd Not affected
SUSE Linux Enterprise Desktop 11 SP4 sssd Not affected
SUSE Linux Enterprise Desktop 12 sssd Ignore
SUSE Linux Enterprise Desktop 12 SP1 sssd Released
SUSE Linux Enterprise Desktop 12 SP2 sssd Not affected
SUSE Linux Enterprise Desktop 12 SP3 sssd Not affected
SUSE Linux Enterprise Server 11 SP3 sssd Unsupported
SUSE Linux Enterprise Server 11 SP3-LTSS sssd Not affected
SUSE Linux Enterprise Server 11 SP4 sssd Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS sssd Not affected
SUSE Linux Enterprise Server 12 sssd Ignore
SUSE Linux Enterprise Server 12 SP1 sssd Released
SUSE Linux Enterprise Server 12 SP1-LTSS sssd Affected
SUSE Linux Enterprise Server 12 SP2 sssd Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS sssd Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS sssd Not affected
SUSE Linux Enterprise Server 12 SP3 sssd Not affected
SUSE Linux Enterprise Server 12 SP3-BCL sssd Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS sssd Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS sssd Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 sssd Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 sssd Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 sssd Not affected
SUSE Linux Enterprise Server for SAP Applications 12 sssd Ignore
SUSE Linux Enterprise Server for SAP Applications 12 SP1 sssd Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sssd Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 sssd Not affected
SUSE Linux Enterprise Software Development Kit 11 SP3 sssd Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 sssd Not affected
SUSE Linux Enterprise Software Development Kit 12 sssd Ignore
SUSE Linux Enterprise Software Development Kit 12 SP1 sssd Released
SUSE Linux Enterprise Software Development Kit 12 SP2 sssd Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 sssd Not affected
SUSE OpenStack Cloud 7 sssd Not affected
SUSE OpenStack Cloud 8 sssd Not affected
SUSE OpenStack Cloud Crowbar 8 sssd Not affected


SUSE Timeline for this CVE

CVE page created: Wed Sep 1 12:32:57 2010
CVE page last modified: Tue Jan 17 12:35:04 2023