Upstream information

CVE-2012-5576 at MITRE

Description

Multiple stack-based buffer overflows in file-xwd.c in the X Window Dump (XWD) plug-in in GIMP 2.8.2 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large (1) red, (2) green, or (3) blue color mask in an XWD file.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.48
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial

This issue is currently rated as having low severity.

SUSE Bugzilla entry: 791372 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • gimp >= 2.6.2-3.34.45.1
  • gimp-lang >= 2.6.2-3.34.45.1
  • gimp-plugins-python >= 2.6.2-3.34.45.1
Patchnames:
sledsp3-gimp
SUSE Linux Enterprise Software Development Kit 11 SP3
  • gimp >= 2.6.2-3.34.45.1
  • gimp-devel >= 2.6.2-3.34.45.1
  • gimp-lang >= 2.6.2-3.34.45.1
  • gimp-plugins-python >= 2.6.2-3.34.45.1
Patchnames:
sdksp3-gimp
SUSE Linux Enterprise Software Development Kit 11 SP3
  • gimp >= 2.6.2-3.34.45.1
  • gimp-devel >= 2.6.2-3.34.45.1
  • gimp-lang >= 2.6.2-3.34.45.1
  • gimp-plugins-python >= 2.6.2-3.34.45.1
Builds
SAT Patch Nr: 8856
SUSE Linux Enterprise Desktop 11 SP3
  • gimp >= 2.6.2-3.34.45.1
  • gimp-lang >= 2.6.2-3.34.45.1
  • gimp-plugins-python >= 2.6.2-3.34.45.1
Builds
SAT Patch Nr: 8856
openSUSE 13.2
  • gimp >= 2.8.14-1.5
  • gimp-help-browser >= 2.8.14-1.5
  • gimp-plugin-aa >= 2.8.14-1.5
  • gimp-plugins-python >= 2.8.14-1.5
  • libgimp-2_0-0 >= 2.8.14-1.5
  • libgimpui-2_0-0 >= 2.8.14-1.5
Patchnames:
openSUSE 13.2 GA gimp
openSUSE Evergreen 11.4
  • gimp >= 2.6.11-13.62.1
  • gimp-branding-upstream >= 2.6.11-13.62.1
  • gimp-debuginfo >= 2.6.11-13.62.1
  • gimp-debugsource >= 2.6.11-13.62.1
  • gimp-devel >= 2.6.11-13.62.1
  • gimp-devel-debuginfo >= 2.6.11-13.62.1
  • gimp-help-browser >= 2.6.11-13.62.1
  • gimp-help-browser-debuginfo >= 2.6.11-13.62.1
  • gimp-lang >= 2.6.11-13.62.1
  • gimp-module-hal >= 2.6.11-13.62.1
  • gimp-module-hal-debuginfo >= 2.6.11-13.62.1
  • gimp-plugins-python >= 2.6.11-13.62.1
  • gimp-plugins-python-debuginfo >= 2.6.11-13.62.1
  • libgimp-2_0-0 >= 2.6.11-13.62.1
  • libgimp-2_0-0-32bit >= 2.6.11-13.62.1
  • libgimp-2_0-0-debuginfo >= 2.6.11-13.62.1
  • libgimp-2_0-0-debuginfo-32bit >= 2.6.11-13.62.1
  • libgimp-2_0-0-debuginfo-x86 >= 2.6.11-13.62.1
  • libgimp-2_0-0-x86 >= 2.6.11-13.62.1
  • libgimpui-2_0-0 >= 2.6.11-13.62.1
  • libgimpui-2_0-0-32bit >= 2.6.11-13.62.1
  • libgimpui-2_0-0-debuginfo >= 2.6.11-13.62.1
  • libgimpui-2_0-0-debuginfo-32bit >= 2.6.11-13.62.1
  • libgimpui-2_0-0-debuginfo-x86 >= 2.6.11-13.62.1
  • libgimpui-2_0-0-x86 >= 2.6.11-13.62.1
Patchnames:
2012-17
openSUSE Leap 42.1
  • gimp >= 2.8.14-2.7
  • gimp-help-browser >= 2.8.14-2.7
  • gimp-lang >= 2.8.14-2.7
  • gimp-plugin-aa >= 2.8.14-2.7
  • gimp-plugins-python >= 2.8.14-2.7
  • libgimp-2_0-0 >= 2.8.14-2.7
  • libgimpui-2_0-0 >= 2.8.14-2.7
Patchnames:
openSUSE Leap 42.1 GA gimp
openSUSE Leap 42.2
  • gimp >= 2.8.18-1.4
  • gimp-help-browser >= 2.8.18-1.4
  • gimp-lang >= 2.8.18-1.4
  • gimp-plugin-aa >= 2.8.18-1.4
  • gimp-plugins-python >= 2.8.18-1.4
  • libgimp-2_0-0 >= 2.8.18-1.4
  • libgimpui-2_0-0 >= 2.8.18-1.4
Patchnames:
openSUSE Leap 42.2 GA gimp


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Desktop 10 SP4
  • SUSE Linux Enterprise Desktop 11 SP2
  • SUSE Linux Enterprise SDK 11 SP2
gimp