Upstream information

CVE-2011-3919 at MITRE

Description

Heap-based buffer overflow in libxml2, as used in Google Chrome before 16.0.912.75, allows remote attackers to cause a denial of service or possibly have unspecified other impact via unknown vectors.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 739894 [RESOLVED / FIXED], 740493 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libxml2 >= 2.7.6-0.13.1
  • libxml2-32bit >= 2.7.6-0.13.1
  • libxml2-doc >= 2.7.6-0.13.1
  • libxml2-python >= 2.7.6-0.25.1
  • libxml2-x86 >= 2.7.6-0.19.1
Patchnames:
slessp1-libxml2
SUSE Linux Enterprise Server 11 SP2
  • libxml2 >= 2.7.6-0.13.1
  • libxml2-32bit >= 2.7.6-0.13.1
  • libxml2-doc >= 2.7.6-0.13.1
  • libxml2-x86 >= 2.7.6-0.13.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libxml2
SUSE Linux Enterprise Server 11 SP3
  • libxml2 >= 2.7.6-0.23.1
  • libxml2-32bit >= 2.7.6-0.23.1
  • libxml2-doc >= 2.7.6-0.23.1
  • libxml2-x86 >= 2.7.6-0.23.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libxml2
SUSE Linux Enterprise Server 11 SP4
  • libxml2 >= 2.7.6-0.31.1
  • libxml2-32bit >= 2.7.6-0.31.1
  • libxml2-doc >= 2.7.6-0.31.1
  • libxml2-x86 >= 2.7.6-0.31.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libxml2
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libxml2-devel >= 2.7.6-0.31.1
  • libxml2-devel-32bit >= 2.7.6-0.31.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libxml2-devel
openSUSE 11.3
  • libxml2-debuginfo >= 2.7.7-4.11.1
  • libxml2-debuginfo-32bit >= 2.7.7-4.11.1
  • libxml2-debugsource >= 2.7.7-4.11.1
openSUSE 11.3
  • libxml2 >= 2.7.7-4.11.1
  • libxml2-32bit >= 2.7.7-4.11.1
  • libxml2-devel >= 2.7.7-4.11.1
  • libxml2-devel-32bit >= 2.7.7-4.11.1
  • libxml2-doc >= 2.7.7-4.11.1
openSUSE 11.4
  • libxml2 >= 2.7.8-16.21.1
  • libxml2-32bit >= 2.7.8-16.21.1
  • libxml2-devel >= 2.7.8-16.21.1
  • libxml2-devel-32bit >= 2.7.8-16.21.1
  • libxml2-doc >= 2.7.8-16.21.1
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • libxml2 >= 2.6.23-15.27.1
  • libxml2-devel >= 2.6.23-15.27.1
sled10-sp4.x86-64
sles10-sp4.ia64
sles10-sp4-debuginfo.x86
sles10-sp4.x86-64
sles10-sp4-debuginfo.x86-64
sles10-sp4-debuginfo.s390x
sled10-sp4.x86
sles10-sp4.x86
sles10-sp4-debuginfo.ppc
sles10-sp4-debuginfo.ia64
sles10-sp4.ppc
sles10-sp4.s390x
ZYPP Patch Nr: 7929
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • libxml2 >= 2.6.23-15.27.1
  • libxml2-32bit >= 2.6.23-15.27.1
  • libxml2-devel >= 2.6.23-15.27.1
  • libxml2-devel-32bit >= 2.6.23-15.27.1
sled10-sp4.x86-64
sles10-sp4.ia64
sles10-sp4-debuginfo.x86
sles10-sp4.x86-64
sles10-sp4-debuginfo.x86-64
sles10-sp4-debuginfo.s390x
sled10-sp4.x86
sles10-sp4.x86
sles10-sp4-debuginfo.ppc
sles10-sp4-debuginfo.ia64
sles10-sp4.ppc
sles10-sp4.s390x
ZYPP Patch Nr: 7929
SUSE Linux Enterprise Server 10 SP4 for IPF
  • libxml2 >= 2.6.23-15.27.1
  • libxml2-devel >= 2.6.23-15.27.1
  • libxml2-x86 >= 2.6.23-15.27.1
sled10-sp4.x86-64
sles10-sp4.ia64
sles10-sp4-debuginfo.x86
sles10-sp4.x86-64
sles10-sp4-debuginfo.x86-64
sles10-sp4-debuginfo.s390x
sled10-sp4.x86
sles10-sp4.x86
sles10-sp4-debuginfo.ppc
sles10-sp4-debuginfo.ia64
sles10-sp4.ppc
sles10-sp4.s390x
ZYPP Patch Nr: 7929
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • libxml2 >= 2.6.23-15.27.1
  • libxml2-64bit >= 2.6.23-15.27.1
  • libxml2-devel >= 2.6.23-15.27.1
  • libxml2-devel-64bit >= 2.6.23-15.27.1
sled10-sp4.x86-64
sles10-sp4.ia64
sles10-sp4-debuginfo.x86
sles10-sp4.x86-64
sles10-sp4-debuginfo.x86-64
sles10-sp4-debuginfo.s390x
sled10-sp4.x86
sles10-sp4.x86
sles10-sp4-debuginfo.ppc
sles10-sp4-debuginfo.ia64
sles10-sp4.ppc
sles10-sp4.s390x
ZYPP Patch Nr: 7929
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • libxml2 >= 2.6.23-15.39.1
  • libxml2-devel >= 2.6.23-15.39.1
  • libxml2-python >= 2.6.23-15.39.1
Builds
ZYPP Patch Nr: 8714
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • libxml2 >= 2.6.23-15.39.1
  • libxml2-32bit >= 2.6.23-15.39.1
  • libxml2-devel >= 2.6.23-15.39.1
  • libxml2-devel-32bit >= 2.6.23-15.39.1
  • libxml2-python >= 2.6.23-15.39.1
Builds
ZYPP Patch Nr: 8714
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • libxml2 >= 2.6.23-15.39.1
  • libxml2-devel >= 2.6.23-15.39.1
  • libxml2-python >= 2.6.23-15.39.1
Builds
ZYPP Patch Nr: 8716
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
  • libxml2 >= 2.6.23-15.39.1
  • libxml2-32bit >= 2.6.23-15.39.1
  • libxml2-devel >= 2.6.23-15.39.1
  • libxml2-devel-32bit >= 2.6.23-15.39.1
  • libxml2-python >= 2.6.23-15.39.1
Builds
ZYPP Patch Nr: 8716
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libxml2-devel >= 2.7.6-0.13.1
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1-vmware.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1.x86
sled11-sp1.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86-64
sles11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
sle11-sp1-sdk.ppc
SAT Patch Nr: 5654
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libxml2-devel >= 2.7.6-0.13.1
  • libxml2-devel-32bit >= 2.7.6-0.13.1
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1-vmware.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1.x86
sled11-sp1.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86-64
sles11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
sle11-sp1-sdk.ppc
SAT Patch Nr: 5654
SUSE Linux Enterprise Desktop 11 SP1
  • libxml2 >= 2.7.6-0.13.1
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1-vmware.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1.x86
sled11-sp1.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86-64
sles11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
sle11-sp1-sdk.ppc
SAT Patch Nr: 5654
SUSE Linux Enterprise Desktop 11 SP1
  • libxml2 >= 2.7.6-0.13.1
  • libxml2-32bit >= 2.7.6-0.13.1
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1-vmware.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1.x86
sled11-sp1.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86-64
sles11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
sle11-sp1-sdk.ppc
SAT Patch Nr: 5654
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libxml2 >= 2.7.6-0.13.1
  • libxml2-32bit >= 2.7.6-0.13.1
  • libxml2-doc >= 2.7.6-0.13.1
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1-vmware.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1.x86
sled11-sp1.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86-64
sles11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
sle11-sp1-sdk.ppc
SAT Patch Nr: 5654
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libxml2 >= 2.7.6-0.13.1
  • libxml2-doc >= 2.7.6-0.13.1
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1-vmware.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1.x86
sled11-sp1.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86-64
sles11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
sle11-sp1-sdk.ppc
SAT Patch Nr: 5654
SUSE Linux Enterprise Server 11 SP1
  • libxml2 >= 2.7.6-0.13.1
  • libxml2-doc >= 2.7.6-0.13.1
  • libxml2-x86 >= 2.7.6-0.13.1
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1-vmware.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1.x86
sled11-sp1.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86-64
sles11-sp1.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
sle11-sp1-sdk.ppc
SAT Patch Nr: 5654
openSUSE 11.4
  • libxml2 >= 2.7.8-16.21.1
  • libxml2-32bit >= 2.7.8-16.21.1
  • libxml2-debuginfo >= 2.7.8-16.21.1
  • libxml2-debuginfo-32bit >= 2.7.8-16.21.1
  • libxml2-debugsource >= 2.7.8-16.21.1
  • libxml2-devel >= 2.7.8-16.21.1
  • libxml2-devel-32bit >= 2.7.8-16.21.1
  • libxml2-doc >= 2.7.8-16.21.1
Patchnames:
libxml2
openSUSE Tumbleweed
  • chromedriver >= 55.0.2883.75-3.1
  • chromium >= 55.0.2883.75-3.1
Patchnames:
openSUSE Tumbleweed GA chromedriver


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 libxml2 Released
SUSE Linux Enterprise Desktop 10 SP4 libxml2 Released
SUSE Linux Enterprise Desktop 11 SP1 libxml2 Released
SUSE Linux Enterprise Desktop 11 SP2 libxml2 Released
SUSE Linux Enterprise Desktop 11 SP3 libxml2 Released
SUSE Linux Enterprise Desktop 11 SP4 libxml2 Released
SUSE Linux Enterprise SDK 11 SP1 libxml2 Released
SUSE Linux Enterprise SDK 11 SP2 libxml2 Released
SUSE Linux Enterprise SDK 11 SP3 libxml2 Released
SUSE Linux Enterprise SDK 11 SP4 libxml2 Released
SUSE Linux Enterprise Server 10 SP3 libxml2 Released
SUSE Linux Enterprise Server 10 SP4 libxml2 Released
SUSE Linux Enterprise Server 10 SP4 LTSS libxml2 Released
SUSE Linux Enterprise Server 11 SP1 libxml2 Released
SUSE Linux Enterprise Server 11 SP1 LTSS libxml2 Released
SUSE Linux Enterprise Server 11 SP2 libxml2 Released
SUSE Linux Enterprise Server 11 SP2 LTSS libxml2 Released
SUSE Linux Enterprise Server 11 SP3 libxml2 Released
SUSE Linux Enterprise Server 11 SP3 LTSS libxml2 Released
SUSE Linux Enterprise Server 11 SP4 libxml2 Released
SUSE Linux Enterprise Server for SAP 11 SP2 libxml2 Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 libxml2 Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 libxml2 Released