CVE-2011-3207

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2011-3207 at MITRE

Description

crypto/x509/x509_vfy.c in OpenSSL 1.0.x before 1.0.0e does not initialize certain structure members, which makes it easier for remote attackers to bypass CRL validation by using a nextUpdate value corresponding to a time in the past.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.96
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None

Note from the SUSE Security Team

This issue affects only openssl versions 1.0.0 and above, so SUSE Linux Enterprise 10 or 11 are not affected. Only openSUSE 11.3 and 11.4 are affected and will receive updates.

SUSE Bugzilla entry: 716143 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.3
  • libopenssl0_9_8-debuginfo >= 0.9.8m-3.9.1
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8m-3.9.1
  • libopenssl0_9_8-debugsource >= 0.9.8m-3.9.1
  • libopenssl1_0_0-debuginfo >= 1.0.0-6.11.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.0-6.11.1
  • openssl-debuginfo >= 1.0.0-6.11.1
  • openssl-debugsource >= 1.0.0-6.11.1
openSUSE 11.3
  • libopenssl-devel >= 1.0.0-6.11.1
  • libopenssl0_9_8 >= 0.9.8m-3.9.1
  • libopenssl0_9_8-32bit >= 0.9.8m-3.9.1
  • libopenssl1_0_0 >= 1.0.0-6.11.1
  • libopenssl1_0_0-32bit >= 1.0.0-6.11.1
  • openssl >= 1.0.0-6.11.1
  • openssl-doc >= 1.0.0-6.11.1
openSUSE 11.4
  • libopenssl-devel >= 1.0.0c-18.21.1
  • libopenssl0_9_8 >= 0.9.8m-6.7.1
  • libopenssl0_9_8-32bit >= 0.9.8m-6.7.1
  • libopenssl1_0_0 >= 1.0.0c-18.21.1
  • libopenssl1_0_0-32bit >= 1.0.0c-18.21.1
  • openssl >= 1.0.0c-18.21.1
  • openssl-doc >= 1.0.0c-18.21.1
openSUSE 11.4
  • libopenssl-devel >= 1.0.0c-18.21.1
  • libopenssl0_9_8 >= 0.9.8m-6.7.1
  • libopenssl0_9_8-32bit >= 0.9.8m-6.7.1
  • libopenssl0_9_8-debuginfo >= 0.9.8m-6.7.1
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8m-6.7.1
  • libopenssl0_9_8-debugsource >= 0.9.8m-6.7.1
  • libopenssl1_0_0 >= 1.0.0c-18.21.1
  • libopenssl1_0_0-32bit >= 1.0.0c-18.21.1
  • libopenssl1_0_0-debuginfo >= 1.0.0c-18.21.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.0c-18.21.1
  • openssl >= 1.0.0c-18.21.1
  • openssl-debuginfo >= 1.0.0c-18.21.1
  • openssl-debugsource >= 1.0.0c-18.21.1
  • openssl-doc >= 1.0.0c-18.21.1
Patchnames:
libopenssl-devel