Upstream information

CVE-2011-0524 at MITRE

Description

Multiple buffer overflows in the NMEA parser (nmea-gen.c) in gypsy 0.8 allow local users to cause a denial of service (crash) via unspecified vectors related to the sprintf function.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 666839 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Software Development Kit 12
  • libgypsy0 >= 0.9-6.24
SUSE Linux Enterprise Module for Desktop Applications 15
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • libgypsy-devel >= 0.9-2.30
  • libgypsy0 >= 0.9-2.30
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libgypsy0 >= 0.9-6.22
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libgypsy-devel >= 0.9-6.24
  • libgypsy0 >= 0.9-6.24
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libgypsy-devel >= 0.9-6.24
openSUSE Leap 15.0
  • libgypsy0 >= 0.9-lp150.2.5
Patchnames:
openSUSE Leap 15.0 GA libgypsy0-0.9-lp150.2.5
openSUSE Tumbleweed
  • gypsy >= 0.9-10.5
  • libgypsy-devel >= 0.9-10.5
  • libgypsy0 >= 0.9-10.5
  • libgypsy0-32bit >= 0.9-10.5
Patchnames:
openSUSE Tumbleweed GA gypsy-0.9-10.5