Upstream information

CVE-2010-4091 at MITRE

Description

The EScript.api plugin in Adobe Reader and Acrobat 10.x before 10.0.1, 9.x before 9.4.1, and 8.x before 8.2.6 on Windows and Mac OS X allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a crafted PDF document that triggers memory corruption, involving the printSeps function. NOTE: some of these details are obtained from third party information.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 651232 [RESOLVED / FIXED], 656765 [RESOLVED / DUPLICATE], 669550 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.2
  • acroread >= 9.4.2-0.2.1
  • acroread-cmaps >= 9.4.2-0.2.1
  • acroread-fonts-ja >= 9.4.2-0.2.1
  • acroread-fonts-ko >= 9.4.2-0.2.1
  • acroread-fonts-zh_CN >= 9.4.2-0.2.1
  • acroread-fonts-zh_TW >= 9.4.2-0.2.1
openSUSE 11.3
  • acroread >= 9.4.2-0.2.1
SUSE Linux Enterprise Desktop 11 GA
  • acroread >= 9.4.1-0.1.1
sled11.x86-64
sled11.x86
SAT Patch Nr: 3634
SUSE Linux Enterprise Desktop 11 GA
  • acroread_ja >= 9.4.1-0.1.1
sled11.x86
sled11.x86-64
SAT Patch Nr: 3638
SUSE Linux Enterprise 11 Moblin 2.1
  • acroread >= 9.4.1-0.1.1
SAT Patch Nr: 3637
SUSE Linux Enterprise Desktop 11 SP1
  • acroread_ja >= 9.4.1-0.1.1
sled11-sp1.x86
sled11-sp1.x86-64
SAT Patch Nr: 3639
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • acroread_ja >= 9.4.2-0.5.1
sled10-sp3.x86
sled10-sp3.x86
sled10-sp3.x86-64
ZYPP Patch Nr: 7359
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • acroread >= 9.4.1-0.4.1
sled10-sp3.x86-64
sled10-sp3.x86
ZYPP Patch Nr: 7266
SUSE Linux Enterprise 11 Moblin 2.0
  • acroread-debuginfo >= 9.4.1-0.1.1
SAT Patch Nr: 3635
SUSE Linux Enterprise 11 Moblin 2.0
  • acroread >= 9.4.1-0.1.1
SAT Patch Nr: 3635
SUSE Linux Enterprise Desktop 11 SP1
  • acroread_ja >= 9.4.2-0.2.1
sled11-sp1.x86
sled11-sp1.x86-64
SAT Patch Nr: 4058
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • acroread_ja >= 9.4.1-0.4.1
sled10-sp3.x86
sled10-sp3.x86-64
ZYPP Patch Nr: 7267
openSUSE 11.1
openSUSE 11.2
  • acroread >= 9.4.1-0.2.1
  • acroread-cmaps >= 9.4.1-0.2.1
  • acroread-fonts-ja >= 9.4.1-0.2.1
  • acroread-fonts-ko >= 9.4.1-0.2.1
  • acroread-fonts-zh_CN >= 9.4.1-0.2.1
  • acroread-fonts-zh_TW >= 9.4.1-0.2.1
openSUSE 11.3
  • acroread >= 9.4.1-0.2.1
SUSE Linux Enterprise Desktop 11 SP1
  • acroread >= 9.4.2-0.2.1
  • acroread-cmaps >= 9.4.2-0.2.1
  • acroread-fonts-ja >= 9.4.2-0.2.1
  • acroread-fonts-ko >= 9.4.2-0.2.1
  • acroread-fonts-zh_CN >= 9.4.2-0.2.1
  • acroread-fonts-zh_TW >= 9.4.2-0.2.1
sled11-sp1.x86-64
sled11-sp1.x86
SAT Patch Nr: 4057
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • acroread >= 9.4.2-0.5.1
  • acroread-cmaps >= 9.4.2-0.5.1
  • acroread-fonts-ja >= 9.4.2-0.5.1
  • acroread-fonts-ko >= 9.4.2-0.5.1
  • acroread-fonts-zh_CN >= 9.4.2-0.5.1
  • acroread-fonts-zh_TW >= 9.4.2-0.5.1
sled10-sp3.x86
sled10-sp3.x86-64
sled10-sp3.x86
ZYPP Patch Nr: 7358
SUSE Linux Enterprise Desktop 11 SP1
  • acroread >= 9.4.1-0.1.1
sled11-sp1.x86-64
sled11-sp1.x86
SAT Patch Nr: 3636


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 acroread Released
SUSE Linux Enterprise Desktop 10 SP4 acroread Released
SUSE Linux Enterprise Desktop 11 GA acroread Released
SUSE Linux Enterprise Desktop 11 SP1 acroread Released
SUSE Linux Enterprise Desktop 11 SP2 acroread Released
SUSE Linux Enterprise Desktop 11 SP3 acroread Released
SUSE Linux Enterprise Desktop 11 SP4 acroread Released