Upstream information

CVE-2007-1558 at MITRE

Description

The APOP protocol allows remote attackers to guess the first 3 characters of a password via man-in-the-middle (MITM) attacks that use crafted message IDs and MD5 collisions. NOTE: this design-level issue potentially affects all products that use APOP, including (1) Thunderbird 1.x before 1.5.0.12 and 2.x before 2.0.0.4, (2) Evolution, (3) mutt, (4) fetchmail before 6.3.8, (5) SeaMonkey 1.0.x before 1.0.9 and 1.1.x before 1.1.2, (6) Balsa 2.3.16 and earlier, (7) Mailfilter before 0.8.2, and possibly other products.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.6
Vector AV:N/AC:H/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 262450 [RESOLVED / INVALID], 271197 [RESOLVED / FIXED], 279843 [RESOLVED / FIXED], 281321 [RESOLVED / FIXED], 281323 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • fetchmail >= 6.3.8.90-13.16.1
  • fetchmailconf >= 6.3.8.90-13.16.1
  • mutt >= 1.5.17-42.33.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA fetchmail-6.3.8.90-13.16.1
SUSE Linux Enterprise Server 11 SP1 GA mutt-1.5.17-42.33.1
SUSE Linux Enterprise Server 11 SP2
  • fetchmail >= 6.3.8.90-13.20.19.1
  • fetchmailconf >= 6.3.8.90-13.20.19.1
  • mutt >= 1.5.17-42.33.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA fetchmail-6.3.8.90-13.20.19.1
SUSE Linux Enterprise Server 11 SP2 GA mutt-1.5.17-42.33.1
SUSE Linux Enterprise Server 11 SP3
  • fetchmail >= 6.3.8.90-13.20.19.1
  • fetchmailconf >= 6.3.8.90-13.20.19.1
  • mutt >= 1.5.17-42.33.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA fetchmail-6.3.8.90-13.20.19.1
SUSE Linux Enterprise Server 11 SP3 GA mutt-1.5.17-42.33.1
SUSE Linux Enterprise Server 11 SP4
  • fetchmail >= 6.3.8.90-13.20.19.1
  • fetchmailconf >= 6.3.8.90-13.20.19.1
  • mutt >= 1.5.17-42.39.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA fetchmail-6.3.8.90-13.20.19.1
SUSE Linux Enterprise Server 11 SP4 GA mutt-1.5.17-42.39.1
openSUSE Tumbleweed
  • claws-mail >= 4.0.0-2.5
  • claws-mail-devel >= 4.0.0-2.5
  • claws-mail-lang >= 4.0.0-2.5
  • fetchmail >= 6.4.21-2.1
  • fetchmailconf >= 6.4.21-2.1
  • mpop >= 1.4.14-1.1
  • mpop-doc >= 1.4.14-1.1
  • mutt >= 2.0.7-2.2
  • mutt-doc >= 2.0.7-2.2
  • mutt-lang >= 2.0.7-2.2
Patchnames:
openSUSE Tumbleweed GA claws-mail-4.0.0-2.5
openSUSE Tumbleweed GA fetchmail-6.4.21-2.1
openSUSE Tumbleweed GA mpop-1.4.14-1.1
openSUSE Tumbleweed GA mutt-2.0.7-2.2