Upstream information

CVE-2007-1536 at MITRE

Description

Integer underflow in the file_printf function in the "file" program before 4.20 allows user-assisted attackers to execute arbitrary code via a file that triggers a heap-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 256290 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • file-devel >= 4.24-43.27.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA file-devel-4.24-43.27.1
SUSE Linux Enterprise Server 11 SP1
  • file >= 4.24-43.17
  • file-32bit >= 4.24-43.17
  • file-x86 >= 4.24-43.17
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA file-32bit-4.24-43.17
SUSE Linux Enterprise Server 11 SP2
  • file >= 4.24-43.19.1
  • file-32bit >= 4.24-43.19.1
  • file-x86 >= 4.24-43.19.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA file-32bit-4.24-43.19.1
SUSE Linux Enterprise Server 11 SP3
  • file >= 4.24-43.23.1
  • file-32bit >= 4.24-43.23.1
  • file-x86 >= 4.24-43.23.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA file-32bit-4.24-43.23.1
SUSE Linux Enterprise Server 11 SP4
  • file >= 4.24-43.27.1
  • file-32bit >= 4.24-43.27.1
  • file-devel >= 4.24-43.27.1
  • file-x86 >= 4.24-43.27.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA file-32bit-4.24-43.27.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA file-devel-4.24-43.27.1
openSUSE Tumbleweed
  • file >= 5.40-1.14
  • file-devel >= 5.40-1.14
  • file-devel-32bit >= 5.40-1.14
  • file-magic >= 5.40-1.14
  • libmagic1 >= 5.40-1.14
  • libmagic1-32bit >= 5.40-1.14
Patchnames:
openSUSE Tumbleweed GA file-5.40-1.14