Upstream information

CVE-2006-6235 at MITRE

Description

A "stack overwrite" vulnerability in GnuPG (gpg) 1.x before 1.4.6, 2.x before 2.0.2, and 1.9.0 through 1.9.95 allows attackers to execute arbitrary code via crafted OpenPGP packets that cause GnuPG to dereference a function pointer from deallocated stack memory.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 225694 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux Desktop 1.0
  • gpg >= 1.2.2rc1-125
slrs8.x86
ul1.s390
sled10.x86
sles10.s390x
sles9-oes.x86
core9.s390
ZYPP Patch Nr: 2355
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • gpg >= 1.0.7-190
slrs8.x86
ul1.s390
sled10.x86
sles10.s390x
sles9-oes.x86
core9.s390
ZYPP Patch Nr: 2355
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • gpg >= 1.2.4-68.22
slrs8.x86
ul1.s390
sled10.x86
sles10.s390x
sles9-oes.x86
core9.s390
ZYPP Patch Nr: 2355
SUSE LINUX 10.0
  • gpg >= 1.4.2-5.11
SUSE LINUX 10.1
  • gpg >= 1.4.2-23.12
SUSE LINUX 9.3
  • gpg >= 1.4.0-4.11
SUSE LINUX 10.0
  • gpg2 >= 1.9.18-2.11
SUSE LINUX 10.1
  • gpg2 >= 1.9.18-17.13
SUSE LINUX 9.3
  • gpg2 >= 1.9.14-6.13
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • gpg2 >= 1.9.10-2.12
sles10.s390x
sled10.x86
ZYPP Patch Nr: 2354