Upstream information

CVE-2019-6286 at MITRE

Description

In LibSass 3.5.5, a heap-based buffer over-read exists in Sass::Prelexer::skip_over_scopes in prelexer.hpp when called from Sass::Parser::parse_import(), a similar issue to CVE-2018-11693.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.0
SUSE Bugzilla entry: 1121945 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • libsass >= 3.6.1-lp150.2.3.1
  • libsass-3_6_1-1 >= 3.6.1-lp150.2.3.1
  • libsass-3_6_1-1-debuginfo >= 3.6.1-lp150.2.3.1
  • libsass-debugsource >= 3.6.1-lp150.2.3.1
  • libsass-devel >= 3.6.1-lp150.2.3.1
Patchnames:
openSUSE-2019-1791
openSUSE Leap 15.1
  • libsass >= 3.6.1-lp151.3.3.1
  • libsass-3_6_1-1 >= 3.6.1-lp151.3.3.1
  • libsass-3_6_1-1-debuginfo >= 3.6.1-lp151.3.3.1
  • libsass-debugsource >= 3.6.1-lp151.3.3.1
  • libsass-devel >= 3.6.1-lp151.3.3.1
Patchnames:
openSUSE-2019-1791