Upstream information

CVE-2019-12527 at MITRE

Description

An issue was discovered in Squid 4.0.23 through 4.7. When checking Basic Authentication with HttpHeader::getAuth, Squid uses a global buffer to store the decoded data. Squid does not check that the decoded length isn't greater than the buffer, leading to a heap-based buffer overflow with user controlled data.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 9.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1141330 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • squid >= 4.8-2.17
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • squid >= 4.9-5.11.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2019-2975
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • squid >= 4.11-5.17.2
SUSE Linux Enterprise Module for Server Applications 15
  • squid >= 4.9-5.11.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-2975
openSUSE Leap 15.0
  • squid >= 4.9-lp150.13.1
  • squid-debuginfo >= 4.9-lp150.13.1
  • squid-debugsource >= 4.9-lp150.13.1
Patchnames:
openSUSE-2019-2540
openSUSE Leap 15.1
  • squid >= 4.9-lp151.2.7.1
  • squid-debuginfo >= 4.9-lp151.2.7.1
  • squid-debugsource >= 4.9-lp151.2.7.1
Patchnames:
openSUSE-2019-2541


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications squid Not affected
SUSE Linux Enterprise 15 Module for Server Applications squid Released
SUSE Linux Enterprise 15-SP1 Module for Server Applications squid Released
SUSE Linux Enterprise High Performance Computing 12 SP4 squid Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS squid Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS squid Not affected
SUSE Linux Enterprise Server 12 LTSS squid Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS squid Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS squid Not affected
SUSE Linux Enterprise Server 12 SP3 squid Not affected
SUSE Linux Enterprise Server 12 SP4 squid Not affected
SUSE Linux Enterprise Server for SAP Applications 12 squid Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 squid Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 squid Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 squid Not affected