Upstream information

CVE-2016-8605 at MITRE

Description

The mkdir procedure of GNU Guile temporarily changed the process' umask to zero. During that time window, in a multithreaded application, other threads could end up creating files with insecure permissions. For example, mkdir without the optional mode argument would create directories as 0777. This is fixed in Guile 2.0.13. Prior versions are affected.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 3.2
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N AV:L/AC:L/Au:S/C:P/I:P/A:N
Access Vector Network Local
Access Complexity Low Low
Authentication None Single
Confidentiality Impact None Partial
Integrity Impact Partial Partial
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.3
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3
SUSE Bugzilla entry: 1004221 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • guile >= 2.0.9-8.3
  • guile-modules-2_0 >= 2.0.9-8.3
  • libguile-2_0-22 >= 2.0.9-8.3
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-196
SUSE Linux Enterprise Desktop 12 SP2
  • guile >= 2.0.9-8.3
  • guile-modules-2_0 >= 2.0.9-8.3
  • libguile-2_0-22 >= 2.0.9-8.3
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-196
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
  • guile >= 2.0.9-8.3
  • guile-modules-2_0 >= 2.0.9-8.3
  • libguile-2_0-22 >= 2.0.9-8.3
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • guile >= 2.0.9-9.3.1
  • guile-modules-2_0 >= 2.0.9-9.3.1
  • libguile-2_0-22 >= 2.0.9-9.3.1
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • guile >= 2.0.14-5.3.1
  • guile-devel >= 2.0.14-5.3.1
  • guile-modules-2_0 >= 2.0.14-5.3.1
  • libguile-2_0-22 >= 2.0.14-5.3.1
  • libguilereadline-v-18-18 >= 2.0.14-5.3.1
SUSE Linux Enterprise Module for Development Tools 15
  • guile >= 2.0.14-3.18
  • guile-devel >= 2.0.14-3.18
  • guile-modules-2_0 >= 2.0.14-3.18
  • libguile-2_0-22 >= 2.0.14-3.18
  • libguilereadline-v-18-18 >= 2.0.14-3.18
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • guile >= 1.8.5-24.1
Patchnames:
slessp4-guile-12969
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • guile >= 2.0.9-8.3
  • guile-modules-2_0 >= 2.0.9-8.3
  • libguile-2_0-22 >= 2.0.9-8.3
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-196
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • guile >= 2.0.9-8.3
  • guile-modules-2_0 >= 2.0.9-8.3
  • libguile-2_0-22 >= 2.0.9-8.3
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-196
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • guile >= 2.0.9-8.3
  • guile-modules-2_0 >= 2.0.9-8.3
  • libguile-2_0-22 >= 2.0.9-8.3
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-196
SUSE Linux Enterprise Software Development Kit 11 SP4
  • guile >= 1.8.5-24.1
  • guile-devel >= 1.8.5-24.1
Patchnames:
sdksp4-guile-12969
SUSE Linux Enterprise Software Development Kit 12 SP1
  • guile >= 2.0.9-8.3
  • guile-devel >= 2.0.9-8.3
  • libguilereadline-v-18-18 >= 2.0.9-8.3
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-196
SUSE Linux Enterprise Software Development Kit 12 SP2
  • guile >= 2.0.9-8.3
  • guile-devel >= 2.0.9-8.3
  • libguilereadline-v-18-18 >= 2.0.9-8.3
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-196
SUSE Linux Enterprise Software Development Kit 12 SP3
  • guile-devel >= 2.0.9-8.3
  • libguilereadline-v-18-18 >= 2.0.9-8.3
SUSE Linux Enterprise Software Development Kit 12 SP4
  • guile-devel >= 2.0.9-8.3
  • guile1 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-1-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-13-14-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-4-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-60-v-2-2 >= 1.8.8-16.4.39
  • libguile1-devel >= 1.8.8-16.4.39
  • libguile17 >= 1.8.8-16.4.39
  • libguilereadline-v-17-17 >= 1.8.8-16.4.39
  • libguilereadline-v-18-18 >= 2.0.9-8.3
Patchnames:
SUSE-SLE-SDK-12-SP4-2020-1659
SUSE Linux Enterprise Software Development Kit 12 SP5
  • guile-devel >= 2.0.9-9.3.1
  • guile1 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-1-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-13-14-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-4-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-60-v-2-2 >= 1.8.8-16.4.39
  • libguile1-devel >= 1.8.8-16.4.39
  • libguile17 >= 1.8.8-16.4.39
  • libguilereadline-v-17-17 >= 1.8.8-16.4.39
  • libguilereadline-v-18-18 >= 2.0.9-9.3.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-1659
SUSE Linux Enterprise Workstation Extension 12 SP4
  • guile1 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-1-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-13-14-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-4-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-60-v-2-2 >= 1.8.8-16.4.39
  • libguile17 >= 1.8.8-16.4.39
  • libguilereadline-v-17-17 >= 1.8.8-16.4.39
Patchnames:
SUSE-SLE-WE-12-SP4-2020-1659
SUSE Linux Enterprise Workstation Extension 12 SP5
  • guile1 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-1-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-13-14-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-4-v-3-3 >= 1.8.8-16.4.39
  • libguile-srfi-srfi-60-v-2-2 >= 1.8.8-16.4.39
  • libguile17 >= 1.8.8-16.4.39
  • libguilereadline-v-17-17 >= 1.8.8-16.4.39
Patchnames:
SUSE-SLE-WE-12-SP5-2020-1659
openSUSE Leap 42.1
  • guile >= 2.0.9-7.1
  • guile-debuginfo >= 2.0.9-7.1
  • guile-debugsource >= 2.0.9-7.1
  • guile-devel >= 2.0.9-7.1
  • guile-modules-2_0 >= 2.0.9-7.1
  • guile1 >= 1.8.8-22.1
  • guile1-debuginfo >= 1.8.8-22.1
  • guile1-debugsource >= 1.8.8-22.1
  • libguile-2_0-22 >= 2.0.9-7.1
  • libguile-2_0-22-debuginfo >= 2.0.9-7.1
  • libguile-srfi-srfi-1-v-3-3 >= 1.8.8-22.1
  • libguile-srfi-srfi-1-v-3-3-debuginfo >= 1.8.8-22.1
  • libguile-srfi-srfi-13-14-v-3-3 >= 1.8.8-22.1
  • libguile-srfi-srfi-13-14-v-3-3-debuginfo >= 1.8.8-22.1
  • libguile-srfi-srfi-4-v-3-3 >= 1.8.8-22.1
  • libguile-srfi-srfi-4-v-3-3-debuginfo >= 1.8.8-22.1
  • libguile-srfi-srfi-60-v-2-2 >= 1.8.8-22.1
  • libguile-srfi-srfi-60-v-2-2-debuginfo >= 1.8.8-22.1
  • libguile1-devel >= 1.8.8-22.1
  • libguile17 >= 1.8.8-22.1
  • libguile17-debuginfo >= 1.8.8-22.1
  • libguilereadline-v-17-17 >= 1.8.8-22.1
  • libguilereadline-v-17-17-debuginfo >= 1.8.8-22.1
  • libguilereadline-v-18-18 >= 2.0.9-7.1
  • libguilereadline-v-18-18-debuginfo >= 2.0.9-7.1
Patchnames:
openSUSE-2016-1231
openSUSE-2017-259
openSUSE Leap 42.2
  • guile >= 2.0.9-8.1
  • guile-debuginfo >= 2.0.9-8.1
  • guile-debugsource >= 2.0.9-8.1
  • guile-devel >= 2.0.9-8.1
  • guile-modules-2_0 >= 2.0.9-8.1
  • libguile-2_0-22 >= 2.0.9-8.1
  • libguile-2_0-22-debuginfo >= 2.0.9-8.1
  • libguilereadline-v-18-18 >= 2.0.9-8.1
  • libguilereadline-v-18-18-debuginfo >= 2.0.9-8.1
Patchnames:
openSUSE-2017-259
openSUSE Leap 42.3
  • guile >= 2.0.9-11.14
  • guile-modules-2_0 >= 2.0.9-11.14
  • libguile-2_0-22 >= 2.0.9-11.14
Patchnames:
openSUSE Leap 42.3 GA guile
openSUSE Tumbleweed
  • guile >= 2.0.13-2.1
  • guile-devel >= 2.0.13-2.1
  • guile-modules-2_0 >= 2.0.13-2.1
  • guile1 >= 1.8.8-19.3
  • libguile-2_0-22 >= 2.0.13-2.1
  • libguile-srfi-srfi-1-v-3-3 >= 1.8.8-19.3
  • libguile-srfi-srfi-13-14-v-3-3 >= 1.8.8-19.3
  • libguile-srfi-srfi-4-v-3-3 >= 1.8.8-19.3
  • libguile-srfi-srfi-60-v-2-2 >= 1.8.8-19.3
  • libguile1-devel >= 1.8.8-19.3
  • libguile17 >= 1.8.8-19.3
  • libguilereadline-v-17-17 >= 1.8.8-19.3
  • libguilereadline-v-18-18 >= 2.0.13-2.1
Patchnames:
openSUSE Tumbleweed GA guile
openSUSE Tumbleweed GA guile1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications guile Released
SLES_LTSS-10-SP4 guile Released
SUSE Linux Enterprise Desktop 11 SP2 guile Released
SUSE Linux Enterprise Desktop 11 SP3 guile Released
SUSE Linux Enterprise Desktop 11 SP4 guile Released
SUSE Linux Enterprise Desktop 12 guile Released
SUSE Linux Enterprise Desktop 12 SP1 guile Released
SUSE Linux Enterprise Desktop 12 SP2 guile Released
SUSE Linux Enterprise High Performance Computing 12 SP5 guile Released
SUSE Linux Enterprise Server 11 SP1 guile Released
SUSE Linux Enterprise Server 11 SP1 LTSS guile Released
SUSE Linux Enterprise Server 11 SP2 guile Released
SUSE Linux Enterprise Server 11 SP2 LTSS guile Released
SUSE Linux Enterprise Server 11 SP2 for VMware guile Released
SUSE Linux Enterprise Server 11 SP3 guile Released
SUSE Linux Enterprise Server 11 SP3 LTSS guile Released
SUSE Linux Enterprise Server 11 SP3 for VMware guile Released
SUSE Linux Enterprise Server 11 SP4 guile Released
SUSE Linux Enterprise Server 12 guile Released
SUSE Linux Enterprise Server 12 LTSS guile Released
SUSE Linux Enterprise Server 12 SP1 guile Released
SUSE Linux Enterprise Server 12 SP2 guile Released
SUSE Linux Enterprise Server 12 SP5 guile Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 guile Released
SUSE Linux Enterprise Server for the Raspberry Pi guile Released
SUSE Linux Enterprise Software Development Kit 11 SP2 guile Released
SUSE Linux Enterprise Software Development Kit 11 SP3 guile Released
SUSE Linux Enterprise Software Development Kit 11 SP4 guile Released
SUSE Linux Enterprise Software Development Kit 12 guile Released
SUSE Linux Enterprise Software Development Kit 12 SP1 guile Released
SUSE Linux Enterprise Workstation Extension 12 guile1 Released