Upstream information

CVE-2014-8158 at MITRE

Description

Multiple stack-based buffer overflows in jpc_qmfb.c in JasPer 1.900.1 and earlier allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted JPEG 2000 image.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 911837 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • jasper >= 1.900.14-181.1
  • libjasper1 >= 1.900.14-181.1
  • libjasper1-32bit >= 1.900.14-181.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1639
SUSE Linux Enterprise Desktop 12 SP2
  • jasper >= 1.900.14-181.1
  • libjasper1 >= 1.900.14-181.1
  • libjasper1-32bit >= 1.900.14-181.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1639
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP3
  • libjasper1 >= 1.900.14-194.1
  • libjasper1-32bit >= 1.900.14-194.1
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise Server 12 SP4
  • libjasper1 >= 1.900.14-195.8.1
  • libjasper1-32bit >= 1.900.14-195.8.1
SUSE Linux Enterprise Desktop 12
  • jasper >= 1.900.1-170.1
  • libjasper1 >= 1.900.1-170.1
  • libjasper1-32bit >= 1.900.1-170.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-73
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • libjasper1 >= 1.900.14-195.15.1
  • libjasper1-32bit >= 1.900.14-195.15.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libjasper4 >= 2.0.14-3.3.2
SUSE Linux Enterprise Module for Basesystem 15
  • libjasper4 >= 2.0.14-1.19
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • libjasper-devel >= 2.0.14-3.3.2
SUSE Linux Enterprise Module for Desktop Applications 15
  • libjasper-devel >= 2.0.14-1.19
SUSE Linux Enterprise Server 11 SP4
  • libjasper >= 1.900.1-134.17.1
  • libjasper-32bit >= 1.900.1-134.17.1
  • libjasper-x86 >= 1.900.1-134.17.1
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • jasper >= 1.900.14-181.1
  • libjasper1 >= 1.900.14-181.1
  • libjasper1-32bit >= 1.900.14-181.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1639
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • jasper >= 1.900.14-181.1
  • libjasper1 >= 1.900.14-181.1
  • libjasper1-32bit >= 1.900.14-181.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1639
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server for SAP Applications 12
  • jasper >= 1.900.1-170.1
  • libjasper1 >= 1.900.1-170.1
  • libjasper1-32bit >= 1.900.1-170.1
Patchnames:
SUSE-SLE-SERVER-12-2015-73
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • jasper >= 1.900.14-181.1
  • libjasper1 >= 1.900.14-181.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1639
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libjasper-devel >= 1.900.1-134.17.1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • jasper >= 1.900.14-181.1
  • libjasper-devel >= 1.900.14-181.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1639
SUSE Linux Enterprise Software Development Kit 12 SP2
  • jasper >= 1.900.14-181.1
  • libjasper-devel >= 1.900.14-181.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2016-1639
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libjasper-devel >= 1.900.14-194.1
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libjasper-devel >= 1.900.14-195.8.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libjasper-devel >= 1.900.14-195.15.1
SUSE Linux Enterprise Software Development Kit 12
  • jasper >= 1.900.1-170.1
  • libjasper-devel >= 1.900.1-170.1
Patchnames:
SUSE-SLE-SDK-12-2015-73
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libjasper-devel >= 1.900.1-134.17.1
Builds
SAT Patch Nr: 10261
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libjasper >= 1.900.1-134.17.1
Builds
SAT Patch Nr: 10261
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libjasper >= 1.900.1-134.17.1
  • libjasper-32bit >= 1.900.1-134.17.1
Builds
SAT Patch Nr: 10261
SUSE Linux Enterprise Server 11 SP3
  • libjasper >= 1.900.1-134.17.1
  • libjasper-x86 >= 1.900.1-134.17.1
Builds
SAT Patch Nr: 10261
openSUSE 13.1
  • jasper >= 1.900.14-160.25.1
  • jasper-debuginfo >= 1.900.14-160.25.1
  • jasper-debugsource >= 1.900.14-160.25.1
  • libjasper-devel >= 1.900.14-160.25.1
  • libjasper1 >= 1.900.14-160.25.1
  • libjasper1-32bit >= 1.900.14-160.25.1
  • libjasper1-debuginfo >= 1.900.14-160.25.1
  • libjasper1-debuginfo-32bit >= 1.900.14-160.25.1
Patchnames:
2016-1270
openSUSE-2015-97
openSUSE Leap 15.0
  • libjasper4 >= 2.0.14-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libjasper4
openSUSE Leap 42.1
  • jasper >= 1.900.14-166.1
  • jasper-debuginfo >= 1.900.14-166.1
  • jasper-debugsource >= 1.900.14-166.1
  • libjasper-devel >= 1.900.1-164.1
  • libjasper1 >= 1.900.1-164.1
  • libjasper1-32bit >= 1.900.1-164.1
  • libjasper1-debuginfo >= 1.900.14-166.1
  • libjasper1-debuginfo-32bit >= 1.900.14-166.1
Patchnames:
openSUSE Leap 42.1 GA libjasper-devel
openSUSE-2016-1309
openSUSE Leap 42.2
  • jasper >= 1.900.14-167.1
  • jasper-debuginfo >= 1.900.14-167.1
  • jasper-debugsource >= 1.900.14-167.1
  • libjasper-devel >= 1.900.1-165.5
  • libjasper1 >= 1.900.1-165.5
  • libjasper1-32bit >= 1.900.1-165.5
  • libjasper1-debuginfo >= 1.900.14-167.1
  • libjasper1-debuginfo-32bit >= 1.900.14-167.1
Patchnames:
openSUSE Leap 42.2 GA libjasper-devel
openSUSE-2016-1309
openSUSE Leap 42.3
  • libjasper-devel >= 1.900.14-177.3
  • libjasper1 >= 1.900.14-177.3
  • libjasper1-32bit >= 1.900.14-177.3
Patchnames:
openSUSE Leap 42.3 GA libjasper-devel
openSUSE Tumbleweed
  • jasper >= 1.900.14-3.1
  • libjasper-devel >= 1.900.14-3.1
  • libjasper1 >= 1.900.14-3.1
  • libjasper1-32bit >= 1.900.14-3.1
Patchnames:
openSUSE Tumbleweed GA jasper


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 jasper Released
SLED-10-SP4 jasper Released
SLES-10-SP3 jasper Released
SLES-10-SP4 jasper Released
SLES_LTSS-10-SP4 jasper Released
SUSE Linux Enterprise Desktop 11 SP1 jasper Released
SUSE Linux Enterprise Desktop 11 SP3 jasper Released
SUSE Linux Enterprise Desktop 12 jasper Released
SUSE Linux Enterprise Desktop 12 SP1 jasper Released
SUSE Linux Enterprise Desktop 12 SP2 jasper Released
SUSE Linux Enterprise High Performance Computing 12 SP5 jasper Released
SUSE Linux Enterprise Server 11 SP1 jasper Affected
SUSE Linux Enterprise Server 11 SP1 LTSS jasper Released
SUSE Linux Enterprise Server 11 SP3 jasper Released
SUSE Linux Enterprise Server 11 SP3 for VMware jasper Released
SUSE Linux Enterprise Server 12 jasper Released
SUSE Linux Enterprise Server 12 SP1 jasper Released
SUSE Linux Enterprise Server 12 SP2 jasper Released
SUSE Linux Enterprise Server 12 SP5 jasper Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 jasper Released
SUSE Linux Enterprise Server for SAP Business All-in-One jasper Released
SUSE Linux Enterprise Server for the Raspberry Pi jasper Released
SUSE Linux Enterprise Software Development Kit 11 SP1 jasper Released
SUSE Linux Enterprise Software Development Kit 11 SP3 jasper Released
SUSE Linux Enterprise Software Development Kit 12 jasper Released
SUSE Linux Enterprise Software Development Kit 12 SP1 jasper Released