Upstream information

CVE-2015-7581 at MITRE

Description

actionpack/lib/action_dispatch/routing/route_set.rb in Action Pack in Ruby on Rails 4.x before 4.2.5.1 and 5.x before 5.0.0.beta1.1 allows remote attackers to cause a denial of service (superfluous caching and memory consumption) by leveraging an application's use of a wildcard controller route.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 4.3
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 963335 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 2.1
  • ruby2.1-rubygem-actionpack-4_2 >= 4.2.2-6.1
  • rubygem-actionpack-4_2 >= 4.2.2-6.1
Patchnames:
SUSE-Storage-2.1-2016-262
SUSE Linux Enterprise Module for Containers 12
  • portus >= 2.0.3-2.4
Patchnames:
SUSE-SLE-Module-Containers-12-2016-672
SUSE OpenStack Cloud 5
  • ruby2.1-rubygem-actionpack-4_1 >= 4.1.9-9.1
  • rubygem-actionpack-4_1 >= 4.1.9-9.1
Patchnames:
sleclo50sp3-rubygem-actionpack-4_1-12468
SUSE OpenStack Cloud 6
  • ruby2.1-rubygem-actionpack-4_2 >= 4.2.2-6.1
openSUSE Leap 42.1
  • ruby2.1-rubygem-actionpack-4_2 >= 4.2.4-6.1
  • ruby2.1-rubygem-actionpack-doc-4_2 >= 4.2.4-6.1
  • ruby2.1-rubygem-actionview-4_2 >= 4.2.4-6.1
  • ruby2.1-rubygem-actionview-doc-4_2 >= 4.2.4-6.1
  • ruby2.1-rubygem-activemodel-4_2 >= 4.2.4-6.1
  • ruby2.1-rubygem-activemodel-doc-4_2 >= 4.2.4-6.1
  • ruby2.1-rubygem-activerecord-4_2 >= 4.2.4-6.1
  • ruby2.1-rubygem-activerecord-doc-4_2 >= 4.2.4-6.1
  • ruby2.1-rubygem-activesupport-4_2 >= 4.2.4-6.1
  • ruby2.1-rubygem-activesupport-doc-4_2 >= 4.2.4-6.1
  • rubygem-actionpack-4_2 >= 4.2.4-6.1
  • rubygem-actionview-4_2 >= 4.2.4-6.1
  • rubygem-activemodel-4_2 >= 4.2.4-6.1
  • rubygem-activerecord-4_2 >= 4.2.4-6.1
  • rubygem-activesupport-4_2 >= 4.2.4-6.1
Patchnames:
openSUSE-2016-159


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Cloud 5 rubygem-actionpack-4_1 Released
SUSE Linux Enterprise Software Development Kit 11 SP4 rubygem-actionpack-3_2 Ignore
SUSE OpenStack Cloud 7 rubygem-actionpack-4_2 Released
SUSE OpenStack Cloud Crowbar 8 rubygem-actionpack-4_2 Released
SUSE OpenStack Cloud Crowbar 9 rubygem-actionpack-4_2 Released