Upstream information

CVE-2023-34411 at MITRE

Description

The xml-rs crate before 0.8.14 for Rust and Crab allows a denial of service (panic) via an invalid <! token (such as <!DOCTYPEs/%<!A nesting) in an XML document. The earliest affected version is 0.8.9.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1211996 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP5 gstreamer-plugins-rs Affected
SUSE Linux Enterprise Desktop 15 SP6 gstreamer-plugins-rs Affected
SUSE Linux Enterprise High Performance Computing 15 SP5 gstreamer-plugins-rs Affected
SUSE Linux Enterprise High Performance Computing 15 SP6 gstreamer-plugins-rs Affected
SUSE Linux Enterprise Micro 5.2 afterburn Affected
SUSE Linux Enterprise Micro 5.3 afterburn Affected
SUSE Linux Enterprise Micro 5.4 afterburn Affected
SUSE Linux Enterprise Micro 5.5 afterburn Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 gstreamer-plugins-rs Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP6 gstreamer-plugins-rs Affected
SUSE Linux Enterprise Server 15 SP5 gstreamer-plugins-rs Affected
SUSE Linux Enterprise Server 15 SP6 gstreamer-plugins-rs Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 gstreamer-plugins-rs Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 gstreamer-plugins-rs Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 gstreamer-plugins-rs Affected
SUSE Manager Proxy 4.3 gstreamer-plugins-rs Affected
SUSE Manager Retail Branch Server 4.3 gstreamer-plugins-rs Affected
SUSE Manager Server 4.3 gstreamer-plugins-rs Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 gstreamer-plugins-rs Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 gstreamer-plugins-rs Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS gstreamer-plugins-rs Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS gstreamer-plugins-rs Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 gstreamer-plugins-rs Affected
SUSE Linux Enterprise Server 15 SP4 gstreamer-plugins-rs Affected
SUSE Linux Enterprise Server 15 SP4-LTSS gstreamer-plugins-rs Affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Real Time 15 SP4 gstreamer-plugins-rs Affected


SUSE Timeline for this CVE

CVE page created: Mon Jun 5 08:00:17 2023
CVE page last modified: Thu Apr 11 18:38:37 2024