Upstream information

CVE-2023-31543 at MITRE


A dependency confusion in pipreqs v0.3.0 to v0.4.11 allows attackers to execute arbitrary code via uploading a crafted PyPI package to the chosen repository server.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1212933 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • python310-pipreqs >= 0.4.13-1.1
  • python311-pipreqs >= 0.4.13-1.1
  • python39-pipreqs >= 0.4.13-1.1
openSUSE Tumbleweed GA python310-pipreqs-0.4.13-1.1

SUSE Timeline for this CVE

CVE page created: Sat Jul 1 00:02:16 2023
CVE page last modified: Sat Feb 17 11:38:10 2024