Upstream information

CVE-2022-31627 at MITRE

Description

In PHP versions 8.1.x below 8.1.8, when fileinfo functions, such as finfo_buffer, due to incorrect patch applied to the third party code from libmagic, incorrect function may be used to free allocated memory, which may lead to heap corruption.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 8.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network Network
Attack Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1201499 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • php8 >= 8.1.8-1.1
  • php8-bcmath >= 8.1.8-1.1
  • php8-bz2 >= 8.1.8-1.1
  • php8-calendar >= 8.1.8-1.1
  • php8-cli >= 8.1.8-1.1
  • php8-ctype >= 8.1.8-1.1
  • php8-curl >= 8.1.8-1.1
  • php8-dba >= 8.1.8-1.1
  • php8-devel >= 8.1.8-1.1
  • php8-dom >= 8.1.8-1.1
  • php8-enchant >= 8.1.8-1.1
  • php8-exif >= 8.1.8-1.1
  • php8-ffi >= 8.1.8-1.1
  • php8-fileinfo >= 8.1.8-1.1
  • php8-ftp >= 8.1.8-1.1
  • php8-gd >= 8.1.8-1.1
  • php8-gettext >= 8.1.8-1.1
  • php8-gmp >= 8.1.8-1.1
  • php8-iconv >= 8.1.8-1.1
  • php8-intl >= 8.1.8-1.1
  • php8-ldap >= 8.1.8-1.1
  • php8-mbstring >= 8.1.8-1.1
  • php8-mysql >= 8.1.8-1.1
  • php8-odbc >= 8.1.8-1.1
  • php8-opcache >= 8.1.8-1.1
  • php8-openssl >= 8.1.8-1.1
  • php8-pcntl >= 8.1.8-1.1
  • php8-pdo >= 8.1.8-1.1
  • php8-pgsql >= 8.1.8-1.1
  • php8-phar >= 8.1.8-1.1
  • php8-posix >= 8.1.8-1.1
  • php8-readline >= 8.1.8-1.1
  • php8-shmop >= 8.1.8-1.1
  • php8-snmp >= 8.1.8-1.1
  • php8-soap >= 8.1.8-1.1
  • php8-sockets >= 8.1.8-1.1
  • php8-sodium >= 8.1.8-1.1
  • php8-sqlite >= 8.1.8-1.1
  • php8-sysvmsg >= 8.1.8-1.1
  • php8-sysvsem >= 8.1.8-1.1
  • php8-sysvshm >= 8.1.8-1.1
  • php8-tidy >= 8.1.8-1.1
  • php8-tokenizer >= 8.1.8-1.1
  • php8-xmlreader >= 8.1.8-1.1
  • php8-xmlwriter >= 8.1.8-1.1
  • php8-xsl >= 8.1.8-1.1
  • php8-zip >= 8.1.8-1.1
  • php8-zlib >= 8.1.8-1.1
Patchnames:
openSUSE Tumbleweed GA php8-8.1.8-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 php7 Not affected
SUSE Enterprise Storage 7.1 php7 Not affected
SUSE Linux Enterprise High Performance Computing 12 php5 Unsupported
SUSE Linux Enterprise High Performance Computing 12 php7 Not affected
SUSE Linux Enterprise High Performance Computing 12 php72 Not affected
SUSE Linux Enterprise High Performance Computing 12 php74 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 php8 Not affected
SUSE Linux Enterprise Module for Legacy 15 SP4 php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php5 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 12 php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php72 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 php74 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP4 php8 Not affected
SUSE Linux Enterprise Server 12 SP5 php5 Unsupported
SUSE Linux Enterprise Server 12 SP5 php7 Not affected
SUSE Linux Enterprise Server 12 SP5 php72 Not affected
SUSE Linux Enterprise Server 12 SP5 php74 Not affected
SUSE Linux Enterprise Server 15 SP4 php7 Not affected
SUSE Linux Enterprise Server 15 SP4 php8 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php72 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 php74 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 php8 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 php7 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 php72 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 php74 Not affected
SUSE Manager Proxy 4.2 php7 Not affected
SUSE Manager Proxy 4.3 php7 Not affected
SUSE Manager Proxy 4.3 php8 Not affected
SUSE Manager Retail Branch Server 4.2 php7 Not affected
SUSE Manager Retail Branch Server 4.3 php7 Not affected
SUSE Manager Retail Branch Server 4.3 php8 Not affected
SUSE Manager Server 4.2 php7 Not affected
SUSE Manager Server 4.3 php7 Not affected
SUSE Manager Server 4.3 php8 Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS php7 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS php7 Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS php7 Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP1 php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP3 php7 Not affected
SUSE Linux Enterprise Server 12 SP4 php5 Unsupported
SUSE Linux Enterprise Server 12 SP4 php7 Not affected
SUSE Linux Enterprise Server 12 SP4 php72 Not affected
SUSE Linux Enterprise Server 12 SP4 php74 Not affected
SUSE Linux Enterprise Server 15 SP1 php7 Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS php7 Not affected
SUSE Linux Enterprise Server 15 SP2 php7 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS php7 Not affected
SUSE Linux Enterprise Server 15 SP3 php7 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS php7 Not affected
SUSE Linux Enterprise Server 15-ESPOS php7 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 php7 Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php72 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 php74 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 php7 Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 php7 Not affected
SUSE Enterprise Storage 6 php7 Not affected
SUSE Linux Enterprise Desktop 11 SP4 php53 Not affected
SUSE Linux Enterprise Desktop 12 php5 Unsupported
SUSE Linux Enterprise Desktop 12 php7 Not affected
SUSE Linux Enterprise Desktop 12 SP1 php5 Unsupported
SUSE Linux Enterprise Desktop 12 SP1 php7 Not affected
SUSE Linux Enterprise Desktop 12 SP2 php5 Unsupported
SUSE Linux Enterprise Desktop 12 SP2 php7 Not affected
SUSE Linux Enterprise Desktop 12 SP3 php5 Unsupported
SUSE Linux Enterprise Desktop 12 SP3 php7 Not affected
SUSE Linux Enterprise Desktop 12 SP3 php72 Not affected
SUSE Linux Enterprise Desktop 12 SP4 php5 Unsupported
SUSE Linux Enterprise Desktop 12 SP4 php7 Not affected
SUSE Linux Enterprise Desktop 12 SP4 php72 Not affected
SUSE Linux Enterprise Desktop 12 SP4 php74 Not affected
SUSE Linux Enterprise Desktop 15 php7 Not affected
SUSE Linux Enterprise Desktop 15 SP1 php7 Not affected
SUSE Linux Enterprise Desktop 15 SP2 php7 Not affected
SUSE Linux Enterprise Desktop 15 SP3 php7 Not affected
SUSE Linux Enterprise Module for Package Hub 15 php7 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP1 php7 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP2 php7 Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 php7 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 php7 Not affected
SUSE Linux Enterprise Server 11 SP3 php53 Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS php53 Not affected
SUSE Linux Enterprise Server 11 SP4 php53 Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS php53 Not affected
SUSE Linux Enterprise Server 12 php5 Unsupported
SUSE Linux Enterprise Server 12 php7 Not affected
SUSE Linux Enterprise Server 12 php72 Not affected
SUSE Linux Enterprise Server 12 php74 Not affected
SUSE Linux Enterprise Server 12 SP1 php5 Unsupported
SUSE Linux Enterprise Server 12 SP1 php7 Not affected
SUSE Linux Enterprise Server 12 SP2 php5 Unsupported
SUSE Linux Enterprise Server 12 SP2 php7 Not affected
SUSE Linux Enterprise Server 12 SP3 php5 Unsupported
SUSE Linux Enterprise Server 12 SP3 php7 Not affected
SUSE Linux Enterprise Server 12 SP3 php72 Not affected
SUSE Linux Enterprise Server 12 SP3 php74 Not affected
SUSE Linux Enterprise Server 15 php7 Not affected
SUSE Linux Enterprise Server 15 SP1-BCL php7 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL php7 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL php7 Not affected
SUSE Linux Enterprise Server 15-LTSS php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 php53 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 php72 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 php74 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP1 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php5 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php7 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php72 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 php74 Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 php53 Not affected
SUSE Linux Enterprise Software Development Kit 12 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 12 php7 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP1 php7 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP2 php7 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 php7 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 php72 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 php5 Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP4 php7 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 php72 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 php74 Not affected
SUSE Manager Proxy 4.0 php7 Not affected
SUSE Manager Proxy 4.1 php7 Not affected
SUSE Manager Retail Branch Server 4.0 php7 Not affected
SUSE Manager Retail Branch Server 4.1 php7 Not affected
SUSE Manager Server 4.0 php7 Not affected
SUSE Manager Server 4.1 php7 Not affected


SUSE Timeline for this CVE

CVE page created: Thu Jul 14 10:00:55 2022
CVE page last modified: Fri Jan 20 16:36:30 2023