Upstream information

CVE-2020-1945 at MITRE

Description

Apache Ant 1.1 to 1.9.14 and 1.10.0 to 1.10.7 uses the default temporary directory identified by the Java system property java.io.tmpdir for several tasks and may thus leak sensitive information. The fixcrlf and replaceregexp tasks also copy files from the temporary directory back into the build tree allowing an attacker to inject modified source files into the build process.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.3
Vector AV:L/AC:M/Au:N/C:P/I:P/A:N
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.3 4.9
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Attack Vector Local Local
Attack Complexity High High
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact None Low
CVSSv3 Version 3.1 3.1

Note from the SUSE Security Team

The best mitigation against CVE-2020-11979 and CVE-2020-1945 still is to make Ant use a directory that is only readable and writable by the current user.

SUSE Bugzilla entries: 1171696 [RESOLVED / FIXED], 1177180 [IN_PROGRESS], 1179729 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Development Tools 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • ant >= 1.10.7-4.3.1
  • ant-antlr >= 1.10.7-4.3.1
  • ant-apache-bcel >= 1.10.7-4.3.1
  • ant-apache-bsf >= 1.10.7-4.3.1
  • ant-apache-log4j >= 1.10.7-4.3.1
  • ant-apache-oro >= 1.10.7-4.3.1
  • ant-apache-regexp >= 1.10.7-4.3.1
  • ant-apache-resolver >= 1.10.7-4.3.1
  • ant-commons-logging >= 1.10.7-4.3.1
  • ant-javamail >= 1.10.7-4.3.1
  • ant-jdepend >= 1.10.7-4.3.1
  • ant-jmf >= 1.10.7-4.3.1
  • ant-junit >= 1.10.7-4.3.1
  • ant-manual >= 1.10.7-4.3.1
  • ant-scripts >= 1.10.7-4.3.1
  • ant-swing >= 1.10.7-4.3.1
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP3 GA ant-1.10.7-4.3.1
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Development Tools 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • ant >= 1.10.7-4.3.1
  • ant-antlr >= 1.10.7-4.3.1
  • ant-apache-bcel >= 1.10.7-4.3.1
  • ant-apache-bsf >= 1.10.7-4.3.1
  • ant-apache-log4j >= 1.10.7-4.3.1
  • ant-apache-oro >= 1.10.7-4.3.1
  • ant-apache-regexp >= 1.10.7-4.3.1
  • ant-apache-resolver >= 1.10.7-4.3.1
  • ant-commons-logging >= 1.10.7-4.3.1
  • ant-javamail >= 1.10.7-4.3.1
  • ant-jdepend >= 1.10.7-4.3.1
  • ant-jmf >= 1.10.7-4.3.1
  • ant-junit >= 1.10.7-4.3.1
  • ant-manual >= 1.10.7-4.3.1
  • ant-scripts >= 1.10.7-4.3.1
  • ant-swing >= 1.10.7-4.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2020-1944
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Development Tools 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • ant >= 1.10.7-150200.4.6.1
  • ant-antlr >= 1.10.7-150200.4.6.1
  • ant-apache-bcel >= 1.10.7-150200.4.6.1
  • ant-apache-bsf >= 1.10.7-150200.4.6.1
  • ant-apache-log4j >= 1.10.7-150200.4.6.1
  • ant-apache-oro >= 1.10.7-150200.4.6.1
  • ant-apache-regexp >= 1.10.7-150200.4.6.1
  • ant-apache-resolver >= 1.10.7-150200.4.6.1
  • ant-commons-logging >= 1.10.7-150200.4.6.1
  • ant-javamail >= 1.10.7-150200.4.6.1
  • ant-jdepend >= 1.10.7-150200.4.6.1
  • ant-jmf >= 1.10.7-150200.4.6.1
  • ant-junit >= 1.10.7-150200.4.6.1
  • ant-manual >= 1.10.7-150200.4.6.1
  • ant-scripts >= 1.10.7-150200.4.6.1
  • ant-swing >= 1.10.7-150200.4.6.1
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP4 GA ant-1.10.7-150200.4.6.1
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • ant >= 1.9.4-3.12.1
  • ant-antlr >= 1.9.4-3.12.3
  • ant-apache-bcel >= 1.9.4-3.12.3
  • ant-apache-bsf >= 1.9.4-3.12.3
  • ant-apache-log4j >= 1.9.4-3.12.3
  • ant-apache-oro >= 1.9.4-3.12.3
  • ant-apache-regexp >= 1.9.4-3.12.3
  • ant-apache-resolver >= 1.9.4-3.12.3
  • ant-commons-logging >= 1.9.4-3.12.3
  • ant-javadoc >= 1.9.4-3.12.3
  • ant-javamail >= 1.9.4-3.12.3
  • ant-jdepend >= 1.9.4-3.12.3
  • ant-jmf >= 1.9.4-3.12.1
  • ant-junit >= 1.9.4-3.12.3
  • ant-manual >= 1.9.4-3.12.3
  • ant-scripts >= 1.9.4-3.12.1
  • ant-swing >= 1.9.4-3.12.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-4022
SUSE-SLE-SERVER-12-SP5-2022-4022
SUSE Linux Enterprise Software Development Kit 12 SP5
  • ant >= 1.9.4-3.12.1
  • ant-antlr >= 1.9.4-3.12.3
  • ant-apache-bcel >= 1.9.4-3.12.3
  • ant-apache-bsf >= 1.9.4-3.12.3
  • ant-apache-log4j >= 1.9.4-3.12.3
  • ant-apache-oro >= 1.9.4-3.12.3
  • ant-apache-regexp >= 1.9.4-3.12.3
  • ant-apache-resolver >= 1.9.4-3.12.3
  • ant-commons-logging >= 1.9.4-3.12.3
  • ant-javadoc >= 1.9.4-3.12.3
  • ant-javamail >= 1.9.4-3.12.3
  • ant-jdepend >= 1.9.4-3.12.3
  • ant-jmf >= 1.9.4-3.12.1
  • ant-junit >= 1.9.4-3.12.3
  • ant-manual >= 1.9.4-3.12.3
  • ant-scripts >= 1.9.4-3.12.1
  • ant-swing >= 1.9.4-3.12.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2022-4022
openSUSE Leap 15.2
  • ant >= 1.10.7-lp152.2.3.1
  • ant-antlr >= 1.10.7-lp152.2.3.1
  • ant-apache-bcel >= 1.10.7-lp152.2.3.1
  • ant-apache-bsf >= 1.10.7-lp152.2.3.1
  • ant-apache-log4j >= 1.10.7-lp152.2.3.1
  • ant-apache-oro >= 1.10.7-lp152.2.3.1
  • ant-apache-regexp >= 1.10.7-lp152.2.3.1
  • ant-apache-resolver >= 1.10.7-lp152.2.3.1
  • ant-apache-xalan2 >= 1.10.7-lp152.2.3.1
  • ant-commons-logging >= 1.10.7-lp152.2.3.1
  • ant-commons-net >= 1.10.7-lp152.2.3.1
  • ant-imageio >= 1.10.7-lp152.2.3.1
  • ant-javamail >= 1.10.7-lp152.2.3.1
  • ant-jdepend >= 1.10.7-lp152.2.3.1
  • ant-jmf >= 1.10.7-lp152.2.3.1
  • ant-jsch >= 1.10.7-lp152.2.3.1
  • ant-junit >= 1.10.7-lp152.2.3.1
  • ant-junit5 >= 1.10.7-lp152.2.3.1
  • ant-manual >= 1.10.7-lp152.2.3.1
  • ant-scripts >= 1.10.7-lp152.2.3.1
  • ant-swing >= 1.10.7-lp152.2.3.1
  • ant-testutil >= 1.10.7-lp152.2.3.1
  • ant-xz >= 1.10.7-lp152.2.3.1
Patchnames:
openSUSE-2020-1022
openSUSE Tumbleweed
  • ant >= 1.10.10-1.2
  • ant-jmf >= 1.10.10-1.2
  • ant-scripts >= 1.10.10-1.2
  • ant-swing >= 1.10.10-1.2
  • junit >= 4.13.2-1.1
  • junit-javadoc >= 4.13.2-1.1
  • junit-manual >= 4.13.2-1.1
Patchnames:
openSUSE Tumbleweed GA ant-1.10.10-1.2
openSUSE Tumbleweed GA junit-4.13.2-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 ant Released
SUSE Enterprise Storage 7 ant-antlr Released
SUSE Enterprise Storage 7 ant-junit Released
SUSE Enterprise Storage 7 junit Already fixed
SUSE Enterprise Storage 7.1 ant Released
SUSE Enterprise Storage 7.1 ant-antlr Already fixed
SUSE Enterprise Storage 7.1 junit Already fixed
SUSE Linux Enterprise Desktop 15 SP4 ant Released
SUSE Linux Enterprise Desktop 15 SP4 ant-antlr Already fixed
SUSE Linux Enterprise Desktop 15 SP4 junit Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 ant Released
SUSE Linux Enterprise High Performance Computing 15 SP4 ant Released
SUSE Linux Enterprise High Performance Computing 15 SP4 ant-antlr Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 junit Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP4 ant Released
SUSE Linux Enterprise Module for Development Tools 15 SP4 ant-antlr Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP4 junit Already fixed
SUSE Linux Enterprise Real Time 15 SP3 ant Released
SUSE Linux Enterprise Real Time 15 SP3 ant-antlr Already fixed
SUSE Linux Enterprise Real Time 15 SP3 junit Already fixed
SUSE Linux Enterprise Server 12 SP5 ant Released
SUSE Linux Enterprise Server 12 SP5 ant-antlr Released
SUSE Linux Enterprise Server 12-LTSS ant Affected
SUSE Linux Enterprise Server 15 SP4 ant Released
SUSE Linux Enterprise Server 15 SP4 ant-antlr Already fixed
SUSE Linux Enterprise Server 15 SP4 junit Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ant Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ant-antlr Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 ant Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 ant-antlr Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 junit Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 ant Released
SUSE Linux Enterprise Software Development Kit 12 SP5 ant-antlr Released
SUSE Manager Proxy 4.2 ant Released
SUSE Manager Proxy 4.2 ant-antlr Already fixed
SUSE Manager Proxy 4.2 junit Already fixed
SUSE Manager Proxy 4.3 ant Released
SUSE Manager Proxy 4.3 ant-antlr Already fixed
SUSE Manager Proxy 4.3 junit Already fixed
SUSE Manager Retail Branch Server 4.2 ant Released
SUSE Manager Retail Branch Server 4.2 ant-antlr Already fixed
SUSE Manager Retail Branch Server 4.2 junit Already fixed
SUSE Manager Retail Branch Server 4.3 ant Released
SUSE Manager Retail Branch Server 4.3 ant-antlr Already fixed
SUSE Manager Retail Branch Server 4.3 junit Already fixed
SUSE Manager Server 4.2 ant Released
SUSE Manager Server 4.2 ant-antlr Already fixed
SUSE Manager Server 4.2 junit Already fixed
SUSE Manager Server 4.3 ant Released
SUSE Manager Server 4.3 ant-antlr Already fixed
SUSE Manager Server 4.3 junit Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP4 ant Affected
SUSE Linux Enterprise High Performance Computing 15 ant Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP1 ant Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS ant Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS ant Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 ant Released
SUSE Linux Enterprise High Performance Computing 15 SP2 ant-antlr Released
SUSE Linux Enterprise High Performance Computing 15 SP2 ant-junit Released
SUSE Linux Enterprise High Performance Computing 15 SP2 junit Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS ant Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS ant-antlr Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS junit Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS ant Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS ant-antlr Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS junit Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 ant Released
SUSE Linux Enterprise High Performance Computing 15 SP3 ant-antlr Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 junit Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS ant Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS ant-antlr Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS junit Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS ant Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS ant-antlr Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS junit Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS ant Won't fix
SUSE Linux Enterprise High Performance Computing 15-LTSS ant Won't fix
SUSE Linux Enterprise Module for Development Tools 15 SP1 ant Unsupported
SUSE Linux Enterprise Module for Development Tools 15 SP2 ant Released
SUSE Linux Enterprise Module for Development Tools 15 SP2 ant-antlr Released
SUSE Linux Enterprise Module for Development Tools 15 SP2 ant-junit Released
SUSE Linux Enterprise Module for Development Tools 15 SP2 junit Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP3 ant Released
SUSE Linux Enterprise Module for Development Tools 15 SP3 ant-antlr Already fixed
SUSE Linux Enterprise Module for Development Tools 15 SP3 junit Already fixed
SUSE Linux Enterprise Server 12 SP2-BCL ant Affected
SUSE Linux Enterprise Server 12 SP4 ant Affected
SUSE Linux Enterprise Server 12 SP4 ant-antlr Affected
SUSE Linux Enterprise Server 12 SP4-LTSS ant Affected
SUSE Linux Enterprise Server 15 SP1 ant Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS ant Affected
SUSE Linux Enterprise Server 15 SP2 ant Released
SUSE Linux Enterprise Server 15 SP2 ant-antlr Released
SUSE Linux Enterprise Server 15 SP2 ant-junit Released
SUSE Linux Enterprise Server 15 SP2 junit Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS ant Released
SUSE Linux Enterprise Server 15 SP2-LTSS ant-antlr Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS junit Already fixed
SUSE Linux Enterprise Server 15 SP3 ant Released
SUSE Linux Enterprise Server 15 SP3 ant-antlr Already fixed
SUSE Linux Enterprise Server 15 SP3 junit Already fixed
SUSE Linux Enterprise Server 15 SP3-LTSS ant Affected
SUSE Linux Enterprise Server 15 SP3-LTSS ant-antlr Already fixed
SUSE Linux Enterprise Server 15 SP3-LTSS junit Already fixed
SUSE Linux Enterprise Server 15-ESPOS ant Won't fix
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 ant Won't fix
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 ant Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 junit Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 ant Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 ant-antlr Already fixed
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 junit Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ant Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ant-antlr Affected
SUSE Linux Enterprise Server for SAP Applications 15 ant Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 ant Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 ant Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 ant-antlr Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 ant-junit Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 junit Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 ant Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 ant-antlr Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 junit Already fixed
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 ant Affected
SUSE CaaS Platform 4.0 ant Affected
SUSE CaaS Platform 4.5 ant Released
SUSE Enterprise Storage 6 ant Affected
SUSE Linux Enterprise Desktop 11 SP4 ant Won't fix
SUSE Linux Enterprise Desktop 12 ant Affected
SUSE Linux Enterprise Desktop 12 ant-antlr Affected
SUSE Linux Enterprise Desktop 12 SP1 ant Affected
SUSE Linux Enterprise Desktop 12 SP1 ant-antlr Affected
SUSE Linux Enterprise Desktop 12 SP2 ant Affected
SUSE Linux Enterprise Desktop 12 SP2 ant-antlr Affected
SUSE Linux Enterprise Desktop 12 SP3 ant Affected
SUSE Linux Enterprise Desktop 12 SP3 ant-antlr Affected
SUSE Linux Enterprise Desktop 12 SP4 ant Affected
SUSE Linux Enterprise Desktop 12 SP4 ant-antlr Affected
SUSE Linux Enterprise Desktop 15 ant Won't fix
SUSE Linux Enterprise Desktop 15 SP1 ant Unsupported
SUSE Linux Enterprise Desktop 15 SP2 ant Released
SUSE Linux Enterprise Desktop 15 SP2 ant-antlr Released
SUSE Linux Enterprise Desktop 15 SP2 ant-junit Released
SUSE Linux Enterprise Desktop 15 SP2 junit Already fixed
SUSE Linux Enterprise Desktop 15 SP3 ant Released
SUSE Linux Enterprise Desktop 15 SP3 ant-antlr Already fixed
SUSE Linux Enterprise Desktop 15 SP3 junit Already fixed
SUSE Linux Enterprise Module for Development Tools 15 ant Won't fix
SUSE Linux Enterprise Real Time 15 SP2 ant Released
SUSE Linux Enterprise Real Time 15 SP2 ant-antlr Already fixed
SUSE Linux Enterprise Real Time 15 SP2 junit Already fixed
SUSE Linux Enterprise Server 11 SP1 ant Unsupported
SUSE Linux Enterprise Server 11 SP3 ant Won't fix
SUSE Linux Enterprise Server 11 SP3-LTSS ant Won't fix
SUSE Linux Enterprise Server 11 SP4 ant Won't fix
SUSE Linux Enterprise Server 11 SP4 LTSS ant Unsupported
SUSE Linux Enterprise Server 11 SP4-LTSS ant Unsupported
SUSE Linux Enterprise Server 12 ant Affected
SUSE Linux Enterprise Server 12 ant-antlr Affected
SUSE Linux Enterprise Server 12 SP1 ant Affected
SUSE Linux Enterprise Server 12 SP1 ant-antlr Affected
SUSE Linux Enterprise Server 12 SP1-LTSS ant Unsupported
SUSE Linux Enterprise Server 12 SP2 ant Affected
SUSE Linux Enterprise Server 12 SP2 ant-antlr Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS ant Affected
SUSE Linux Enterprise Server 12 SP2-LTSS ant Unsupported
SUSE Linux Enterprise Server 12 SP3 ant Affected
SUSE Linux Enterprise Server 12 SP3 ant-antlr Affected
SUSE Linux Enterprise Server 12 SP3-BCL ant Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS ant Affected
SUSE Linux Enterprise Server 12 SP3-LTSS ant Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS ant Affected
SUSE Linux Enterprise Server 15 ant Won't fix
SUSE Linux Enterprise Server 15 SP1-BCL ant Won't fix
SUSE Linux Enterprise Server 15 SP2-BCL ant Affected
SUSE Linux Enterprise Server 15 SP2-BCL ant-antlr Already fixed
SUSE Linux Enterprise Server 15 SP2-BCL junit Already fixed
SUSE Linux Enterprise Server 15 SP3-BCL ant Affected
SUSE Linux Enterprise Server 15 SP3-BCL ant-antlr Already fixed
SUSE Linux Enterprise Server 15 SP3-BCL junit Already fixed
SUSE Linux Enterprise Server 15-LTSS ant Won't fix
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 ant Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 ant Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 ant Affected
SUSE Linux Enterprise Server for SAP Applications 12 ant-antlr Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 ant Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 ant-antlr Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ant Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ant-antlr Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ant Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ant-antlr Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 ant Won't fix
SUSE Linux Enterprise Software Development Kit 12 ant Affected
SUSE Linux Enterprise Software Development Kit 12 ant-antlr Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 ant Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 ant-antlr Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 ant Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 ant-antlr Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 ant Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 ant-antlr Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 ant Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 ant-antlr Affected
SUSE Manager Proxy 4.0 ant Unsupported
SUSE Manager Proxy 4.1 ant Released
SUSE Manager Proxy 4.1 ant-antlr Released
SUSE Manager Proxy 4.1 ant-junit Released
SUSE Manager Proxy 4.1 junit Already fixed
SUSE Manager Retail Branch Server 4.0 ant Unsupported
SUSE Manager Retail Branch Server 4.1 ant Released
SUSE Manager Retail Branch Server 4.1 ant-antlr Released
SUSE Manager Retail Branch Server 4.1 ant-junit Released
SUSE Manager Retail Branch Server 4.1 junit Already fixed
SUSE Manager Server 4.0 ant Unsupported
SUSE Manager Server 4.1 ant Released
SUSE Manager Server 4.1 ant-antlr Released
SUSE Manager Server 4.1 ant-junit Released
SUSE Manager Server 4.1 junit Already fixed
SUSE OpenStack Cloud 7 ant Affected
SUSE OpenStack Cloud 8 ant Affected
SUSE OpenStack Cloud 9 ant Affected
SUSE OpenStack Cloud Crowbar 8 ant Affected
SUSE OpenStack Cloud Crowbar 9 ant Affected
Container Status
bci/openjdk-devel
bci/openjdk-devel:11
junitAlready fixed


SUSE Timeline for this CVE

CVE page created: Wed May 13 21:15:05 2020
CVE page last modified: Fri Jan 20 15:12:38 2023