Upstream information

CVE-2019-18397 at MITRE

Description

A buffer overflow in the fribidi_get_par_embedding_levels_ex() function in lib/fribidi-bidi.c of GNU FriBidi through 1.0.7 allows an attacker to cause a denial of service or possibly execute arbitrary code by delivering crafted text content to a user, when this content is then rendered by an application that uses FriBidi for text layout calculations. Examples include any GNOME or GTK+ based application that uses Pango for text layout, as this internally uses FriBidi for bidirectional text layout. For example, the attacker can construct a crafted text file to be opened in GEdit, or a crafted IRC message to be viewed in HexChat.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1156260 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/sles/15.2/virt-launcher:0.38.1.5.8.40
Image SLES15-SP2-SAP-Azure
Image SLES15-SP2-SAP-Azure-LI-BYOS-Production
Image SLES15-SP2-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP2-SAP-BYOS-Azure
Image SLES15-SP2-SAP-BYOS-EC2-HVM
Image SLES15-SP2-SAP-BYOS-GCE
Image SLES15-SP2-SAP-EC2-HVM
Image SLES15-SP2-SAP-GCE
Image SLES15-SP3-SAP-Azure-LI-BYOS-Production
Image SLES15-SP3-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP3-SAP-BYOS-Azure
Image SLES15-SP3-SAP-BYOS-EC2-HVM
Image SLES15-SP3-SAP-BYOS-GCE
  • libfribidi0 >= 1.0.5-3.3.1
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • fribidi >= 1.0.5-3.3.1
  • fribidi-devel >= 1.0.5-3.3.1
  • libfribidi0 >= 1.0.5-3.3.1
  • libfribidi0-32bit >= 1.0.5-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-1655
SUSE-SLE-Module-Desktop-Applications-15-SP3-2021-1655
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • fribidi >= 1.0.5-3.3.1
  • fribidi-devel >= 1.0.5-3.3.1
  • libfribidi0 >= 1.0.5-3.3.1
  • libfribidi0-32bit >= 1.0.5-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-1655
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-1655
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • fribidi >= 1.0.10-150400.1.7
  • fribidi-devel >= 1.0.10-150400.1.7
  • libfribidi0 >= 1.0.10-150400.1.7
  • libfribidi0-32bit >= 1.0.10-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA fribidi-1.0.10-150400.1.7
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA libfribidi0-32bit-1.0.10-150400.1.7
SUSE Linux Enterprise Micro 5.0
  • libfribidi0 >= 1.0.5-3.3.1
Patchnames:
SUSE-SUSE-MicroOS-5.0-2021-1655
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • fribidi >= 1.0.5-3.3.1
  • fribidi-devel >= 1.0.5-3.3.1
  • libfribidi0 >= 1.0.5-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-1655
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • fribidi >= 1.0.5-3.3.1
  • fribidi-devel >= 1.0.5-3.3.1
  • libfribidi0 >= 1.0.5-3.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-1655
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • fribidi >= 1.0.10-150400.1.7
  • fribidi-devel >= 1.0.10-150400.1.7
  • libfribidi0 >= 1.0.10-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA fribidi-1.0.10-150400.1.7
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • libfribidi0-32bit >= 1.0.5-3.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-1655
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
  • libfribidi0-32bit >= 1.0.5-3.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP3-2021-1655
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
  • libfribidi0-32bit >= 1.0.10-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA libfribidi0-32bit-1.0.10-150400.1.7
openSUSE Leap 15.2
  • fribidi >= 1.0.5-lp152.2.3.1
  • fribidi-devel >= 1.0.5-lp152.2.3.1
  • libfribidi0 >= 1.0.5-lp152.2.3.1
  • libfribidi0-32bit >= 1.0.5-lp152.2.3.1
Patchnames:
openSUSE-2021-763
openSUSE Leap 15.3
  • fribidi >= 1.0.5-3.3.1
  • fribidi-devel >= 1.0.5-3.3.1
  • libfribidi0 >= 1.0.5-3.3.1
  • libfribidi0-32bit >= 1.0.5-3.3.1
Patchnames:
openSUSE-SLE-15.3-2021-1655
openSUSE Leap 15.4
  • fribidi >= 1.0.10-150400.1.7
  • libfribidi0 >= 1.0.10-150400.1.7
Patchnames:
openSUSE Leap 15.4 GA fribidi-1.0.10-150400.1.7
openSUSE Tumbleweed
  • fribidi >= 1.0.10-2.1
  • fribidi-devel >= 1.0.10-2.1
  • libfribidi0 >= 1.0.10-2.1
  • libfribidi0-32bit >= 1.0.10-2.1
Patchnames:
openSUSE Tumbleweed GA fribidi-1.0.10-2.1


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 fribidi Released
SUSE Enterprise Storage 7.1 fribidi Released
SUSE Linux Enterprise Desktop 15 SP4 fribidi Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 fribidi Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 fribidi Already fixed
SUSE Linux Enterprise Micro 5.2 fribidi Affected
SUSE Linux Enterprise Micro 5.3 fribidi Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 fribidi Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 fribidi Already fixed
SUSE Linux Enterprise Real Time 15 SP3 fribidi Affected
SUSE Linux Enterprise Server 12 SP5 fribidi Not affected
SUSE Linux Enterprise Server 12-LTSS fribidi Not affected
SUSE Linux Enterprise Server 15 SP4 fribidi Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 fribidi Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 fribidi Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 fribidi Not affected
SUSE Manager Proxy 4.2 fribidi Released
SUSE Manager Proxy 4.3 fribidi Already fixed
SUSE Manager Retail Branch Server 4.2 fribidi Released
SUSE Manager Retail Branch Server 4.3 fribidi Already fixed
SUSE Manager Server 4.2 fribidi Released
SUSE Manager Server 4.3 fribidi Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP4 fribidi Not affected
SUSE Linux Enterprise High Performance Computing 15 fribidi Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 fribidi Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS fribidi Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS fribidi Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 fribidi Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS fribidi Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS fribidi Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 fribidi Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS fribidi Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS fribidi Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS fribidi Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS fribidi Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 fribidi Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 fribidi Released
SUSE Linux Enterprise Module for Basesystem 15 SP3 fribidi Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 fribidi Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 fribidi Released
SUSE Linux Enterprise Server 12 SP2-BCL fribidi Not affected
SUSE Linux Enterprise Server 12 SP4 fribidi Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS fribidi Not affected
SUSE Linux Enterprise Server 15 SP1 fribidi Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS fribidi Not affected
SUSE Linux Enterprise Server 15 SP2 fribidi Released
SUSE Linux Enterprise Server 15 SP2-LTSS fribidi Affected
SUSE Linux Enterprise Server 15 SP3 fribidi Released
SUSE Linux Enterprise Server 15 SP3-LTSS fribidi Affected
SUSE Linux Enterprise Server 15-ESPOS fribidi Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 fribidi Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 fribidi Not affected
SUSE Linux Enterprise Server for SAP Applications 15 fribidi Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 fribidi Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 fribidi Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 fribidi Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 fribidi Not affected
SUSE CaaS Platform 4.0 fribidi Not affected
SUSE Enterprise Storage 5 fribidi Unsupported
SUSE Enterprise Storage 6 fribidi Not affected
SUSE Linux Enterprise Desktop 11 SP4 fribidi Not affected
SUSE Linux Enterprise Desktop 12 fribidi Not affected
SUSE Linux Enterprise Desktop 12 SP1 fribidi Not affected
SUSE Linux Enterprise Desktop 12 SP2 fribidi Not affected
SUSE Linux Enterprise Desktop 12 SP3 fribidi Not affected
SUSE Linux Enterprise Desktop 12 SP4 fribidi Not affected
SUSE Linux Enterprise Desktop 15 fribidi Not affected
SUSE Linux Enterprise Desktop 15 SP1 fribidi Unsupported
SUSE Linux Enterprise Desktop 15 SP2 fribidi Released
SUSE Linux Enterprise Desktop 15 SP3 fribidi Released
SUSE Linux Enterprise Micro 5.0 fribidi Released
SUSE Linux Enterprise Module for Basesystem 15 fribidi Not affected
SUSE Linux Enterprise Point of Service 11 SP3 fribidi Not affected
SUSE Linux Enterprise Point of Service Image Server 12 SP2 fribidi Unsupported
SUSE Linux Enterprise Real Time 15 SP2 fribidi Affected
SUSE Linux Enterprise Server 11 SP3 fribidi Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS fribidi Not affected
SUSE Linux Enterprise Server 11 SP4 fribidi Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS fribidi Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS fribidi Not affected
SUSE Linux Enterprise Server 12 fribidi Not affected
SUSE Linux Enterprise Server 12 SP1 fribidi Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS fribidi Not affected
SUSE Linux Enterprise Server 12 SP2 fribidi Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS fribidi Unsupported
SUSE Linux Enterprise Server 12 SP2-LTSS fribidi Not affected
SUSE Linux Enterprise Server 12 SP3 fribidi Not affected
SUSE Linux Enterprise Server 12 SP3-BCL fribidi Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS fribidi Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS fribidi Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS fribidi Not affected
SUSE Linux Enterprise Server 15 fribidi Not affected
SUSE Linux Enterprise Server 15 SP1-BCL fribidi Not affected
SUSE Linux Enterprise Server 15 SP2-BCL fribidi Affected
SUSE Linux Enterprise Server 15 SP3-BCL fribidi Affected
SUSE Linux Enterprise Server 15-LTSS fribidi Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 fribidi Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 fribidi Not affected
SUSE Linux Enterprise Server for SAP Applications 12 fribidi Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 fribidi Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 fribidi Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 fribidi Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 fribidi Not affected
SUSE Linux Enterprise Software Development Kit 12 fribidi Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 fribidi Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 fribidi Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 fribidi Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 fribidi Not affected
SUSE Manager Proxy 4.0 fribidi Unsupported
SUSE Manager Proxy 4.1 fribidi Released
SUSE Manager Retail Branch Server 4.0 fribidi Unsupported
SUSE Manager Retail Branch Server 4.1 fribidi Released
SUSE Manager Server 4.0 fribidi Unsupported
SUSE Manager Server 4.1 fribidi Released
SUSE OpenStack Cloud 7 fribidi Not affected
SUSE OpenStack Cloud 8 fribidi Not affected
SUSE OpenStack Cloud 9 fribidi Not affected
SUSE OpenStack Cloud Crowbar 8 fribidi Not affected
SUSE OpenStack Cloud Crowbar 9 fribidi Not affected


SUSE Timeline for this CVE

CVE page created: Fri Nov 8 00:05:23 2019
CVE page last modified: Fri Jan 20 15:04:55 2023