Upstream information

CVE-2019-12420 at MITRE

Description

In Apache SpamAssassin before 3.4.3, a message can be crafted in a way to use excessive resources. Upgrading to SA 3.4.3 as soon as possible is the recommended fix but details will not be shared publicly.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1159133 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
HPE-Helion-OpenStack-8-2021-1152
SUSE CaaS Platform 4.0
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-1163
SUSE Enterprise Storage 6
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-Storage-6-2021-1163
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-1163
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-1163
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • perl-Mail-SpamAssassin >= 3.4.5-7.14.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-7.14.1
  • spamassassin >= 3.4.5-7.14.1
Patchnames:
SUSE-SLE-Product-HPC-15-2021-1153
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP2-2021-1163
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP3-2021-1163
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2021-1163
SUSE Linux Enterprise Module for Development Tools 15 SP3
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2021-1163
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2021-1152
SUSE Linux Enterprise Server 12 SP2-LTSS-ERICSSON
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS-ERICSSON
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-LTSS-ERICSSON-2021-1152
SUSE Linux Enterprise Server 12 SP2-LTSS-SAP
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS-SAP
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-LTSS-SAP-2021-1152
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2021-1152
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2021-1152
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2021-1152
SUSE Linux Enterprise Server 12 SP4-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP4-ESPOS
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2021-1152
SUSE Linux Enterprise Server 12 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP4-LTSS
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2021-1152
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2021-1152
SUSE Linux Enterprise Server 15 SP1-BCL
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-1163
SUSE Linux Enterprise Server 15 SP1-LTSS
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-1163
SUSE Linux Enterprise Server 15-LTSS
  • perl-Mail-SpamAssassin >= 3.4.5-7.14.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-7.14.1
  • spamassassin >= 3.4.5-7.14.1
Patchnames:
SUSE-SLE-Product-SLES-15-2021-1153
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2021-1152
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2021-1152
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-1163
SUSE Linux Enterprise Server for SAP Applications 15
  • perl-Mail-SpamAssassin >= 3.4.5-7.14.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-7.14.1
  • spamassassin >= 3.4.5-7.14.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2021-1153
SUSE Manager Proxy 4.0
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-1163
SUSE Manager Retail Branch Server 4.0
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-1163
SUSE Manager Server 4.0
  • perl-Mail-SpamAssassin >= 3.4.5-12.10.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-12.10.1
  • spamassassin >= 3.4.5-12.10.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-1163
SUSE OpenStack Cloud 8
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-OpenStack-Cloud-8-2021-1152
SUSE OpenStack Cloud 9
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-OpenStack-Cloud-9-2021-1152
SUSE OpenStack Cloud Crowbar 8
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2021-1152
SUSE OpenStack Cloud Crowbar 9
  • perl-Mail-SpamAssassin >= 3.4.5-44.13.1
  • spamassassin >= 3.4.5-44.13.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2021-1152
openSUSE Leap 15.2
  • perl-Mail-SpamAssassin >= 3.4.5-lp152.10.3.1
  • perl-Mail-SpamAssassin-Plugin-iXhash2 >= 2.05-lp152.10.3.1
  • spamassassin >= 3.4.5-lp152.10.3.1
  • spamassassin-debuginfo >= 3.4.5-lp152.10.3.1
  • spamassassin-debugsource >= 3.4.5-lp152.10.3.1
Patchnames:
openSUSE-2021-551


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
HPE Helion OpenStack 8 spamassassin Released
SUSE CaaS Platform 4.0 spamassassin Released
SUSE Enterprise Storage 6 spamassassin Released
SUSE Linux Enterprise Desktop 12 SP4 spamassassin Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 spamassassin Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 spamassassin Released
SUSE Linux Enterprise High Performance Computing 15 LTSS spamassassin Released
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS spamassassin Released
SUSE Linux Enterprise Module for Basesystem 15 spamassassin Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 spamassassin Unsupported
SUSE Linux Enterprise Module for Basesystem 15 SP2 spamassassin Released
SUSE Linux Enterprise Module for Development Tools 15 spamassassin Affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 spamassassin Unsupported
SUSE Linux Enterprise Module for Development Tools 15 SP2 spamassassin Released
SUSE Linux Enterprise Point of Service Image Server 12 spamassassin Unsupported
SUSE Linux Enterprise Server 11 SP4 LTSS spamassassin Analysis
SUSE Linux Enterprise Server 12 SP1 LTSS spamassassin Affected
SUSE Linux Enterprise Server 12 SP2 BCL spamassassin Released
SUSE Linux Enterprise Server 12 SP2 ESPOS spamassassin Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS spamassassin In progress
SUSE Linux Enterprise Server 12 SP2 LTSS ERICSSON spamassassin Released
SUSE Linux Enterprise Server 12 SP2 LTSS SAP spamassassin Released
SUSE Linux Enterprise Server 12 SP3 BCL spamassassin Released
SUSE Linux Enterprise Server 12 SP3 ESPOS spamassassin Released
SUSE Linux Enterprise Server 12 SP3 LTSS spamassassin Released
SUSE Linux Enterprise Server 12 SP4 spamassassin Affected
SUSE Linux Enterprise Server 12 SP4 ESPOS spamassassin Released
SUSE Linux Enterprise Server 12 SP4 LTSS spamassassin Released
SUSE Linux Enterprise Server 12 SP5 spamassassin Released
SUSE Linux Enterprise Server 15 LTSS spamassassin Released
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux spamassassin Released
SUSE Linux Enterprise Server 15 SP1 LTSS spamassassin Released
SUSE Linux Enterprise Server ESPOS 15 spamassassin Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 spamassassin Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 spamassassin Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 spamassassin Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 spamassassin Released
SUSE Linux Enterprise Server for SAP Applications 15 spamassassin Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 spamassassin Released
SUSE Manager Proxy 4.0 spamassassin Released
SUSE Manager Retail Branch Server 4.0 spamassassin Released
SUSE Manager Server 4.0 spamassassin Released
SUSE OpenStack Cloud 7 spamassassin In progress
SUSE OpenStack Cloud 8 spamassassin Released
SUSE OpenStack Cloud 9 spamassassin Released
SUSE OpenStack Cloud Crowbar 8 spamassassin Released
SUSE OpenStack Cloud Crowbar 9 spamassassin Released