Upstream information

CVE-2019-11235 at MITRE

Description

FreeRADIUS before 3.0.19 mishandles the "each participant verifies that the received scalar is within a range, and that the received group element is a valid point on the curve being used" protection mechanism, aka a "Dragonblood" issue, a similar issue to CVE-2019-9498 and CVE-2019-9499.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 8.1
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Access Vector Network Adjacent Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High None
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1132549 [RESOLVED / FIXED], 1132664 [RESOLVED / FIXED], 1144524 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • freeradius-server >= 3.0.3-17.12.1
  • freeradius-server-doc >= 3.0.3-17.12.1
  • freeradius-server-krb5 >= 3.0.3-17.12.1
  • freeradius-server-ldap >= 3.0.3-17.12.1
  • freeradius-server-libs >= 3.0.3-17.12.1
  • freeradius-server-mysql >= 3.0.3-17.12.1
  • freeradius-server-perl >= 3.0.3-17.12.1
  • freeradius-server-postgresql >= 3.0.3-17.12.1
  • freeradius-server-python >= 3.0.3-17.12.1
  • freeradius-server-sqlite >= 3.0.3-17.12.1
  • freeradius-server-utils >= 3.0.3-17.12.1
Patchnames:
SUSE-Storage-4-2019-1039
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • freeradius-server >= 3.0.19-1.48
  • freeradius-server-doc >= 3.0.19-1.48
  • freeradius-server-krb5 >= 3.0.19-1.48
  • freeradius-server-ldap >= 3.0.19-1.48
  • freeradius-server-libs >= 3.0.19-1.48
  • freeradius-server-mysql >= 3.0.19-1.48
  • freeradius-server-perl >= 3.0.19-1.48
  • freeradius-server-postgresql >= 3.0.19-1.48
  • freeradius-server-python >= 3.0.19-1.48
  • freeradius-server-sqlite >= 3.0.19-1.48
  • freeradius-server-utils >= 3.0.19-1.48
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • freeradius-server >= 3.0.16-3.3.1
  • freeradius-server-doc >= 3.0.16-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-1086
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • freeradius-server >= 3.0.16-3.3.1
  • freeradius-server-devel >= 3.0.16-3.3.1
  • freeradius-server-krb5 >= 3.0.16-3.3.1
  • freeradius-server-ldap >= 3.0.16-3.3.1
  • freeradius-server-libs >= 3.0.16-3.3.1
  • freeradius-server-mysql >= 3.0.16-3.3.1
  • freeradius-server-perl >= 3.0.16-3.3.1
  • freeradius-server-postgresql >= 3.0.16-3.3.1
  • freeradius-server-python >= 3.0.16-3.3.1
  • freeradius-server-sqlite >= 3.0.16-3.3.1
  • freeradius-server-utils >= 3.0.16-3.3.1
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • freeradius-server >= 3.0.21-1.33
  • freeradius-server-devel >= 3.0.21-1.33
  • freeradius-server-krb5 >= 3.0.21-1.33
  • freeradius-server-ldap >= 3.0.21-1.33
  • freeradius-server-libs >= 3.0.21-1.33
  • freeradius-server-mysql >= 3.0.21-1.33
  • freeradius-server-perl >= 3.0.21-1.33
  • freeradius-server-postgresql >= 3.0.21-1.33
  • freeradius-server-python3 >= 3.0.21-1.33
  • freeradius-server-sqlite >= 3.0.21-1.33
  • freeradius-server-utils >= 3.0.21-1.33
SUSE Linux Enterprise Module for Server Applications 15
  • freeradius-server >= 3.0.16-3.3.1
  • freeradius-server-devel >= 3.0.16-3.3.1
  • freeradius-server-krb5 >= 3.0.16-3.3.1
  • freeradius-server-ldap >= 3.0.16-3.3.1
  • freeradius-server-libs >= 3.0.16-3.3.1
  • freeradius-server-mysql >= 3.0.16-3.3.1
  • freeradius-server-perl >= 3.0.16-3.3.1
  • freeradius-server-postgresql >= 3.0.16-3.3.1
  • freeradius-server-python >= 3.0.16-3.3.1
  • freeradius-server-sqlite >= 3.0.16-3.3.1
  • freeradius-server-utils >= 3.0.16-3.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-2019-1086
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • freeradius-server >= 3.0.3-17.12.1
  • freeradius-server-doc >= 3.0.3-17.12.1
  • freeradius-server-krb5 >= 3.0.3-17.12.1
  • freeradius-server-ldap >= 3.0.3-17.12.1
  • freeradius-server-libs >= 3.0.3-17.12.1
  • freeradius-server-mysql >= 3.0.3-17.12.1
  • freeradius-server-perl >= 3.0.3-17.12.1
  • freeradius-server-postgresql >= 3.0.3-17.12.1
  • freeradius-server-python >= 3.0.3-17.12.1
  • freeradius-server-sqlite >= 3.0.3-17.12.1
  • freeradius-server-utils >= 3.0.3-17.12.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-1039
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • freeradius-server >= 3.0.3-17.12.1
  • freeradius-server-doc >= 3.0.3-17.12.1
  • freeradius-server-krb5 >= 3.0.3-17.12.1
  • freeradius-server-ldap >= 3.0.3-17.12.1
  • freeradius-server-libs >= 3.0.3-17.12.1
  • freeradius-server-mysql >= 3.0.3-17.12.1
  • freeradius-server-perl >= 3.0.3-17.12.1
  • freeradius-server-postgresql >= 3.0.3-17.12.1
  • freeradius-server-python >= 3.0.3-17.12.1
  • freeradius-server-sqlite >= 3.0.3-17.12.1
  • freeradius-server-utils >= 3.0.3-17.12.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-1039
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • freeradius-server >= 3.0.3-17.12.1
  • freeradius-server-doc >= 3.0.3-17.12.1
  • freeradius-server-krb5 >= 3.0.3-17.12.1
  • freeradius-server-ldap >= 3.0.3-17.12.1
  • freeradius-server-libs >= 3.0.3-17.12.1
  • freeradius-server-mysql >= 3.0.3-17.12.1
  • freeradius-server-perl >= 3.0.3-17.12.1
  • freeradius-server-postgresql >= 3.0.3-17.12.1
  • freeradius-server-python >= 3.0.3-17.12.1
  • freeradius-server-sqlite >= 3.0.3-17.12.1
  • freeradius-server-utils >= 3.0.3-17.12.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-1039
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • freeradius-server >= 3.0.3-17.12.1
  • freeradius-server-doc >= 3.0.3-17.12.1
  • freeradius-server-krb5 >= 3.0.3-17.12.1
  • freeradius-server-ldap >= 3.0.3-17.12.1
  • freeradius-server-libs >= 3.0.3-17.12.1
  • freeradius-server-mysql >= 3.0.3-17.12.1
  • freeradius-server-perl >= 3.0.3-17.12.1
  • freeradius-server-postgresql >= 3.0.3-17.12.1
  • freeradius-server-python >= 3.0.3-17.12.1
  • freeradius-server-sqlite >= 3.0.3-17.12.1
  • freeradius-server-utils >= 3.0.3-17.12.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-1039
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • freeradius-server >= 3.0.3-17.12.1
  • freeradius-server-doc >= 3.0.3-17.12.1
  • freeradius-server-krb5 >= 3.0.3-17.12.1
  • freeradius-server-ldap >= 3.0.3-17.12.1
  • freeradius-server-libs >= 3.0.3-17.12.1
  • freeradius-server-mysql >= 3.0.3-17.12.1
  • freeradius-server-perl >= 3.0.3-17.12.1
  • freeradius-server-postgresql >= 3.0.3-17.12.1
  • freeradius-server-python >= 3.0.3-17.12.1
  • freeradius-server-sqlite >= 3.0.3-17.12.1
  • freeradius-server-utils >= 3.0.3-17.12.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-1039
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • freeradius-server >= 3.0.15-2.11.2
  • freeradius-server-doc >= 3.0.15-2.11.2
  • freeradius-server-krb5 >= 3.0.15-2.11.2
  • freeradius-server-ldap >= 3.0.15-2.11.2
  • freeradius-server-libs >= 3.0.15-2.11.2
  • freeradius-server-mysql >= 3.0.15-2.11.2
  • freeradius-server-perl >= 3.0.15-2.11.2
  • freeradius-server-postgresql >= 3.0.15-2.11.2
  • freeradius-server-python >= 3.0.15-2.11.2
  • freeradius-server-sqlite >= 3.0.15-2.11.2
  • freeradius-server-utils >= 3.0.15-2.11.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-1181
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • freeradius-server >= 3.0.15-2.11.2
  • freeradius-server-doc >= 3.0.15-2.11.2
  • freeradius-server-krb5 >= 3.0.15-2.11.2
  • freeradius-server-ldap >= 3.0.15-2.11.2
  • freeradius-server-libs >= 3.0.15-2.11.2
  • freeradius-server-mysql >= 3.0.15-2.11.2
  • freeradius-server-perl >= 3.0.15-2.11.2
  • freeradius-server-postgresql >= 3.0.15-2.11.2
  • freeradius-server-python >= 3.0.15-2.11.2
  • freeradius-server-sqlite >= 3.0.15-2.11.2
  • freeradius-server-utils >= 3.0.15-2.11.2
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-1181
SUSE Linux Enterprise Server 12-LTSS
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • freeradius-server >= 3.0.3-17.12.1
  • freeradius-server-doc >= 3.0.3-17.12.1
  • freeradius-server-krb5 >= 3.0.3-17.12.1
  • freeradius-server-ldap >= 3.0.3-17.12.1
  • freeradius-server-libs >= 3.0.3-17.12.1
  • freeradius-server-mysql >= 3.0.3-17.12.1
  • freeradius-server-perl >= 3.0.3-17.12.1
  • freeradius-server-postgresql >= 3.0.3-17.12.1
  • freeradius-server-python >= 3.0.3-17.12.1
  • freeradius-server-sqlite >= 3.0.3-17.12.1
  • freeradius-server-utils >= 3.0.3-17.12.1
Patchnames:
SUSE-SLE-SERVER-12-2019-1039
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • freeradius-server >= 3.0.3-17.12.1
  • freeradius-server-doc >= 3.0.3-17.12.1
  • freeradius-server-krb5 >= 3.0.3-17.12.1
  • freeradius-server-ldap >= 3.0.3-17.12.1
  • freeradius-server-libs >= 3.0.3-17.12.1
  • freeradius-server-mysql >= 3.0.3-17.12.1
  • freeradius-server-perl >= 3.0.3-17.12.1
  • freeradius-server-postgresql >= 3.0.3-17.12.1
  • freeradius-server-python >= 3.0.3-17.12.1
  • freeradius-server-sqlite >= 3.0.3-17.12.1
  • freeradius-server-utils >= 3.0.3-17.12.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-1039
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • freeradius-server >= 3.0.3-17.12.1
  • freeradius-server-doc >= 3.0.3-17.12.1
  • freeradius-server-krb5 >= 3.0.3-17.12.1
  • freeradius-server-ldap >= 3.0.3-17.12.1
  • freeradius-server-libs >= 3.0.3-17.12.1
  • freeradius-server-mysql >= 3.0.3-17.12.1
  • freeradius-server-perl >= 3.0.3-17.12.1
  • freeradius-server-postgresql >= 3.0.3-17.12.1
  • freeradius-server-python >= 3.0.3-17.12.1
  • freeradius-server-sqlite >= 3.0.3-17.12.1
  • freeradius-server-utils >= 3.0.3-17.12.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-1039
SUSE Linux Enterprise Software Development Kit 12 SP3
  • freeradius-server >= 3.0.15-2.11.2
  • freeradius-server-devel >= 3.0.15-2.11.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2019-1181
SUSE Linux Enterprise Software Development Kit 12 SP4
  • freeradius-server >= 3.0.15-2.11.2
  • freeradius-server-devel >= 3.0.15-2.11.2
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-1181
SUSE Linux Enterprise Software Development Kit 12 SP5
  • freeradius-server-devel >= 3.0.19-1.48
SUSE OpenStack Cloud 7
  • freeradius-server >= 3.0.3-17.12.1
  • freeradius-server-doc >= 3.0.3-17.12.1
  • freeradius-server-krb5 >= 3.0.3-17.12.1
  • freeradius-server-ldap >= 3.0.3-17.12.1
  • freeradius-server-libs >= 3.0.3-17.12.1
  • freeradius-server-mysql >= 3.0.3-17.12.1
  • freeradius-server-perl >= 3.0.3-17.12.1
  • freeradius-server-postgresql >= 3.0.3-17.12.1
  • freeradius-server-python >= 3.0.3-17.12.1
  • freeradius-server-sqlite >= 3.0.3-17.12.1
  • freeradius-server-utils >= 3.0.3-17.12.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-1039
openSUSE Leap 15.0
  • freeradius-server >= 3.0.16-lp150.2.3.1
  • freeradius-server-debuginfo >= 3.0.16-lp150.2.3.1
  • freeradius-server-debugsource >= 3.0.16-lp150.2.3.1
  • freeradius-server-devel >= 3.0.16-lp150.2.3.1
  • freeradius-server-doc >= 3.0.16-lp150.2.3.1
  • freeradius-server-krb5 >= 3.0.16-lp150.2.3.1
  • freeradius-server-krb5-debuginfo >= 3.0.16-lp150.2.3.1
  • freeradius-server-ldap >= 3.0.16-lp150.2.3.1
  • freeradius-server-ldap-debuginfo >= 3.0.16-lp150.2.3.1
  • freeradius-server-libs >= 3.0.16-lp150.2.3.1
  • freeradius-server-libs-debuginfo >= 3.0.16-lp150.2.3.1
  • freeradius-server-mysql >= 3.0.16-lp150.2.3.1
  • freeradius-server-mysql-debuginfo >= 3.0.16-lp150.2.3.1
  • freeradius-server-perl >= 3.0.16-lp150.2.3.1
  • freeradius-server-perl-debuginfo >= 3.0.16-lp150.2.3.1
  • freeradius-server-postgresql >= 3.0.16-lp150.2.3.1
  • freeradius-server-postgresql-debuginfo >= 3.0.16-lp150.2.3.1
  • freeradius-server-python >= 3.0.16-lp150.2.3.1
  • freeradius-server-python-debuginfo >= 3.0.16-lp150.2.3.1
  • freeradius-server-sqlite >= 3.0.16-lp150.2.3.1
  • freeradius-server-sqlite-debuginfo >= 3.0.16-lp150.2.3.1
  • freeradius-server-utils >= 3.0.16-lp150.2.3.1
  • freeradius-server-utils-debuginfo >= 3.0.16-lp150.2.3.1
Patchnames:
openSUSE-2019-1346
openSUSE Leap 15.1
  • freeradius-server >= 3.0.16-lp151.4.3.1
  • freeradius-server-debuginfo >= 3.0.16-lp151.4.3.1
  • freeradius-server-debugsource >= 3.0.16-lp151.4.3.1
  • freeradius-server-devel >= 3.0.16-lp151.4.3.1
  • freeradius-server-doc >= 3.0.16-lp151.4.3.1
  • freeradius-server-krb5 >= 3.0.16-lp151.4.3.1
  • freeradius-server-krb5-debuginfo >= 3.0.16-lp151.4.3.1
  • freeradius-server-ldap >= 3.0.16-lp151.4.3.1
  • freeradius-server-ldap-debuginfo >= 3.0.16-lp151.4.3.1
  • freeradius-server-libs >= 3.0.16-lp151.4.3.1
  • freeradius-server-libs-debuginfo >= 3.0.16-lp151.4.3.1
  • freeradius-server-mysql >= 3.0.16-lp151.4.3.1
  • freeradius-server-mysql-debuginfo >= 3.0.16-lp151.4.3.1
  • freeradius-server-perl >= 3.0.16-lp151.4.3.1
  • freeradius-server-perl-debuginfo >= 3.0.16-lp151.4.3.1
  • freeradius-server-postgresql >= 3.0.16-lp151.4.3.1
  • freeradius-server-postgresql-debuginfo >= 3.0.16-lp151.4.3.1
  • freeradius-server-python >= 3.0.16-lp151.4.3.1
  • freeradius-server-python-debuginfo >= 3.0.16-lp151.4.3.1
  • freeradius-server-sqlite >= 3.0.16-lp151.4.3.1
  • freeradius-server-sqlite-debuginfo >= 3.0.16-lp151.4.3.1
  • freeradius-server-utils >= 3.0.16-lp151.4.3.1
  • freeradius-server-utils-debuginfo >= 3.0.16-lp151.4.3.1
Patchnames:
openSUSE-2020-542
openSUSE Leap 42.3
  • freeradius-server >= 3.0.15-9.1
  • freeradius-server-debuginfo >= 3.0.15-9.1
  • freeradius-server-debugsource >= 3.0.15-9.1
  • freeradius-server-devel >= 3.0.15-9.1
  • freeradius-server-doc >= 3.0.15-9.1
  • freeradius-server-krb5 >= 3.0.15-9.1
  • freeradius-server-krb5-debuginfo >= 3.0.15-9.1
  • freeradius-server-ldap >= 3.0.15-9.1
  • freeradius-server-ldap-debuginfo >= 3.0.15-9.1
  • freeradius-server-libs >= 3.0.15-9.1
  • freeradius-server-libs-debuginfo >= 3.0.15-9.1
  • freeradius-server-mysql >= 3.0.15-9.1
  • freeradius-server-mysql-debuginfo >= 3.0.15-9.1
  • freeradius-server-perl >= 3.0.15-9.1
  • freeradius-server-perl-debuginfo >= 3.0.15-9.1
  • freeradius-server-postgresql >= 3.0.15-9.1
  • freeradius-server-postgresql-debuginfo >= 3.0.15-9.1
  • freeradius-server-python >= 3.0.15-9.1
  • freeradius-server-python-debuginfo >= 3.0.15-9.1
  • freeradius-server-sqlite >= 3.0.15-9.1
  • freeradius-server-sqlite-debuginfo >= 3.0.15-9.1
  • freeradius-server-utils >= 3.0.15-9.1
  • freeradius-server-utils-debuginfo >= 3.0.15-9.1
Patchnames:
openSUSE-2019-1394


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications freeradius-server Not affected
SUSE Linux Enterprise 15 Module for Server Applications freeradius-server Released
SUSE Linux Enterprise High Performance Computing 12 SP4 freeradius-server Released
SUSE Linux Enterprise Server 11 SP3 LTSS freeradius-server Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS freeradius-server Not affected
SUSE Linux Enterprise Server 12 LTSS freeradius-server Released
SUSE Linux Enterprise Server 12 SP1 LTSS freeradius-server Released
SUSE Linux Enterprise Server 12 SP2 LTSS freeradius-server Released
SUSE Linux Enterprise Server 12 SP3 freeradius-server Released
SUSE Linux Enterprise Server 12 SP4 freeradius-server Released
SUSE Linux Enterprise Server for SAP Applications 12 freeradius-server Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 freeradius-server Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 freeradius-server Released
SUSE Linux Enterprise Software Development Kit 12 SP3 freeradius-server Released
SUSE Linux Enterprise Software Development Kit 12 SP4 freeradius-server Released