Upstream information

CVE-2018-5804 at MITRE

Description

A type confusion error within the "identify()" function (internal/dcraw_common.cpp) in LibRaw versions prior to 0.18.8 can be exploited to trigger a division by zero.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 6.2
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entry: 1097975 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • libraw >= 0.18.9-3.5.1
  • libraw-devel-static >= 0.18.9-3.5.1
  • libraw-tools >= 0.18.9-3.5.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-5
SUSE Linux Enterprise Workstation Extension 15
  • libraw >= 0.18.9-3.5.1
  • libraw-devel >= 0.18.9-3.5.1
  • libraw16 >= 0.18.9-3.5.1
Patchnames:
SUSE-SLE-Product-WE-15-2019-5
openSUSE Leap 15.0
  • libraw >= 0.18.9-lp150.2.3.1
  • libraw-debuginfo >= 0.18.9-lp150.2.3.1
  • libraw-debugsource >= 0.18.9-lp150.2.3.1
  • libraw-devel >= 0.18.9-lp150.2.3.1
  • libraw-devel-static >= 0.18.9-lp150.2.3.1
  • libraw-tools >= 0.18.9-lp150.2.3.1
  • libraw-tools-debuginfo >= 0.18.9-lp150.2.3.1
  • libraw16 >= 0.18.9-lp150.2.3.1
  • libraw16-debuginfo >= 0.18.9-lp150.2.3.1
Patchnames:
openSUSE-2019-8
openSUSE Leap 42.3
  • libraw >= 0.17.1-26.1
  • libraw-debugsource >= 0.17.1-26.1
  • libraw-devel >= 0.17.1-26.1
  • libraw-devel-static >= 0.17.1-26.1
  • libraw-tools >= 0.17.1-26.1
  • libraw-tools-debuginfo >= 0.17.1-26.1
  • libraw15 >= 0.17.1-26.1
  • libraw15-debuginfo >= 0.17.1-26.1
Patchnames:
openSUSE-2018-1619


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 dcraw Affected
SUSE Linux Enterprise Desktop 12 SP3 libraw Not affected
SUSE Linux Enterprise Desktop 12 SP4 dcraw Affected
SUSE Linux Enterprise Desktop 12 SP4 libraw Not affected
SUSE Linux Enterprise SDK 11 SP4 dcraw Affected
SUSE Linux Enterprise SDK 12 SP3 dcraw Affected
SUSE Linux Enterprise SDK 12 SP3 libraw Not affected
SUSE Linux Enterprise SDK 12 SP4 dcraw Affected
SUSE Linux Enterprise SDK 12 SP4 libraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP3 dcraw Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 libraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP4 dcraw Affected
SUSE Linux Enterprise Workstation Extension 12 SP4 libraw Not affected
SUSE Linux Enterprise Workstation Extension 15 GA libraw Released