Upstream information

CVE-2018-5738 at MITRE

Description

Change #4777 (introduced in October 2017) introduced an unforeseen issue in releases which were issued after that date, affecting which clients are permitted to make recursive queries to a BIND nameserver. The intended (and documented) behavior is that if an operator has not specified a value for the "allow-recursion" setting, it SHOULD default to one of the following: none, if "recursion no;" is set in named.conf; a value inherited from the "allow-query-cache" or "allow-query" settings IF "recursion yes;" (the default for that setting) AND match lists are explicitly set for "allow-query-cache" or "allow-query" (see the BIND9 Administrative Reference Manual section 6.2 for more details); or the intended default of "allow-recursion {localhost; localnets;};" if "recursion yes;" is in effect and no values are explicitly set for "allow-query-cache" or "allow-query". However, because of the regression introduced by change #4777, it is possible when "recursion yes;" is in effect and no match list values are provided for "allow-query-cache" or "allow-query" for the setting of "allow-recursion" to inherit a setting of all hosts from the "allow-query" setting default, improperly permitting recursion to all clients. Affects BIND 9.9.12, 9.10.7, 9.11.3, 9.12.0->9.12.1-P2, the development release 9.13.0, and also releases 9.9.12-S1, 9.10.7-S1, 9.11.3-S1, and 9.11.3-S2 from BIND 9 Supported Preview Edition.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.3
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1096864 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • bind >= 9.16.6-20.39
  • bind-chrootenv >= 9.16.6-20.39
  • bind-devel >= 9.16.6-20.39
  • bind-doc >= 9.16.6-20.39
  • bind-utils >= 9.16.6-20.39
  • libbind9-1600 >= 9.16.6-20.39
  • libdns1605 >= 9.16.6-20.39
  • libirs-devel >= 9.16.6-20.39
  • libirs1601 >= 9.16.6-20.39
  • libisc1606 >= 9.16.6-20.39
  • libisccc1600 >= 9.16.6-20.39
  • libisccfg1600 >= 9.16.6-20.39
  • libns1604 >= 9.16.6-20.39
  • python3-bind >= 9.16.6-20.39
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA bind-devel-9.16.6-20.39
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA bind-9.16.6-20.39
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise Module for Basesystem 15 SP3
  • bind-devel >= 9.16.6-20.39
  • bind-utils >= 9.16.6-20.39
  • libbind9-1600 >= 9.16.6-20.39
  • libdns1605 >= 9.16.6-20.39
  • libirs-devel >= 9.16.6-20.39
  • libirs1601 >= 9.16.6-20.39
  • libisc1606 >= 9.16.6-20.39
  • libisccc1600 >= 9.16.6-20.39
  • libisccfg1600 >= 9.16.6-20.39
  • libns1604 >= 9.16.6-20.39
  • python3-bind >= 9.16.6-20.39
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP3 GA bind-devel-9.16.6-20.39
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Module for Basesystem 15 SP4
  • bind-utils >= 9.16.20-150400.3.6
  • python3-bind >= 9.16.20-150400.3.6
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA bind-utils-9.16.20-150400.3.6
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • bind-devel >= 9.16.6-150300.22.27.1
  • bind-utils >= 9.16.38-150400.5.20.2
  • libbind9-1600 >= 9.16.6-150300.22.27.1
  • libdns1605 >= 9.16.6-150300.22.27.1
  • libirs-devel >= 9.16.6-150300.22.27.1
  • libirs1601 >= 9.16.6-150300.22.27.1
  • libisc1606 >= 9.16.6-150300.22.27.1
  • libisccc1600 >= 9.16.6-150300.22.27.1
  • libisccfg1600 >= 9.16.6-150300.22.27.1
  • libns1604 >= 9.16.6-150300.22.27.1
  • python3-bind >= 9.16.38-150400.5.20.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP5 GA bind-devel-9.16.6-150300.22.27.1
SUSE Linux Enterprise Module for Basesystem 15 SP5 GA bind-utils-9.16.38-150400.5.20.2
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • bind >= 9.16.20-150400.3.6
  • bind-doc >= 9.16.20-150400.3.6
  • bind-utils >= 9.16.20-150400.3.6
  • python3-bind >= 9.16.20-150400.3.6
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP4 GA bind-utils-9.16.20-150400.3.6
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA bind-9.16.20-150400.3.6
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • bind >= 9.16.6-20.39
  • bind-chrootenv >= 9.16.6-20.39
  • bind-doc >= 9.16.6-20.39
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA bind-9.16.6-20.39
SUSE Linux Enterprise Module for Server Applications 15 SP4
  • bind >= 9.16.20-150400.3.6
  • bind-doc >= 9.16.20-150400.3.6
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA bind-9.16.20-150400.3.6
openSUSE Leap 15.3
  • bind >= 9.16.6-20.39
  • bind-chrootenv >= 9.16.6-20.39
  • bind-utils >= 9.16.6-20.39
  • libbind9-1600 >= 9.16.6-20.39
  • libdns1605 >= 9.16.6-20.39
  • libirs1601 >= 9.16.6-20.39
  • libisc1606 >= 9.16.6-20.39
  • libisccc1600 >= 9.16.6-20.39
  • libisccfg1600 >= 9.16.6-20.39
  • libns1604 >= 9.16.6-20.39
  • python3-bind >= 9.16.6-20.39
Patchnames:
openSUSE Leap 15.3 GA bind-9.16.6-20.39
openSUSE Leap 15.4
  • bind >= 9.16.20-150400.3.6
  • bind-utils >= 9.16.20-150400.3.6
  • python3-bind >= 9.16.20-150400.3.6
Patchnames:
openSUSE Leap 15.4 GA bind-9.16.20-150400.3.6


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Performance Computing 12 SP5 bind Not affected
SUSE Linux Enterprise Server 12 SP5 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 bind Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 bind Not affected
SUSE Manager Tools for SLE Micro 5 bind Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 bind Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS bind Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS bind Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 bind Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP2 bind Unsupported
SUSE Linux Enterprise Server 15 SP2 bind Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS bind Not affected
SUSE Linux Enterprise Server 15-ESPOS bind Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 bind Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 bind Unsupported
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 bind Not affected
SUSE CaaS Platform 3.0 bind Not affected
SUSE CaaS Platform 4.0 bind Not affected
SUSE Enterprise Storage 6 bind Affected
SUSE Enterprise Storage 7 bind Unsupported
SUSE Linux Enterprise Desktop 11 bind Not affected
SUSE Linux Enterprise Desktop 11 SP1 bind Not affected
SUSE Linux Enterprise Desktop 11 SP2 bind Not affected
SUSE Linux Enterprise Desktop 11 SP3 bind Not affected
SUSE Linux Enterprise Desktop 11 SP4 bind Not affected
SUSE Linux Enterprise Desktop 12 SP1 bind Not affected
SUSE Linux Enterprise Desktop 12 SP2 bind Not affected
SUSE Linux Enterprise Desktop 12 SP3 bind Not affected
SUSE Linux Enterprise Desktop 12 SP4 bind Unsupported
SUSE Linux Enterprise Desktop 15 bind Not affected
SUSE Linux Enterprise Desktop 15 SP1 bind Not affected
SUSE Linux Enterprise Desktop 15 SP2 bind Unsupported
SUSE Linux Enterprise High Performance Computing 12 SP4 bind Affected
SUSE Linux Enterprise High Performance Computing 15 bind Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 bind Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS bind Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS bind Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS bind Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS bind Unsupported
SUSE Linux Enterprise Module for Basesystem 15 bind Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 bind Not affected
SUSE Linux Enterprise Module for Server Applications 15 bind Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 bind Not affected
SUSE Linux Enterprise Real Time 15 SP2 bind Not affected
SUSE Linux Enterprise Server 11 SP3 bind Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS bind Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS bind Not affected
SUSE Linux Enterprise Server 11 SP4 bind Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS bind Not affected
SUSE Linux Enterprise Server 12 SP1 bind Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS bind Not affected
SUSE Linux Enterprise Server 12 SP2 bind Not affected
SUSE Linux Enterprise Server 12 SP2-BCL bind Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS bind Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS bind Not affected
SUSE Linux Enterprise Server 12 SP3 bind Not affected
SUSE Linux Enterprise Server 12 SP3-BCL bind Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS bind Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS bind Not affected
SUSE Linux Enterprise Server 12 SP4 bind Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS bind Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS bind Not affected
SUSE Linux Enterprise Server 15 bind Not affected
SUSE Linux Enterprise Server 15 SP1 bind Not affected
SUSE Linux Enterprise Server 15 SP1-BCL bind Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS bind Not affected
SUSE Linux Enterprise Server 15 SP2-BCL bind Not affected
SUSE Linux Enterprise Server 15-LTSS bind Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 15 bind Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 bind Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 bind Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 bind Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 bind Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 bind Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 bind Unsupported
SUSE Manager Proxy 4.0 bind Unsupported
SUSE Manager Proxy 4.1 bind Unsupported
SUSE Manager Retail Branch Server 4.0 bind Unsupported
SUSE Manager Retail Branch Server 4.1 bind Unsupported
SUSE Manager Server 4.0 bind Unsupported
SUSE Manager Server 4.1 bind Unsupported
SUSE OpenStack Cloud 7 bind Not affected
SUSE OpenStack Cloud 8 bind Not affected
SUSE OpenStack Cloud 9 bind Not affected
SUSE OpenStack Cloud Crowbar 8 bind Not affected
SUSE OpenStack Cloud Crowbar 9 bind Not affected


SUSE Timeline for this CVE

CVE page created: Mon Jun 11 07:58:24 2018
CVE page last modified: Sat Jun 15 23:58:39 2024