Upstream information

CVE-2017-12955 at MITRE

Description

There is a heap-based buffer overflow in basicio.cpp of Exiv2 0.26. The vulnerability causes an out-of-bounds write in Exiv2::Image::printIFDStructure(), which may lead to remote denial of service or possibly unspecified other impact.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entries: 1054593 [RESOLVED / FIXED], 1061023 [RESOLVED / FIXED], 1061025 [RESOLVED / INVALID], 1068871 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise Desktop 15 SP1
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • libexiv2-26 >= 0.26-6.3.1
  • libexiv2-devel >= 0.26-6.3.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA libexiv2-26-0.26-6.3.1
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Desktop Applications 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • libexiv2-26 >= 0.26-6.8.1
  • libexiv2-devel >= 0.26-6.8.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 GA libexiv2-26-0.26-6.8.1
SUSE Enterprise Storage 7
SUSE Linux Enterprise Desktop 15 SP2
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • libexiv2-26 >= 0.26-6.8.1
  • libexiv2-devel >= 0.26-6.8.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 GA libexiv2-26-0.26-6.8.1
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libexiv2-26 >= 0.26-6.8.1
  • libexiv2-devel >= 0.26-6.8.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 GA libexiv2-26-0.26-6.8.1
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Module for Desktop Applications 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • libexiv2-26 >= 0.26-6.3.1
  • libexiv2-devel >= 0.26-6.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-1280
openSUSE Leap 15.0
  • exiv2 >= 0.26-lp150.5.3.1
  • exiv2-lang >= 0.26-lp150.5.3.1
  • libexiv2-26 >= 0.26-lp150.5.3.1
  • libexiv2-26-32bit >= 0.26-lp150.5.3.1
  • libexiv2-devel >= 0.26-lp150.5.3.1
  • libexiv2-doc >= 0.26-lp150.5.3.1
Patchnames:
openSUSE-2019-504
openSUSE Leap 15.2
  • libexiv2-26 >= 0.26-lp152.8.3
Patchnames:
openSUSE Leap 15.2 GA libexiv2-26-0.26-lp152.8.1
openSUSE Leap 15.3
  • libexiv2-26 >= 0.26-6.8.1
Patchnames:
openSUSE Leap 15.3 GA libexiv2-26-0.26-6.8.1
openSUSE Leap 15.4
  • libexiv2-26 >= 0.26-6.8.1
Patchnames:
openSUSE Leap 15.4 GA libexiv2-26-0.26-6.8.1
openSUSE Tumbleweed
  • exiv2 >= 0.27.4-1.2
  • exiv2-lang >= 0.27.4-1.2
  • libexiv2-27 >= 0.27.4-1.2
  • libexiv2-27-32bit >= 0.27.4-1.2
  • libexiv2-devel >= 0.27.4-1.2
  • libexiv2-xmp-static >= 0.27.4-1.2
Patchnames:
openSUSE Tumbleweed GA exiv2-0.27.4-1.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 exiv2 Affected
SUSE Enterprise Storage 7.1 exiv2 Unsupported
SUSE Linux Enterprise Desktop 15 SP4 exiv2 Released
SUSE Linux Enterprise Desktop 15 SP4 exiv2-0_26 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 exiv2 Released
SUSE Linux Enterprise High Performance Computing 15 SP4 exiv2-0_26 Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 exiv2 Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 exiv2-0_26 Affected
SUSE Linux Enterprise Real Time 15 SP3 exiv2 Affected
SUSE Linux Enterprise Server 12 SP5 exiv2 Won't fix
SUSE Linux Enterprise Server 12-LTSS exiv2 Not affected
SUSE Linux Enterprise Server 15 SP4 exiv2 Released
SUSE Linux Enterprise Server 15 SP4 exiv2-0_26 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 exiv2 Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP4 exiv2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 exiv2-0_26 Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 exiv2 Won't fix
SUSE Manager Proxy 4.2 exiv2 Unsupported
SUSE Manager Proxy 4.3 exiv2 Released
SUSE Manager Proxy 4.3 exiv2-0_26 Affected
SUSE Manager Retail Branch Server 4.2 exiv2 Unsupported
SUSE Manager Retail Branch Server 4.3 exiv2 Released
SUSE Manager Retail Branch Server 4.3 exiv2-0_26 Affected
SUSE Manager Server 4.2 exiv2 Unsupported
SUSE Manager Server 4.3 exiv2 Released
SUSE Manager Server 4.3 exiv2-0_26 Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 exiv2 Released
SUSE Linux Enterprise High Performance Computing 15 SP1 exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS exiv2 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS exiv2 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 exiv2 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS exiv2 Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS exiv2 Unsupported
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 exiv2 Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 exiv2 Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 exiv2 Unsupported
SUSE Linux Enterprise Server 12 SP2-BCL exiv2 Won't fix
SUSE Linux Enterprise Server 12 SP4 exiv2 Won't fix
SUSE Linux Enterprise Server 12 SP4-LTSS exiv2 Won't fix
SUSE Linux Enterprise Server 15 SP1 exiv2 Affected
SUSE Linux Enterprise Server 15 SP1-LTSS exiv2 Affected
SUSE Linux Enterprise Server 15 SP2 exiv2 Affected
SUSE Linux Enterprise Server 15 SP2-LTSS exiv2 Affected
SUSE Linux Enterprise Server 15 SP3 exiv2 Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS exiv2 Affected
SUSE Linux Enterprise Server 15-ESPOS exiv2 Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 exiv2 Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 exiv2 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 exiv2 Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 exiv2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 exiv2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 exiv2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 exiv2 Unsupported
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 exiv2 Won't fix
SUSE CaaS Platform 4.0 exiv2 Affected
SUSE Enterprise Storage 6 exiv2 Affected
SUSE Linux Enterprise Desktop 11 SP4 exiv2 Not affected
SUSE Linux Enterprise Desktop 12 exiv2 Won't fix
SUSE Linux Enterprise Desktop 12 SP1 exiv2 Won't fix
SUSE Linux Enterprise Desktop 12 SP2 exiv2 Affected
SUSE Linux Enterprise Desktop 12 SP3 exiv2 Not affected
SUSE Linux Enterprise Desktop 12 SP4 exiv2 Won't fix
SUSE Linux Enterprise Desktop 15 exiv2 Released
SUSE Linux Enterprise Desktop 15 SP1 exiv2 Affected
SUSE Linux Enterprise Desktop 15 SP2 exiv2 Affected
SUSE Linux Enterprise Desktop 15 SP3 exiv2 Unsupported
SUSE Linux Enterprise Module for Desktop Applications 15 exiv2 Released
SUSE Linux Enterprise Real Time 15 SP2 exiv2 Affected
SUSE Linux Enterprise Server 11 SP3 exiv2 Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS exiv2 Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS exiv2 Not affected
SUSE Linux Enterprise Server 11 SP4 exiv2 Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS exiv2 Not affected
SUSE Linux Enterprise Server 12 exiv2 Won't fix
SUSE Linux Enterprise Server 12 SP1 exiv2 Won't fix
SUSE Linux Enterprise Server 12 SP1-LTSS exiv2 Not affected
SUSE Linux Enterprise Server 12 SP2 exiv2 Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS exiv2 Won't fix
SUSE Linux Enterprise Server 12 SP2-LTSS exiv2 Won't fix
SUSE Linux Enterprise Server 12 SP3 exiv2 Not affected
SUSE Linux Enterprise Server 12 SP3-BCL exiv2 Won't fix
SUSE Linux Enterprise Server 12 SP3-ESPOS exiv2 Won't fix
SUSE Linux Enterprise Server 12 SP3-LTSS exiv2 Won't fix
SUSE Linux Enterprise Server 12 SP4-ESPOS exiv2 Won't fix
SUSE Linux Enterprise Server 15 exiv2 Released
SUSE Linux Enterprise Server 15 SP1-BCL exiv2 Affected
SUSE Linux Enterprise Server 15 SP2-BCL exiv2 Affected
SUSE Linux Enterprise Server 15 SP3-BCL exiv2 Affected
SUSE Linux Enterprise Server 15-LTSS exiv2 Unsupported
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 exiv2 Won't fix
SUSE Linux Enterprise Server for SAP Applications 11 SP4 exiv2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 exiv2 Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP1 exiv2 Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP2 exiv2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 exiv2 Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 exiv2 Not affected
SUSE Linux Enterprise Software Development Kit 12 exiv2 Won't fix
SUSE Linux Enterprise Software Development Kit 12 SP1 exiv2 Won't fix
SUSE Linux Enterprise Software Development Kit 12 SP2 exiv2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 exiv2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 exiv2 Won't fix
SUSE Manager Proxy 4.0 exiv2 Affected
SUSE Manager Proxy 4.1 exiv2 Affected
SUSE Manager Retail Branch Server 4.0 exiv2 Affected
SUSE Manager Retail Branch Server 4.1 exiv2 Affected
SUSE Manager Server 4.0 exiv2 Affected
SUSE Manager Server 4.1 exiv2 Affected
SUSE OpenStack Cloud 7 exiv2 Won't fix
SUSE OpenStack Cloud 8 exiv2 Won't fix
SUSE OpenStack Cloud 9 exiv2 Won't fix
SUSE OpenStack Cloud Crowbar 8 exiv2 Won't fix
SUSE OpenStack Cloud Crowbar 9 exiv2 Won't fix


SUSE Timeline for this CVE

CVE page created: Sat Aug 19 00:36:32 2017
CVE page last modified: Fri Jan 20 13:46:17 2023