Upstream information

CVE-2016-20013 at MITRE

Description

sha256crypt and sha512crypt through 0.6 allow attackers to cause a denial of service (CPU consumption) because the algorithm's runtime is proportional to the square of the length of the password.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1196928 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SLES15-SP3-CHOST-BYOS-Aliyun glibc Won't fix
SLES15-SP3-CHOST-BYOS-Azure glibc Won't fix
SLES15-SP3-CHOST-BYOS-EC2 glibc Won't fix
SLES15-SP3-CHOST-BYOS-GCE glibc Won't fix
SLES15-SP4-CHOST-BYOS glibc Won't fix
SLES15-SP4-CHOST-BYOS-Aliyun glibc Won't fix
SLES15-SP4-CHOST-BYOS-Azure glibc Won't fix
SLES15-SP4-CHOST-BYOS-EC2 glibc Won't fix
SLES15-SP4-CHOST-BYOS-GCE glibc Won't fix
SUSE Enterprise Storage 7 glibc Won't fix
SUSE Enterprise Storage 7.1 glibc Won't fix
SUSE Linux Enterprise Desktop 15 SP4 glibc Won't fix
SUSE Linux Enterprise High Performance Computing 12 SP5 glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP4 glibc Won't fix
SUSE Linux Enterprise Micro 5.1 glibc Won't fix
SUSE Linux Enterprise Micro 5.2 glibc Won't fix
SUSE Linux Enterprise Micro 5.3 glibc Won't fix
SUSE Linux Enterprise Module for Basesystem 15 SP4 glibc Won't fix
SUSE Linux Enterprise Module for Development Tools 15 SP4 glibc Won't fix
SUSE Linux Enterprise Real Time 15 SP3 glibc Won't fix
SUSE Linux Enterprise Server 12 SP5 glibc Won't fix
SUSE Linux Enterprise Server 15 SP4 glibc Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP5 glibc Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP4 glibc Won't fix
SUSE Linux Enterprise Software Development Kit 12 SP5 glibc Won't fix
SUSE Manager Proxy 4.2 glibc Won't fix
SUSE Manager Proxy 4.3 glibc Won't fix
SUSE Manager Retail Branch Server 4.2 glibc Won't fix
SUSE Manager Retail Branch Server 4.3 glibc Won't fix
SUSE Manager Server 4.2 glibc Won't fix
SUSE Manager Server 4.3 glibc Won't fix
Products under Long Term Service Pack support and receiving important and critical security fixes.
SLES15-EC2-CHOST-HVM-BYOS glibc Won't fix
SLES15-SP1-CHOST-BYOS-Azure glibc Won't fix
SLES15-SP1-CHOST-BYOS-EC2 glibc Won't fix
SLES15-SP1-CHOST-BYOS-GCE glibc Won't fix
SLES15-SP2-CHOST-BYOS-Aliyun glibc Won't fix
SLES15-SP2-CHOST-BYOS-Azure glibc Won't fix
SLES15-SP2-CHOST-BYOS-EC2 glibc Won't fix
SLES15-SP2-CHOST-BYOS-GCE glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15 glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP1 glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP2 glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP3 glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15-ESPOS glibc Won't fix
SUSE Linux Enterprise High Performance Computing 15-LTSS glibc Won't fix
SUSE Linux Enterprise Module for Basesystem 15 SP1 glibc Won't fix
SUSE Linux Enterprise Module for Basesystem 15 SP2 glibc Won't fix
SUSE Linux Enterprise Module for Basesystem 15 SP3 glibc Won't fix
SUSE Linux Enterprise Module for Development Tools 15 SP1 glibc Won't fix
SUSE Linux Enterprise Module for Development Tools 15 SP2 glibc Won't fix
SUSE Linux Enterprise Module for Development Tools 15 SP3 glibc Won't fix
SUSE Linux Enterprise Module for Legacy 15 SP3 glibc Won't fix
SUSE Linux Enterprise Server 12 SP2-BCL glibc Won't fix
SUSE Linux Enterprise Server 12 SP4 glibc Won't fix
SUSE Linux Enterprise Server 12 SP4-LTSS glibc Won't fix
SUSE Linux Enterprise Server 15 SP1 glibc Won't fix
SUSE Linux Enterprise Server 15 SP1-LTSS glibc Won't fix
SUSE Linux Enterprise Server 15 SP2 glibc Won't fix
SUSE Linux Enterprise Server 15 SP2-LTSS glibc Won't fix
SUSE Linux Enterprise Server 15 SP3 glibc Won't fix
SUSE Linux Enterprise Server 15 SP3-LTSS glibc Won't fix
SUSE Linux Enterprise Server 15-ESPOS glibc Won't fix
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 glibc Won't fix
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 glibc Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP4 glibc Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 glibc Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP1 glibc Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP2 glibc Won't fix
SUSE Linux Enterprise Server for SAP Applications 15 SP3 glibc Won't fix
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 glibc Won't fix
SUSE CaaS Platform 3.0 glibc Won't fix
SUSE CaaS Platform 4.0 glibc Won't fix
SUSE Enterprise Storage 6 glibc Won't fix
SUSE Linux Enterprise Desktop 11 SP4 glibc Won't fix
SUSE Linux Enterprise Desktop 12 SP2 glibc Won't fix
SUSE Linux Enterprise Desktop 12 SP3 glibc Won't fix
SUSE Linux Enterprise Desktop 12 SP4 glibc Won't fix
SUSE Linux Enterprise Desktop 15 glibc Won't fix
SUSE Linux Enterprise Desktop 15 SP1 glibc Won't fix
SUSE Linux Enterprise Desktop 15 SP2 glibc Won't fix
SUSE Linux Enterprise Desktop 15 SP3 glibc Won't fix
SUSE Linux Enterprise Micro 5.0 glibc Won't fix
SUSE Linux Enterprise Module for Basesystem 15 glibc Won't fix
SUSE Linux Enterprise Module for Development Tools 15 glibc Won't fix
SUSE Linux Enterprise Real Time 15 SP2 glibc Won't fix
SUSE Linux Enterprise Server 11 SP1 glibc Unsupported
SUSE Linux Enterprise Server 11 SP3 glibc Won't fix
SUSE Linux Enterprise Server 11 SP3-LTSS glibc Won't fix
SUSE Linux Enterprise Server 11 SP4 glibc Won't fix
SUSE Linux Enterprise Server 11 SP4-LTSS glibc Analysis
SUSE Linux Enterprise Server 12 SP2 glibc Won't fix
SUSE Linux Enterprise Server 12 SP2-ESPOS glibc Won't fix
SUSE Linux Enterprise Server 12 SP2-LTSS glibc Won't fix
SUSE Linux Enterprise Server 12 SP3 glibc Won't fix
SUSE Linux Enterprise Server 12 SP3-BCL glibc Won't fix
SUSE Linux Enterprise Server 12 SP3-ESPOS glibc Won't fix
SUSE Linux Enterprise Server 12 SP3-LTSS glibc Won't fix
SUSE Linux Enterprise Server 12 SP4-ESPOS glibc Won't fix
SUSE Linux Enterprise Server 15 glibc Won't fix
SUSE Linux Enterprise Server 15 SP1-BCL glibc Won't fix
SUSE Linux Enterprise Server 15 SP2-BCL glibc Won't fix
SUSE Linux Enterprise Server 15 SP3-BCL glibc Won't fix
SUSE Linux Enterprise Server 15-LTSS glibc Won't fix
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 glibc Won't fix
SUSE Linux Enterprise Server for SAP Applications 11 SP4 glibc Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP2 glibc Won't fix
SUSE Linux Enterprise Server for SAP Applications 12 SP3 glibc Won't fix
SUSE Linux Enterprise Software Development Kit 11 SP4 glibc Won't fix
SUSE Linux Enterprise Software Development Kit 12 SP2 glibc Won't fix
SUSE Linux Enterprise Software Development Kit 12 SP3 glibc Won't fix
SUSE Linux Enterprise Software Development Kit 12 SP4 glibc Won't fix
SUSE Manager Proxy 4.0 glibc Won't fix
SUSE Manager Proxy 4.1 glibc Won't fix
SUSE Manager Retail Branch Server 4.0 glibc Won't fix
SUSE Manager Retail Branch Server 4.1 glibc Won't fix
SUSE Manager Server 4.0 glibc Won't fix
SUSE Manager Server 4.1 glibc Won't fix
SUSE OpenStack Cloud 7 glibc Won't fix
SUSE OpenStack Cloud 8 glibc Won't fix
SUSE OpenStack Cloud 9 glibc Won't fix
SUSE OpenStack Cloud Crowbar 8 glibc Won't fix
SUSE OpenStack Cloud Crowbar 9 glibc Won't fix
Container Status
bci/bci-busybox
bci/bci-init
bci/bci-init:15.3
bci/bci-micro
bci/bci-micro:15.3
bci/bci-minimal
bci/bci-minimal:15.3
bci/dotnet-aspnet
bci/dotnet-aspnet:3.1
bci/dotnet-aspnet:5.0
bci/dotnet-aspnet:6.0
bci/dotnet-runtime
bci/dotnet-runtime:3.1
bci/dotnet-runtime:5.0
bci/dotnet-runtime:6.0
bci/dotnet-sdk
bci/dotnet-sdk:3.1
bci/dotnet-sdk:5.0
bci/dotnet-sdk:6.0
bci/golang
bci/golang:1.16
bci/golang:1.17
bci/golang:1.18
bci/node:12
bci/node:14
bci/nodejs
bci/openjdk
bci/openjdk-devel
bci/openjdk-devel:11
bci/openjdk:11
bci/python
bci/python:3
bci/ruby
bci/rust
bci/rust:1.56
bci/rust:1.59
bci/rust:1.60
bci/rust:1.61
bci/rust:1.62
bci/rust:1.63
bci/rust:1.64
bci/rust:1.65
ses/6/cephcsi/cephcsi
ses/6/rook/ceph
ses/7.1/ceph/grafana
ses/7.1/ceph/haproxy
ses/7.1/ceph/keepalived
ses/7.1/ceph/prometheus-alertmanager
ses/7.1/ceph/prometheus-node-exporter
ses/7.1/ceph/prometheus-server
ses/7.1/ceph/prometheus-snmp_notifier
ses/7.1/cephcsi/cephcsi
ses/7.1/cephcsi/csi-attacher:v3.5.0
ses/7.1/cephcsi/csi-node-driver-registrar:v2.5.1
ses/7.1/cephcsi/csi-provisioner:v3.2.1
ses/7.1/cephcsi/csi-resizer:v1.5.0
ses/7.1/cephcsi/csi-snapshotter:v6.0.1
ses/7.1/rook/ceph
ses/7/ceph/ceph
ses/7/ceph/grafana
ses/7/ceph/prometheus-alertmanager
ses/7/ceph/prometheus-node-exporter
ses/7/ceph/prometheus-server
ses/7/cephcsi/cephcsi
ses/7/cephcsi/csi-attacher:v2.1.0
ses/7/cephcsi/csi-attacher:v3.3.0
ses/7/cephcsi/csi-livenessprobe:v1.1.0
ses/7/cephcsi/csi-node-driver-registrar:v1.2.0
ses/7/cephcsi/csi-node-driver-registrar:v2.3.0
ses/7/cephcsi/csi-provisioner:v1.6.0
ses/7/cephcsi/csi-provisioner:v3.0.0
ses/7/cephcsi/csi-resizer:v0.4.0
ses/7/cephcsi/csi-resizer:v1.3.0
ses/7/cephcsi/csi-snapshotter:v2.1.0
ses/7/cephcsi/csi-snapshotter:v2.1.1
ses/7/cephcsi/csi-snapshotter:v4.2.0
ses/7/prometheus-webhook-snmp
ses/7/rook/ceph
suse/389-ds
suse/manager/4.3/proxy-httpd
suse/manager/4.3/proxy-salt-broker
suse/manager/4.3/proxy-squid
suse/manager/4.3/proxy-ssh
suse/manager/4.3/proxy-tftpd
suse/pcp
suse/postgres
suse/postgres:10
suse/postgres:12
suse/postgres:13
suse/registry
suse/rmt-mariadb
suse/rmt-mariadb-client
suse/rmt-mariadb-client:10.6
suse/rmt-mariadb:10.6
suse/rmt-nginx
suse/rmt-nginx:1.21
suse/rmt-server
suse/rmt-server:2.7
suse/sle-micro-rancher/5.2
suse/sle-micro-rancher/5.3
suse/sle-micro/5.0/toolbox
suse/sle-micro/5.1/toolbox
suse/sle-micro/5.2/toolbox
suse/sle-micro/5.3/toolbox
suse/sle-micro/5.4/toolbox
suse/sle15:15.0
suse/sle15:15.1
suse/sle15:15.2
suse/sle15:15.3
suse/sle15:15.4
suse/sles/15.2/virt-api:0.38.1
suse/sles/15.2/virt-controller:0.38.1
suse/sles/15.2/virt-handler:0.38.1
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.2/virt-operator:0.38.1
suse/sles/15.3/cdi-apiserver:1.37.1
suse/sles/15.3/cdi-cloner:1.37.1
suse/sles/15.3/cdi-controller:1.37.1
suse/sles/15.3/cdi-importer:1.37.1
suse/sles/15.3/cdi-operator:1.37.1
suse/sles/15.3/cdi-uploadproxy:1.37.1
suse/sles/15.3/cdi-uploadserver:1.37.1
suse/sles/15.3/libguestfs-tools:0.45.0
suse/sles/15.3/virt-api:0.45.0
suse/sles/15.3/virt-controller:0.45.0
suse/sles/15.3/virt-handler:0.45.0
suse/sles/15.3/virt-launcher:0.45.0
suse/sles/15.3/virt-operator:0.45.0
suse/sles/15.4/cdi-apiserver:1.43.0
suse/sles/15.4/cdi-cloner:1.43.0
suse/sles/15.4/cdi-controller:1.43.0
suse/sles/15.4/cdi-importer:1.43.0
suse/sles/15.4/cdi-operator:1.43.0
suse/sles/15.4/cdi-uploadproxy:1.43.0
suse/sles/15.4/cdi-uploadserver:1.43.0
suse/sles/15.4/libguestfs-tools:0.49.0
suse/sles/15.4/virt-api:0.49.0
suse/sles/15.4/virt-controller:0.49.0
suse/sles/15.4/virt-handler:0.49.0
suse/sles/15.4/virt-launcher:0.49.0
suse/sles/15.4/virt-operator:0.49.0
suse/sles12sp3
suse/sles12sp4
suse/sles12sp5
trento/trento-db
trento/trento-runner
trento/trento-web
glibcWon't fix


SUSE Timeline for this CVE

CVE page created: Sat Feb 19 11:00:04 2022
CVE page last modified: Fri Jan 20 13:19:30 2023