Upstream information

CVE-2015-3885 at MITRE

Description

Integer overflow in the ljpeg_start function in dcraw 7.00 and earlier allows remote attackers to cause a denial of service (crash) via a crafted image, which triggers a buffer overflow, related to the len variable.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 3.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:L/AC:M/Au:N/C:N/I:P/A:P
Access Vector Network Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None Partial
Availability Impact Partial Partial
SUSE Bugzilla entry: 930683 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libraw-devel >= 0.15.4-9.2
  • libraw-devel-static >= 0.15.4-9.2
  • libraw9 >= 0.15.4-9.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1416
SUSE-SLE-SDK-12-SP2-2017-1416
SUSE-SLE-WE-12-SP2-2017-1416
SUSE Linux Enterprise Desktop 12 SP3
  • libraw-devel >= 0.15.4-9.2
  • libraw-devel-static >= 0.15.4-9.2
  • libraw9 >= 0.15.4-9.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1416
SUSE-SLE-SDK-12-SP3-2017-1416
SUSE-SLE-WE-12-SP3-2017-1416
SUSE Linux Enterprise Desktop 12 SP4
  • libraw-devel >= 0.15.4-21.1
  • libraw-devel-static >= 0.15.4-21.1
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libraw9-0.15.4-21.1
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libraw-devel-0.15.4-21.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libraw9-0.15.4-21.1
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libraw-devel >= 0.15.4-9.2
  • libraw-devel-static >= 0.15.4-9.2
  • libraw9 >= 0.15.4-9.2
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1416
SUSE-SLE-WE-12-SP2-2017-1416
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libraw-devel >= 0.15.4-9.2
  • libraw-devel-static >= 0.15.4-9.2
  • libraw9 >= 0.15.4-9.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1416
SUSE-SLE-WE-12-SP3-2017-1416
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libraw-devel >= 0.15.4-21.1
  • libraw-devel-static >= 0.15.4-21.1
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libraw-devel-0.15.4-21.1
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libraw9-0.15.4-21.1
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libraw-devel >= 0.15.4-30.1
  • libraw-devel-static >= 0.15.4-30.1
  • libraw9 >= 0.15.4-30.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libraw-devel-0.15.4-30.1
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libraw9-0.15.4-30.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libraw-devel >= 0.15.4-9.2
  • libraw-devel-static >= 0.15.4-9.2
  • libraw9 >= 0.15.4-9.2
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1416
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libraw-devel >= 0.15.4-9.2
  • libraw-devel-static >= 0.15.4-9.2
  • libraw9 >= 0.15.4-9.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1416
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libraw-devel >= 0.15.4-21.1
  • libraw-devel-static >= 0.15.4-21.1
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libraw-devel-0.15.4-21.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libraw-devel >= 0.15.4-30.1
  • libraw-devel-static >= 0.15.4-30.1
  • libraw9 >= 0.15.4-30.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA libraw-devel-0.15.4-30.1
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libraw9 >= 0.15.4-9.2
Patchnames:
SUSE-SLE-WE-12-SP2-2017-1416
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libraw9 >= 0.15.4-9.2
Patchnames:
SUSE-SLE-WE-12-SP3-2017-1416
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libraw9 >= 0.15.4-21.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libraw9-0.15.4-21.1
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libraw9 >= 0.15.4-30.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP5 GA libraw9-0.15.4-30.1
openSUSE Tumbleweed
  • darktable >= 2.0.7-1.1
  • darktable-doc >= 2.0.7-1.1
  • rawtherapee >= 5.8-5.1
Patchnames:
openSUSE Tumbleweed GA darktable-2.0.7-1.1
openSUSE Tumbleweed GA rawtherapee-5.8-5.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 netpbm Not affected
SUSE Enterprise Storage 7.1 netpbm Not affected
SUSE Linux Enterprise Desktop 15 SP4 libraw Not affected
SUSE Linux Enterprise Desktop 15 SP4 netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 libraw Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 netpbm Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 netpbm Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 libraw Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 netpbm Not affected
SUSE Linux Enterprise Real Time 15 SP3 netpbm Not affected
SUSE Linux Enterprise Server 12 SP5 dcraw Not affected
SUSE Linux Enterprise Server 12 SP5 libraw Released
SUSE Linux Enterprise Server 12 SP5 netpbm Not affected
SUSE Linux Enterprise Server 12-LTSS netpbm Not affected
SUSE Linux Enterprise Server 15 SP4 libraw Not affected
SUSE Linux Enterprise Server 15 SP4 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 dcraw Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libraw Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 netpbm Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 dcraw Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 libraw Released
SUSE Linux Enterprise Software Development Kit 12 SP5 netpbm Not affected
SUSE Linux Enterprise Workstation Extension 12 SP5 dcraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP5 libraw Released
SUSE Linux Enterprise Workstation Extension 15 SP4 libraw Not affected
SUSE Manager Proxy 4.2 netpbm Not affected
SUSE Manager Proxy 4.3 libraw Not affected
SUSE Manager Proxy 4.3 netpbm Not affected
SUSE Manager Retail Branch Server 4.2 netpbm Not affected
SUSE Manager Retail Branch Server 4.3 libraw Not affected
SUSE Manager Retail Branch Server 4.3 netpbm Not affected
SUSE Manager Server 4.2 netpbm Not affected
SUSE Manager Server 4.3 libraw Not affected
SUSE Manager Server 4.3 netpbm Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS netpbm Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS netpbm Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 netpbm Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 netpbm Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 netpbm Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 netpbm Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 netpbm Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 netpbm Not affected
SUSE Linux Enterprise Server 12 SP2-BCL netpbm Not affected
SUSE Linux Enterprise Server 12 SP4 dcraw Not affected
SUSE Linux Enterprise Server 12 SP4 libraw Affected
SUSE Linux Enterprise Server 12 SP4 netpbm Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS netpbm Not affected
SUSE Linux Enterprise Server 15 SP1 libraw Not affected
SUSE Linux Enterprise Server 15 SP1 netpbm Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS netpbm Not affected
SUSE Linux Enterprise Server 15 SP2 libraw Not affected
SUSE Linux Enterprise Server 15 SP2 netpbm Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS netpbm Not affected
SUSE Linux Enterprise Server 15 SP3 libraw Not affected
SUSE Linux Enterprise Server 15 SP3 netpbm Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS netpbm Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 netpbm Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 dcraw Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libraw Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 15 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 15 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libraw Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 netpbm Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 netpbm Not affected
SUSE CaaS Platform 4.0 netpbm Not affected
SUSE CaaS Platform 4.5 netpbm Not affected
SUSE Enterprise Storage 6 netpbm Not affected
SUSE Linux Enterprise Desktop 11 SP1 dcraw Affected
SUSE Linux Enterprise Desktop 11 SP2 dcraw Released
SUSE Linux Enterprise Desktop 11 SP3 dcraw Released
SUSE Linux Enterprise Desktop 11 SP3 netpbm Not affected
SUSE Linux Enterprise Desktop 11 SP4 dcraw Released
SUSE Linux Enterprise Desktop 11 SP4 netpbm Not affected
SUSE Linux Enterprise Desktop 12 dcraw Affected
SUSE Linux Enterprise Desktop 12 libraw Released
SUSE Linux Enterprise Desktop 12 netpbm Affected
SUSE Linux Enterprise Desktop 12 SP1 dcraw Not affected
SUSE Linux Enterprise Desktop 12 SP1 libraw Affected
SUSE Linux Enterprise Desktop 12 SP1 netpbm Not affected
SUSE Linux Enterprise Desktop 12 SP2 dcraw Not affected
SUSE Linux Enterprise Desktop 12 SP2 libraw Released
SUSE Linux Enterprise Desktop 12 SP2 netpbm Not affected
SUSE Linux Enterprise Desktop 12 SP3 dcraw Not affected
SUSE Linux Enterprise Desktop 12 SP3 libraw Released
SUSE Linux Enterprise Desktop 12 SP3 netpbm Not affected
SUSE Linux Enterprise Desktop 12 SP4 dcraw Not affected
SUSE Linux Enterprise Desktop 12 SP4 libraw Affected
SUSE Linux Enterprise Desktop 12 SP4 netpbm Not affected
SUSE Linux Enterprise Desktop 15 libraw Not affected
SUSE Linux Enterprise Desktop 15 netpbm Not affected
SUSE Linux Enterprise Desktop 15 SP1 libraw Not affected
SUSE Linux Enterprise Desktop 15 SP1 netpbm Not affected
SUSE Linux Enterprise Desktop 15 SP2 libraw Not affected
SUSE Linux Enterprise Desktop 15 SP2 netpbm Not affected
SUSE Linux Enterprise Desktop 15 SP3 libraw Not affected
SUSE Linux Enterprise Desktop 15 SP3 netpbm Not affected
SUSE Linux Enterprise Module for Basesystem 15 netpbm Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 netpbm Not affected
SUSE Linux Enterprise Real Time 15 SP2 netpbm Not affected
SUSE Linux Enterprise Server 11 SP1 netpbm Unsupported
SUSE Linux Enterprise Server 11 SP2 dcraw Released
SUSE Linux Enterprise Server 11 SP3 dcraw Released
SUSE Linux Enterprise Server 11 SP3 netpbm Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS netpbm Not affected
SUSE Linux Enterprise Server 11 SP4 dcraw Affected
SUSE Linux Enterprise Server 11 SP4 netpbm Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS netpbm Not affected
SUSE Linux Enterprise Server 12 dcraw Affected
SUSE Linux Enterprise Server 12 libraw Released
SUSE Linux Enterprise Server 12 netpbm Affected
SUSE Linux Enterprise Server 12 SP1 dcraw Not affected
SUSE Linux Enterprise Server 12 SP1 libraw Affected
SUSE Linux Enterprise Server 12 SP1 netpbm Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS netpbm Not affected
SUSE Linux Enterprise Server 12 SP2 dcraw Not affected
SUSE Linux Enterprise Server 12 SP2 libraw Released
SUSE Linux Enterprise Server 12 SP2 netpbm Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS netpbm Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS netpbm Not affected
SUSE Linux Enterprise Server 12 SP3 dcraw Not affected
SUSE Linux Enterprise Server 12 SP3 libraw Released
SUSE Linux Enterprise Server 12 SP3 netpbm Not affected
SUSE Linux Enterprise Server 12 SP3-BCL netpbm Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS netpbm Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS netpbm Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS netpbm Not affected
SUSE Linux Enterprise Server 15 libraw Not affected
SUSE Linux Enterprise Server 15 netpbm Not affected
SUSE Linux Enterprise Server 15 SP1-BCL netpbm Not affected
SUSE Linux Enterprise Server 15 SP2-BCL netpbm Not affected
SUSE Linux Enterprise Server 15 SP3-BCL netpbm Not affected
SUSE Linux Enterprise Server 15-LTSS netpbm Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 dcraw Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 dcraw Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 dcraw Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 dcraw Affected
SUSE Linux Enterprise Server for SAP Applications 12 libraw Released
SUSE Linux Enterprise Server for SAP Applications 12 netpbm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 dcraw Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libraw Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 dcraw Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libraw Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 netpbm Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 dcraw Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libraw Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 netpbm Not affected
SUSE Linux Enterprise Software Development Kit 11 SP2 dcraw Released
SUSE Linux Enterprise Software Development Kit 11 SP3 dcraw Released
SUSE Linux Enterprise Software Development Kit 11 SP3 netpbm Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 dcraw Affected
SUSE Linux Enterprise Software Development Kit 11 SP4 netpbm Not affected
SUSE Linux Enterprise Software Development Kit 12 dcraw Affected
SUSE Linux Enterprise Software Development Kit 12 libraw Released
SUSE Linux Enterprise Software Development Kit 12 netpbm Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 dcraw Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libraw Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 netpbm Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 dcraw Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libraw Released
SUSE Linux Enterprise Software Development Kit 12 SP2 netpbm Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 dcraw Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libraw Released
SUSE Linux Enterprise Software Development Kit 12 SP3 netpbm Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 dcraw Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libraw Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 netpbm Not affected
SUSE Linux Enterprise Workstation Extension 12 dcraw Not affected
SUSE Linux Enterprise Workstation Extension 12 libraw Released
SUSE Linux Enterprise Workstation Extension 12 SP1 dcraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP1 libraw Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 dcraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP2 libraw Released
SUSE Linux Enterprise Workstation Extension 12 SP3 dcraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP3 libraw Released
SUSE Linux Enterprise Workstation Extension 12 SP4 dcraw Not affected
SUSE Linux Enterprise Workstation Extension 12 SP4 libraw Affected
SUSE Linux Enterprise Workstation Extension 15 libraw Not affected
SUSE Linux Enterprise Workstation Extension 15 SP1 libraw Not affected
SUSE Linux Enterprise Workstation Extension 15 SP2 libraw Not affected
SUSE Linux Enterprise Workstation Extension 15 SP3 libraw Not affected
SUSE Manager Proxy 4.0 netpbm Not affected
SUSE Manager Proxy 4.1 netpbm Not affected
SUSE Manager Retail Branch Server 4.0 netpbm Not affected
SUSE Manager Retail Branch Server 4.1 netpbm Not affected
SUSE Manager Server 4.0 netpbm Not affected
SUSE Manager Server 4.1 netpbm Not affected
SUSE OpenStack Cloud 7 netpbm Not affected
SUSE OpenStack Cloud 8 netpbm Not affected
SUSE OpenStack Cloud 9 netpbm Not affected
SUSE OpenStack Cloud Crowbar 8 netpbm Not affected
SUSE OpenStack Cloud Crowbar 9 netpbm Not affected


SUSE Timeline for this CVE

CVE page created: Tue May 12 21:36:50 2015
CVE page last modified: Fri Jan 20 12:39:52 2023