Upstream information

CVE-2010-1323 at MITRE

Description

MIT Kerberos 5 (aka krb5) 1.3.x, 1.4.x, 1.5.x, 1.6.x, 1.7.x, and 1.8.x through 1.8.3 does not properly determine the acceptability of checksums, which might allow remote attackers to modify user-visible prompt text, modify a response to a Key Distribution Center (KDC), or forge a KRB-SAFE message via certain checksums that (1) are unkeyed or (2) use RC4 keys.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.6
Vector AV:N/AC:H/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 3.7
Vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Attack Vector Network
Attack Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3
SUSE Bugzilla entry: 650650 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
SUSE Linux Enterprise Software Development Kit 11 SP4
  • krb5-devel >= 1.6.3-133.49.66.1
  • krb5-devel-32bit >= 1.6.3-133.49.66.1
  • krb5-server >= 1.6.3-133.49.66.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA krb5-devel-1.6.3-133.49.66.1
SUSE Linux Enterprise Desktop 12 SP1
  • krb5 >= 1.12.1-19.1
  • krb5-32bit >= 1.12.1-19.1
  • krb5-client >= 1.12.1-19.1
  • krb5-devel >= 1.12.1-19.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA krb5-1.12.1-19.1
SUSE Linux Enterprise Software Development Kit 12 SP1 GA krb5-devel-1.12.1-19.1
SUSE Linux Enterprise Desktop 12 SP2
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-devel >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA krb5-1.12.5-39.1
SUSE Linux Enterprise Software Development Kit 12 SP2 GA krb5-devel-1.12.5-39.1
SUSE Linux Enterprise Desktop 12 SP3
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-devel >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA krb5-1.12.5-39.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA krb5-devel-1.12.5-39.1
SUSE Linux Enterprise Desktop 12 SP4
  • krb5 >= 1.12.5-40.28.2
  • krb5-32bit >= 1.12.5-40.28.2
  • krb5-client >= 1.12.5-40.28.2
  • krb5-devel >= 1.12.5-40.28.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA krb5-1.12.5-40.28.2
SUSE Linux Enterprise Software Development Kit 12 SP4 GA krb5-devel-1.12.5-40.28.2
SUSE Linux Enterprise Desktop 12
  • krb5 >= 1.12.1-6.3
  • krb5-32bit >= 1.12.1-6.3
  • krb5-client >= 1.12.1-6.3
  • krb5-devel >= 1.12.1-6.3
Patchnames:
SUSE Linux Enterprise Desktop 12 GA krb5-1.12.1-6.3
SUSE Linux Enterprise Software Development Kit 12 GA krb5-devel-1.12.1-6.3
SUSE Linux Enterprise Desktop 15
SUSE Linux Enterprise Module for Basesystem 15
  • krb5 >= 1.15.2-4.25
  • krb5-32bit >= 1.15.2-4.25
  • krb5-client >= 1.15.2-4.25
  • krb5-devel >= 1.15.2-4.25
  • krb5-plugin-preauth-otp >= 1.15.2-4.25
  • krb5-plugin-preauth-pkinit >= 1.15.2-4.25
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA krb5-1.15.2-4.25
SUSE Linux Enterprise High Performance Computing 12 SP5
  • krb5 >= 1.12.5-40.37.7
  • krb5-32bit >= 1.12.5-40.37.7
  • krb5-client >= 1.12.5-40.37.7
  • krb5-doc >= 1.12.5-40.37.7
  • krb5-plugin-kdb-ldap >= 1.12.5-40.37.7
  • krb5-plugin-preauth-otp >= 1.12.5-40.37.7
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.37.7
  • krb5-server >= 1.12.5-40.37.7
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA krb5-1.12.5-40.37.7
SUSE Linux Enterprise High Performance Computing 15
SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server for SAP Applications 15
  • krb5 >= 1.15.2-4.25
  • krb5-32bit >= 1.15.2-4.25
  • krb5-client >= 1.15.2-4.25
  • krb5-devel >= 1.15.2-4.25
  • krb5-plugin-kdb-ldap >= 1.15.2-4.25
  • krb5-plugin-preauth-otp >= 1.15.2-4.25
  • krb5-plugin-preauth-pkinit >= 1.15.2-4.25
  • krb5-server >= 1.15.2-4.25
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA krb5-1.15.2-4.25
SUSE Linux Enterprise Module for Server Applications 15 GA krb5-plugin-kdb-ldap-1.15.2-4.25
SUSE Linux Enterprise Micro 6.0
  • krb5 >= 1.20.1-4.11
Patchnames:
SUSE Linux Enterprise Micro 6.0 GA krb5-1.20.1-4.11
SUSE Linux Enterprise Module for Server Applications 15
  • krb5-plugin-kdb-ldap >= 1.15.2-4.25
  • krb5-server >= 1.15.2-4.25
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA krb5-plugin-kdb-ldap-1.15.2-4.25
SUSE Linux Enterprise Server 11 SP2
  • krb5 >= 1.6.3-133.48.48.1
  • krb5-32bit >= 1.6.3-133.48.48.1
  • krb5-apps-clients >= 1.6.3-133.48.48.1
  • krb5-apps-servers >= 1.6.3-133.48.48.1
  • krb5-client >= 1.6.3-133.48.48.1
  • krb5-server >= 1.6.3-133.48.48.1
  • krb5-x86 >= 1.6.3-133.48.48.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA krb5-1.6.3-133.48.48.1
SUSE Linux Enterprise Server 11 SP3
  • krb5 >= 1.6.3-133.49.54.1
  • krb5-32bit >= 1.6.3-133.49.54.1
  • krb5-apps-clients >= 1.6.3-133.49.54.1
  • krb5-apps-servers >= 1.6.3-133.49.54.1
  • krb5-client >= 1.6.3-133.49.54.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.54.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.54.1
  • krb5-server >= 1.6.3-133.49.54.1
  • krb5-x86 >= 1.6.3-133.49.54.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA krb5-1.6.3-133.49.54.1
SUSE Linux Enterprise Server 11 SP3 GA krb5-plugin-kdb-ldap-1.6.3-133.49.54.1
SUSE Linux Enterprise Server 11 SP4
  • krb5 >= 1.6.3-133.49.66.1
  • krb5-32bit >= 1.6.3-133.49.66.1
  • krb5-apps-clients >= 1.6.3-133.49.66.1
  • krb5-apps-servers >= 1.6.3-133.49.66.1
  • krb5-client >= 1.6.3-133.49.66.1
  • krb5-devel >= 1.6.3-133.49.66.1
  • krb5-devel-32bit >= 1.6.3-133.49.66.1
  • krb5-plugin-kdb-ldap >= 1.6.3-133.49.66.1
  • krb5-plugin-preauth-pkinit >= 1.6.3-133.49.66.1
  • krb5-server >= 1.6.3-133.49.66.1
  • krb5-x86 >= 1.6.3-133.49.66.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA krb5-1.6.3-133.49.66.1
SUSE Linux Enterprise Server 11 SP4 GA krb5-plugin-kdb-ldap-1.6.3-133.49.66.1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA krb5-devel-1.6.3-133.49.66.1
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • krb5 >= 1.6.3-133.39.1
  • krb5-32bit >= 1.6.3-133.39.1
  • krb5-apps-clients >= 1.6.3-133.39.1
  • krb5-apps-servers >= 1.6.3-133.39.1
  • krb5-client >= 1.6.3-133.39.1
  • krb5-server >= 1.6.3-133.39.1
  • krb5-x86 >= 1.6.3-133.39.1
Patchnames:
slessp0-krb5
SUSE Linux Enterprise Server 12 SP1
  • krb5 >= 1.12.1-19.1
  • krb5-32bit >= 1.12.1-19.1
  • krb5-client >= 1.12.1-19.1
  • krb5-devel >= 1.12.1-19.1
  • krb5-doc >= 1.12.1-19.1
  • krb5-plugin-kdb-ldap >= 1.12.1-19.1
  • krb5-plugin-preauth-otp >= 1.12.1-19.1
  • krb5-plugin-preauth-pkinit >= 1.12.1-19.1
  • krb5-server >= 1.12.1-19.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA krb5-1.12.1-19.1
SUSE Linux Enterprise Software Development Kit 12 SP1 GA krb5-devel-1.12.1-19.1
SUSE Linux Enterprise Server 12 SP2
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-devel >= 1.12.5-39.1
  • krb5-doc >= 1.12.5-39.1
  • krb5-plugin-kdb-ldap >= 1.12.5-39.1
  • krb5-plugin-preauth-otp >= 1.12.5-39.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-39.1
  • krb5-server >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA krb5-1.12.5-39.1
SUSE Linux Enterprise Software Development Kit 12 SP2 GA krb5-devel-1.12.5-39.1
SUSE Linux Enterprise Server 12 SP3
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-devel >= 1.12.5-39.1
  • krb5-doc >= 1.12.5-39.1
  • krb5-plugin-kdb-ldap >= 1.12.5-39.1
  • krb5-plugin-preauth-otp >= 1.12.5-39.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-39.1
  • krb5-server >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA krb5-1.12.5-39.1
SUSE Linux Enterprise Software Development Kit 12 SP3 GA krb5-devel-1.12.5-39.1
SUSE Linux Enterprise Server 12 SP4
  • krb5 >= 1.12.5-40.28.2
  • krb5-32bit >= 1.12.5-40.28.2
  • krb5-client >= 1.12.5-40.28.2
  • krb5-devel >= 1.12.5-40.28.2
  • krb5-doc >= 1.12.5-40.28.2
  • krb5-plugin-kdb-ldap >= 1.12.5-40.28.2
  • krb5-plugin-preauth-otp >= 1.12.5-40.28.2
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.28.2
  • krb5-server >= 1.12.5-40.28.2
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA krb5-1.12.5-40.28.2
SUSE Linux Enterprise Software Development Kit 12 SP4 GA krb5-devel-1.12.5-40.28.2
SUSE Linux Enterprise Server 12 SP5
  • krb5 >= 1.12.5-40.37.7
  • krb5-32bit >= 1.12.5-40.37.7
  • krb5-client >= 1.12.5-40.37.7
  • krb5-devel >= 1.12.5-40.37.7
  • krb5-doc >= 1.12.5-40.37.7
  • krb5-plugin-kdb-ldap >= 1.12.5-40.37.7
  • krb5-plugin-preauth-otp >= 1.12.5-40.37.7
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.37.7
  • krb5-server >= 1.12.5-40.37.7
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA krb5-1.12.5-40.37.7
SUSE Linux Enterprise Software Development Kit 12 SP5 GA krb5-devel-1.12.5-40.37.7
SUSE Linux Enterprise Server 12
  • krb5 >= 1.12.1-6.3
  • krb5-32bit >= 1.12.1-6.3
  • krb5-client >= 1.12.1-6.3
  • krb5-devel >= 1.12.1-6.3
  • krb5-doc >= 1.12.1-6.3
  • krb5-plugin-kdb-ldap >= 1.12.1-6.3
  • krb5-plugin-preauth-otp >= 1.12.1-6.3
  • krb5-plugin-preauth-pkinit >= 1.12.1-6.3
  • krb5-server >= 1.12.1-6.3
Patchnames:
SUSE Linux Enterprise Server 12 GA krb5-1.12.1-6.2
SUSE Linux Enterprise Software Development Kit 12 GA krb5-devel-1.12.1-6.3
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • krb5 >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-doc >= 1.12.5-39.1
  • krb5-plugin-kdb-ldap >= 1.12.5-39.1
  • krb5-plugin-preauth-otp >= 1.12.5-39.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-39.1
  • krb5-server >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA krb5-1.12.5-39.1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
SUSE Linux Enterprise Software Development Kit 12 SP1
  • krb5-devel >= 1.12.1-19.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA krb5-devel-1.12.1-19.1
SUSE Linux Enterprise Server for SAP Applications 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP2
  • krb5-devel >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA krb5-devel-1.12.5-39.1
SUSE Linux Enterprise Server for SAP Applications 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP3
  • krb5-devel >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA krb5-devel-1.12.5-39.1
SUSE Linux Enterprise Server for SAP Applications 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP4
  • krb5-devel >= 1.12.5-40.28.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA krb5-devel-1.12.5-40.28.2
SUSE Linux Enterprise Server for SAP Applications 12 SP5
SUSE Linux Enterprise Software Development Kit 12 SP5
  • krb5-devel >= 1.12.5-40.37.7
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA krb5-devel-1.12.5-40.37.7
SUSE Linux Enterprise Server for SAP Applications 12
SUSE Linux Enterprise Software Development Kit 12
  • krb5-devel >= 1.12.1-6.3
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA krb5-devel-1.12.1-6.3
openSUSE Leap 15.0
  • krb5 >= 1.15.2-lp150.4.4
  • krb5-32bit >= 1.15.2-lp150.4.4
  • krb5-server >= 1.15.2-lp150.4.4
Patchnames:
openSUSE Leap 15.0 GA krb5-1.15.2-lp150.4.4
openSUSE Tumbleweed
  • krb5 >= 1.15-1.1
  • krb5-32bit >= 1.15-1.1
  • krb5-client >= 1.15-1.1
  • krb5-devel >= 1.15-1.1
  • krb5-devel-32bit >= 1.15-1.1
  • krb5-doc >= 1.15-1.1
  • krb5-mini >= 1.15-1.1
  • krb5-mini-devel >= 1.15-1.1
  • krb5-plugin-kdb-ldap >= 1.15-1.1
  • krb5-plugin-preauth-otp >= 1.15-1.1
  • krb5-plugin-preauth-pkinit >= 1.15-1.1
  • krb5-server >= 1.15-1.1
Patchnames:
openSUSE-Tumbleweed-2024-10004


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP5 krb5 Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP5 krb5 Already fixed
SUSE Linux Enterprise Micro 5.5 krb5 Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP5 krb5 Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP5 krb5 Already fixed
SUSE Linux Enterprise Server 15 SP5 krb5 Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 krb5 Already fixed
openSUSE Leap 15.5 krb5 Already fixed
openSUSE Leap Micro 5.5 krb5 Already fixed
Products past their end of life and not receiving proactive updates anymore.
SLES for SAP Applications 11 SP2 krb5 Released
SLES for SAP Applications 11 SP3 krb5 Released
SUSE Linux Enterprise Desktop 11 krb5 Released
SUSE Linux Enterprise Desktop 11 SP1 krb5 Released
SUSE Linux Enterprise Desktop 11 SP2 krb5 Released
SUSE Linux Enterprise Desktop 11 SP3 krb5 Released
SUSE Linux Enterprise Desktop 11 SP4 krb5 Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search krb5 Released
SUSE Linux Enterprise Point of Sale 11 SP3 krb5 Affected
SUSE Linux Enterprise Server 10 SP4-LTSS krb5 Affected
SUSE Linux Enterprise Server 11 krb5 Released
SUSE Linux Enterprise Server 11 SP1 krb5 Released
SUSE Linux Enterprise Server 11 SP1 LTSS krb5 Released
SUSE Linux Enterprise Server 11 SP1-LTSS krb5 Affected
SUSE Linux Enterprise Server 11 SP2 krb5 Released
SUSE Linux Enterprise Server 11 SP2 LTSS krb5 Released
SUSE Linux Enterprise Server 11 SP2-LTSS krb5 Affected
SUSE Linux Enterprise Server 11 SP3 krb5 Released
SUSE Linux Enterprise Server 11 SP3 LTSS krb5 Released
SUSE Linux Enterprise Server 11 SP3-LTSS krb5 Affected
SUSE Linux Enterprise Server 11 SP4 krb5 Released
SUSE Linux Enterprise Server 11 SP4 LTSS krb5 Released
SUSE Linux Enterprise Server 11 SP4-LTSS krb5 Released
SUSE Linux Enterprise Server for SAP Applications 11 krb5 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP1 krb5 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 krb5 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 krb5 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP4 krb5 Released
SUSE Linux Enterprise Server for SAP Business All-in-One 11 SP1 krb5 Released
SUSE Linux Enterprise Software Development Kit 11 krb5 Released
SUSE Linux Enterprise Software Development Kit 11 SP1 krb5 Released
SUSE Linux Enterprise Software Development Kit 11 SP2 krb5 Released
SUSE Linux Enterprise Software Development Kit 11 SP3 krb5 Released
SUSE Linux Enterprise Software Development Kit 11 SP4 krb5 Released


SUSE Timeline for this CVE

CVE page created: Fri Jun 28 07:38:30 2013
CVE page last modified: Fri Jul 19 16:33:22 2024