Security update for the Linux Kernel (Live Patch 40 for SLE 15 SP3)

Announcement ID: SUSE-SU-2024:0394-1
Rating: important
References:
Cross-References:
CVSS scores:
  • CVE-2023-1829 ( SUSE ): 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
  • CVE-2023-1829 ( NVD ): 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Affected Products:
  • openSUSE Leap 15.3
  • SUSE Linux Enterprise High Performance Computing 15 SP3
  • SUSE Linux Enterprise Live Patching 15-SP3
  • SUSE Linux Enterprise Micro 5.1
  • SUSE Linux Enterprise Micro 5.2
  • SUSE Linux Enterprise Server 15 SP3
  • SUSE Linux Enterprise Server for SAP Applications 15 SP3

An update that solves one vulnerability can now be installed.

Description:

This update for the Linux Kernel 5.3.18-150300_59_147 fixes one issue.

The following security issue was fixed:

  • CVE-2023-1829: Fixed a use-after-free vulnerability in the control index filter (tcindex) (bsc#1210619).

Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Live Patching 15-SP3
    zypper in -t patch SUSE-SLE-Module-Live-Patching-15-SP3-2024-394=1
  • openSUSE Leap 15.3
    zypper in -t patch SUSE-2024-394=1

Package List:

  • SUSE Linux Enterprise Live Patching 15-SP3 (ppc64le s390x x86_64)
    • kernel-livepatch-5_3_18-150300_59_147-default-2-150300.2.1
  • openSUSE Leap 15.3 (ppc64le s390x x86_64)
    • kernel-livepatch-5_3_18-150300_59_147-default-debuginfo-2-150300.2.1
    • kernel-livepatch-5_3_18-150300_59_147-default-2-150300.2.1
    • kernel-livepatch-SLE15-SP3_Update_40-debugsource-2-150300.2.1
  • openSUSE Leap 15.3 (x86_64)
    • kernel-livepatch-5_3_18-150300_59_147-preempt-debuginfo-2-150300.2.1
    • kernel-livepatch-5_3_18-150300_59_147-preempt-2-150300.2.1

References: